所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

NE40E V800R010C00 配置指南 - 用户接入 01

评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置按L2TP隧道进行QoS调度的用户接入示例

配置按L2TP隧道进行QoS调度的用户接入示例

介绍一个按L2TP隧道QoS调度的配置示例,结合配置组网图来理解业务的配置过程。配置示例包括组网需求、思路准备、操作步骤和配置文件。

组网需求

图10-11所示,NE40E作为L2TP隧道的LNS设备。VPN用户访问公司总部的过程如下:

  • 用户以普通的上网方式进行拨号上网。

  • 在接入服务器(NAS)处对用户进行验证,发现是VPN用户,则由接入服务器向LNS发起隧道连接的请求。

  • 在接入服务器与LNS隧道建立后,接入服务器把与VPN用户已经协商的内容作为报文内容传给LNS。

  • LNS再根据预协商的内容决定是否接受此连接。

  • 用户与公司总部间的通信通过接入服务器与LNS之间的隧道传输。

  • 用户通过域doma1接入,从地址池pool1获取地址。

要求对LNS配置按隧道L2TP QoS调度。同一隧道下多个用户上线,域下所有用户共享100M保证带宽和200M峰值带宽。

图10-11  按L2TP隧道进行QoS调度的用户接入组网图

配置思路

配置LNS的思路如下:

  1. 配置LAC

  2. 配置LNS,此时NE40E作为LNS设备

  3. 配置调度模板和QoS模板

  4. 在域下应用QoS模板

  5. 配置L2TP组按隧道进行L2TP QoS调度

数据准备

为完成此配置例,需准备如下的数据:

  • Loopback地址

  • 地址池名称、地址池网段和地址池网关

  • 用户所在域的域名

  • 调度模板名,QoS模板名

操作步骤

  1. 用户侧的配置

    在用户侧,在拨号网络窗口中输入VPN用户名vpdnuser@doma1,口令1qaz@WSX,拨入号码为170。在拨号后弹出的拨号终端窗口中输入用于RADIUS验证的用户名username和口令Userpass0。

  2. NAS侧的配置

    配置过程略,配置过程请参看相关产品手册。

    以NAS接入服务器作为LAC侧设备。

    # 在NAS上配置拨入号码为170。

    # 在RADIUS服务器上设置一个用户名为username、口令为Userpass0的VPN用户,并设置相应的LNS侧设备的IP地址(本例中,LNS侧的IP地址为192.168.0.1)。

    # 将本端的设备名称定义为lac,需要进行隧道验证,隧道验证密码为1qaz#EDC。

  3. NE40E(LNS侧)的配置

    # 创建并配置虚拟接口模板。

    <Device> system-view
    [~Device] interface virtual-template 1
    [*Device-Virtual-Template1] ppp authentication-mode chap
    [*Device-Virtual-Template1] commit
    [~Device-Virtual-Template1] quit

    # 使能L2TP服务,创建一个L2TP组。

    [~Device] l2tp enable
    [~Device] l2tp-group lns1

    # 配置LNS侧的L2TP连接。

    [*Device-l2tp-lns1] tunnel name LNS
    [*Device-l2tp-lns1] allow l2tp virtual-template 1 remote lac

    # 启用隧道验证并设置隧道验证密码。

    [*Device-l2tp-lns1] tunnel authentication
    [*Device-l2tp-lns1] tunnel password simple 1qaz#EDC
    [*Device-l2tp-lns1] commit
    [~Device-l2tp-lns1] quit

    # 定义一个地址池,为拨入用户分配地址。

    [~Device] ip pool pool1 bas local
    [*Device-ip-pool-pool1] gateway 10.10.10.1 255.255.255.0
    [*Device-ip-pool-pool1] section 0 10.10.10.2 10.10.10.100
    [*Device-ip-pool-pool1] commit
    [~Device-ip-pool-pool1] quit

    # 配置RADIUS服务器。

    [~Device] radius-server group radius1
    [*Device-radius-radius1] radius-server authentication 20.20.20.1 1812
    [*Device-radius-radius1] radius-server accounting 20.20.20.1 1813
    [*Device-radius-radius1] radius-server shared-key itellin
    [*Device-radius-radius1] commit
    [~Device-radius-radius1] quit

    # 配置doma1域。

    [~Device] aaa
    [*Device-aaa] domain doma1
    [*Device-aaa-domain-domain1] radius-server group radius1
    [*Device-aaa-domain-doma1] authentication-scheme default1
    [*Device-aaa-domain-doma1] accounting-scheme default1
    [*Device-aaa-domain-doma1] ip-pool pool1
    [*Device-aaa-domain-doma1] commit
    [~Device-aaa-domain-doma1] quit
    [~Device-aaa] quit

    # 配置LNS侧接口地址。

    [~Device] interface loopback0
    [*Device-LoopBack0] ip address 192.168.0.1 255.255.255.255
    [*Device-LoopBack0] commit
    [~Device-LoopBack0] quit

    # 创建LNS组group1。

    [~Device] lns-group group1

    # 为LNS组绑定隧道板1。

    [Device-lns-group-group1] bind slot 1 

    # 为LNS组绑定接口。

    [*Device-lns-group-group1] bind source loopback0
    [*Device-lns-group-group1] commit
    [~Device-lns-group-group1] quit

  4. 配置QoS模板

    # 配置QoS模板。

    [~Device] qos-profile pro1
    [*Device-qos-pro1] user-queue cir 100000 pir 200000 inbound
    [*Device-qos-pro1] user-queue cir 100000 pir 200000 outbound
    [*Device-qos-pro1] commit
    [~Device-qos-pro1] quit

  5. 在域下绑定QoS模板

    [~Device] aaa
    [*Device-aaa] domain doma1
    [*Device-aaa-domain-doma1] qos-profile pro1 inbound lns-gts
    [*Device-aaa-domain-doma1] commit
    [~Device-aaa-domain-doma1] quit
    [~Device-aaa] quit

  6. 在L2TP组下配置调度方式为按隧道调度

    [~Device] l2tp-group lns1
    [*Device-l2tp-lns1] qos scheduling-mode tunnel
    [*Device-l2tp-lns1] commit
    [~Device-l2tp-lns1] quit

  7. 检查配置结果

    在LNS上执行命令display l2tp-group,可以查看到L2TP组配置使用的QoS调度方式为tunnel

    <Device> display l2tp-group lns1                                                
     -----------------------------------------------                                
     L2tp-index      : 3                                                            
     Group-Name      : lns1                                                            
     .........
     QOS-mode        : tunnel                                                   
     .........
     -----------------------------------------------                                

    执行命令display domain可以查看到L2TP用户使用QoS模板名称为pro1。

    <Device> display domain doma1                                                
     ------------------------------------------------------------------------------
      Domain-name                     : doma1                                       
      Domain-state                    : Active                                      
    ...............
      L2TP-QosProfile-inbound         : pro1                                        
    ...............
      ------------------------------------------------------------------------------

配置文件

#
 sysname Device
#
 l2tp enable
#
radius-server group radius1
 radius-server authentication 20.20.20.1 1812 
 radius-server accounting 20.20.20.1 1813 
 radius-server shared-key itellin
#
qos-profile pro1
 user-queue cir 100000 pir 200000 inbound
 user-queue cir 100000 pir 200000 outbound
#
interface Virtual-Template1
 ppp authentication-mode chap 
#
interface GigabitEthernet1/0/0
 undo shutdown 
#
interface GigabitEthernet1/0/0.2
 pppoe-server bind Virtual-Template 1
 user-vlan 270 277
 undo shutdown 
 bas
  access-type layer2-subscriber
#
interface loopback0
 ip address 192.168.0.1 255.255.255.255
#
l2tp-group lns1
 allow l2tp virtual-template 1 remote lac
 tunnel password simple 1qaz#EDC
 tunnel name LNS
 qos scheduling-mode tunnel
#
lns-group group1
 bind slot 1 
 bind source loopback0
#
ip pool pool1 bas local
 gateway 10.10.10.1 255.255.255.0
 section 0 10.10.10.2 10.10.10.100
#
aaa
domain  doma1 
  radius-server group  radius1
 authentication-scheme   default1
 accounting-scheme   default1
 ip-pool   pool1
 qos-profile pro1 inbound lns-gts
#
return
下载文档
更新时间:2018-07-12

文档编号:EDOC1100028564

浏览量:15973

下载量:204

平均得分:
本文档适用于这些产品
相关文档
相关版本
分享
上一页 下一页