所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

NE40E V800R010C00 配置指南 - 用户接入 01

评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置L2TP隧道负载分担示例

配置L2TP隧道负载分担示例

介绍一个L2TP隧道负载分担的配置示例,结合配置组网图来理解业务的配置过程。配置示例包括组网需求、思路准备、操作步骤和配置文件。

组网需求

图10-13所示,由于性能问题,单个LNS不能完全承载所有的L2TP业务,可以使用LNS负载均衡功能,把业务按权重分配到多个LNS进行处理。

图10-13  配置L2TP负载分担组网图

配置思路

配置LAC侧的L2TP连接时,L2TP组配置两个LNS,指定LNS的IP地址和权重。

  1. 在用户侧进行拨号配置

  2. 配置LAC(在LAC侧配置L2TP连接时,配置两个LNS地址,按权重进行负载分担)

  3. 配置LNS

数据准备

为完成此配置例,需准备如下的数据:

  • PC1用户名、口令

  • 隧道的密码、LNS侧本端名称和远端名称

  • 虚拟接口模板编号及L2TP组编号

  • 远端地址池编号、范围及掩码

说明:

本节只列出了与L2TP相关的配置步骤。

操作步骤

  1. 用户侧的配置

    建立一个拨号网络,号码为DeviceA的接入号码,接收由LNS服务器端分配的地址。

    对于PC1而言,在弹出的拨号终端窗口中输入用户名user1@isp1,口令(此用户名与口令已在LNS中注册)。

  2. DeviceA(LAC侧)的配置

    # 配置虚模板接口1。

    <Device> system-viewDevice] sysname DeviceA
    [*DeviceA] interface virtual-template 1
    [*DeviceA-Virtual-Template1] ppp authentication-mode chap
    [*DeviceA-Virtual-Template1] commit
    [~DeviceA-Virtual-Template1] quit

    # 在GE 2/0/0.100接口上绑定虚模板接口1。

    [~DeviceA] interface gigabitethernet 2/0/0.100
    [*DeviceA-GigabitEthernet2/0/0.100] pppoe-server bind virtual-template 1
    [*DeviceA-GigabitEthernet2/0/0.100] user-vlan 1 100
    [*DeviceA-GigabitEthernet2/0/0.100-vlan-1-100] commit
    [~DeviceA-GigabitEthernet2/0/0.100-vlan-1-100] quit

    # 配置BAS接口。

    [~DeviceA-GigabitEthernet2/0/0.100] bas
    [*DeviceA-GigabitEthernet2/0/0.100-bas] access-type layer2-subscriber
    [*DeviceA-GigabitEthernet2/0/0.100-bas] authentication-method ppp
    [*DeviceA-GigabitEthernet2/0/0.100-bas] commit
    [~DeviceA-GigabitEthernet2/0/0.100-bas] quit
    [~DeviceA-GigabitEthernet2/0/0.100] quit

    # 创建环回接口。

    [~DeviceA] interface loopback0
    [*DeviceA-LoopBack0] ip address 1.1.1.1 255.255.255.255
    [*DeviceA-LoopBack0] commit
    [~DeviceA-LoopBack0] quit

    # 配置隧道物理接口IP地址。

    [~DeviceA] interface gigabitethernet1/0/1
    [*DeviceA-GigabitEthernet1/0/1] ip address 11.11.11.1 255.255.255.0
    [*DeviceA-GigabitEthernet1/0/1] commit
    [~DeviceA-GigabitEthernet1/0/1] quit
    [~DeviceA] interface gigabitethernet1/0/2
    [*DeviceA-GigabitEthernet1/0/2] ip address 12.12.12.1 255.255.255.0
    [*DeviceA-GigabitEthernet1/0/2] commit
    [~DeviceA-GigabitEthernet1/0/2] quit

    # 设置L2TP组创建负载分担的隧道连接,并配置相关属性。

    [~DeviceA] l2tp enable
    [~DeviceA] l2tp-group lac1
    [*DeviceA-l2tp-lac1] tunnel name lac1
    [*DeviceA-l2tp-lac1] start l2tp ip 3.3.3.3 ip 4.4.4.4
    [*DeviceA-l2tp-lac1] tunnel load-sharing
    [*DeviceA-l2tp-lac1] tunnel authentication
    [*DeviceA-l2tp-lac1] tunnel password simple 1qaz#EDC
    [*DeviceA-l2tp-lac1] tunnel source loopback0
    [*DeviceA-l2tp-lac1] commit
    [~DeviceA-l2tp-lac1] quit

    # 配置RADIUS服务器。

    [~DeviceA] radius-server group radius1
    [*DeviceA-radius-radius1] radius-server authentication 20.20.20.1 1812
    [*DeviceA-radius-radius1] radius-server accounting 20.20.20.1 1813
    [*DeviceA-radius-radius1] radius-server shared-key itellin
    [*DeviceA-radius-radius1] commit
    [~DeviceA-radius-radius1] quit

    # 配置用户所在域。

    [~DeviceA] aaa
    [*DeviceA-aaa] domain isp1
    [*DeviceA-aaa-domain-isp1] l2tp-group lac1
    [*DeviceA-aaa-domain-isp1] radius-server group radius1
    [*DeviceA-aaa-domain-isp1] authentication-scheme default1
    [*DeviceA-aaa-domain-isp1] accounting-scheme default1
    [*DeviceA-aaa-domain-isp1] commit
    [~DeviceA-aaa-domain-isp1] quit

    # 配置路由。

    [~DeviceA] ip route-static 3.3.3.3 255.255.255.255 11.11.11.2
    [~DeviceA] ip route-static 4.4.4.4 255.255.255.255 12.12.12.2

  3. DeviceB(LNS侧)的配置

    # 创建环回接口。

    [~DeviceB] interface loopback0
    [*DeviceB-LoopBack0] ip address 3.3.3.3 255.255.255.255
    [*DeviceB-LoopBack0] commit
    [~DeviceB-LoopBack0] quit 

    # 配置隧道物理接口IP地址。

    [~DeviceB] interface gigabitethernet1/0/1
    [*DeviceB-GigabitEthernet1/0/1] ip address 11.11.11.2 255.255.255.0
    [*DeviceB-GigabitEthernet1/0/1] commit
    [~DeviceB-GigabitEthernet1/0/1] quit

    # 创建虚模板接口1。

    [~DeviceB] interface virtual-template 1
    [*DeviceB-Virtual-Template1] ppp authentication-mode chap
    [*DeviceB-Virtual-Template1] commit
    [~DeviceB-Virtual-Template1] quit

    # 使能L2TP服务,并配置L2TP组。

    [~DeviceB] l2tp enable
    [~DeviceB] l2tp-group lns1
    [*DeviceB-l2tp-lns1] tunnel name lns1
    [*DeviceB-l2tp-lns1] allow l2tp virtual-template 1 remote lac1
    [*DeviceB-l2tp-lns1] tunnel authentication
    [*DeviceB-l2tp-lns1] tunnel password simple 1qaz#EDC
    [*DeviceB-l2tp-lns1] commit
    [~DeviceB-l2tp-lns1] quit

    # 创建并配置LNS组group1。

    [~DeviceB] lns-group group1
    [*DeviceB-lns-group-group1] bind slot 1 
    [*DeviceB-lns-group-group1] bind source loopback 0
    [*DeviceB-lns-group-group1] commit
    [~DeviceB-lns-group-group1] quit

    # 配置给用户分配的地址池。

    [~DeviceB] ip pool pool1 bas local
    [*DeviceB-ip-pool-pool1] gateway 10.10.0.1 255.255.255.0
    [*DeviceB-ip-pool-pool1] section 0 10.10.0.10 10.10.0.100
    [*DeviceB-ip-pool-pool1] commit
    [~DeviceB-ip-pool-pool1] quit

    # 配置RADIUS服务器。

    [~DeviceB] radius-server group radius1
    [*DeviceB-radius-radius1] radius-server authentication 10.10.0.249 1812
    [*DeviceB-radius-radius1] radius-server accounting 10.10.0.249 1813
    [*DeviceB-radius-radius1] radius-server shared-key itellin
    [*DeviceB-radius-radius1] commit
    [~DeviceB-radius-radius1] quit

    # 配置用户所在域。

    [~DeviceB] aaa
    [*DeviceB-aaa] domain isp1
    [*DeviceB-aaa-domain-isp1] authentication-scheme default1
    [*DeviceB-aaa-domain-isp1] accounting-scheme default1
    [*DeviceB-aaa-domain-isp1] radius-server group radius1
    [*DeviceB-aaa-domain-isp1] ip-pool pool1
    [*DeviceB-aaa-domain-isp1] commit
    [~DeviceB-aaa-domain-isp1] quit
    [~DeviceB-aaa] quit

    # 配置路由。

    [~DeviceB] ip route-static 1.1.1.1 255.255.255.255 11.11.11.1

  4. DeviceC(LNS侧)的配置

    # 创建环回接口。

    [~DeviceC] interface loopback1
    [*DeviceC-LoopBack1] ip address 4.4.4.4 255.255.255.255
    [*DeviceC-LoopBack1] commit
    [~DeviceC-LoopBack1] quit

    # 配置隧道物理接口IP地址。

    [~DeviceC] interface gigabitethernet1/0/1
    [~DeviceC--GigabitEthernet1/0/1] ip address 12.12.12.2 255.255.255.0

    # 创建虚模板接口1。

    [~DeviceC] interface virtual-template 1
    [*DeviceC-Virtual-Template1] ppp authentication-mode chap
    [*DeviceC-Virtual-Template1] commit
    [~DeviceC-Virtual-Template1] quit

    # 使能L2TP服务,并配置L2TP组。

    [~DeviceC] l2tp enable
    [~DeviceC] l2tp-group lns1
    [*DeviceC-l2tp-lns1] tunnel name lns1
    [*DeviceC-l2tp-lns1] allow l2tp virtual-template 1 remote lac1
    [*DeviceC-l2tp-lns1] tunnel authentication
    [*DeviceC-l2tp-lns1] tunnel password simple 1qaz#EDC
    [*DeviceC-l2tp-lns1] commit
    [~DeviceC-l2tp-lns1] quit

    # 创建并配置LNS组group1。

    [~DeviceC] lns-group group1
    [*DeviceC-lns-group-group1] bind slot 1 
    [*DeviceC-lns-group-group1] bind source loopback 1
    [*DeviceC-lns-group-group1] commit
    [~DeviceC-lns-group-group1] quit

    # 配置给用户分配的地址池。

    [~DeviceC] ip pool pool1 bas local
    [*DeviceC-ip-pool-pool1] gateway 10.10.0.101 255.255.255.0
    [*DeviceC-ip-pool-pool1] section 0 10.10.0.102 10.10.0.200
    [*DeviceC-ip-pool-pool1] commit
    [~DeviceC-ip-pool-pool1] quit

    # 配置RADIUS服务器。

    [~DeviceC] radius-server group radius1
    [*DeviceC-radius-radius1] radius-server authentication 10.10.0.249 1812
    [*DeviceC-radius-radius1] radius-server accounting 10.10.0.249 1813
    [*DeviceC-radius-radius1] radius-server shared-key itellin
    [*DeviceC-radius-radius1] commit
    [~DeviceC-radius-radius1] quit

    # 配置用户所在域。

    [~DeviceC] aaa
    [*DeviceC-aaa] domain isp1
    [*DeviceC-aaa-domain-isp1] authentication-scheme default1
    [*DeviceC-aaa-domain-isp1] accounting-scheme default1
    [*DeviceC-aaa-domain-isp1] radius-server group radius1
    [*DeviceC-aaa-domain-isp1] ip-pool pool1
    [*DeviceC-aaa-domain-isp1] commit
    [~DeviceC-aaa-domain-isp1] quit
    [~DeviceC-aaa] quit

    # 配置路由。

    [~DeviceC] ip route-static 1.1.1.1 255.255.255.255 12.12.12.1

  5. 检查配置结果

    [~DeviceA] test l2tp-tunnel l2tp-group lac1 ip-address 3.3.3.3
    Testing L2TP tunnel connectivity now....... 
    Test L2TP tunnel connectivity success.
    [~DeviceA] test l2tp-tunnel l2tp-group lac1 ip-address 4.4.4.4
    Testing L2TP tunnel connectivity now....... 
    Test L2TP tunnel connectivity success.

配置文件

  • DeviceA的配置文件

    #
     sysname DeviceA
    #
     l2tp enable
    #
    radius-server group radius1
     radius-server authentication 20.20.20.1 1812 
     radius-server accounting 20.20.20.1 1813 
     radius-server shared-key itellin
    #
    interface Virtual-Template1
    ppp authentication-mode chap
    #
    interface GigabitEthernet2/0/0
     pppoe-server bind Virtual-Template 1
     undo shutdown
     bas
      access-type layer2-subscriber
    #
    interface LoopBack0
     ip address 1.1.1.1 255.255.255.255
    #
    l2tp-group lac1
     tunnel password simple 1qaz#EDC
     tunnel name lac1
     start l2tp ip 3.3.3.3 ip 4.4.4.4 weight 5
     tunnel load-sharing
     tunnel source LoopBack0
    #
    aaa
    domain isp1
      authentication-scheme default1
      accounting-scheme default1
      radius-server group radius1
      l2tp-group lac1
    #
    interface GigabitEthernet1/0/1
     undo shutdown
     ip address 11.11.11.1 255.255.255.0
    #
    interface GigabitEthernet1/0/2
     undo shutdown
     ip address 12.12.12.1 255.255.255.0
    #
     ip route-static 3.3.3.3 255.255.255.255 11.11.11.2
     ip route-static 4.4.4.4 255.255.255.255 12.12.12.2
    #
    return
  • DeviceB的配置文件

    #
     sysname DeviceB
    #
     l2tp enable
    #
    interface Virtual-Template1
    ppp authentication-mode chap
    #
    interface LoopBack0
     ip address 3.3.3.3 255.255.255.255
    #
    l2tp-group lns1
     allow l2tp virtual-template 1 remote lac1
     tunnel password simple 1qaz#EDC
     tunnel name lns1
    #
    lns-group group1
     bind slot 1 
     bind source LoopBack0
    #
    ip pool pool1 bas local
     gateway 10.10.0.1 255.255.255.0
     section 0 10.10.0.2 10.10.0.100
    #
    aaa
     domain  isp1
      authentication-scheme   default1
      accounting-scheme   default1
      ip-pool   pool1
    #
    interface GigabitEthernet1/0/1
     undo shutdown
     ip address 11.11.11.2 255.255.255.0
    #
     ip route-static  1.1.1.1 255.255.255.255 11.11.11.1
    #
    return
  • DeviceC的配置文件

    #
     sysname DeviceC
    #
     l2tp enable
    #
    interface Virtual-Template1
    ppp authentication-mode chap
    #
    interface LoopBack1
     ip address 4.4.4.4 255.255.255.255
    #
    l2tp-group lns1
     allow l2tp virtual-template 1 remote lac1
     tunnel password simple 1qaz#EDC
     tunnel name lns1
    #
    lns-group group1
     bind slot 1 
     bind source LoopBack1
    #
    ip pool pool1 bas local
     gateway 10.10.0.101 255.255.255.0
     section 0 10.10.0.102 10.10.0.200
    #
    aaa
    domain  isp1
      authentication-scheme   default1
      accounting-scheme   default1
      ip-pool   pool1
    #
    interface GigabitEthernet1/0/1
     undo shutdown
     ip address 12.12.12.2 255.255.255.0
    #
     ip route-static  1.1.1.1 255.255.255.255 12.12.12.1
    #
    return
下载文档
更新时间:2018-07-12

文档编号:EDOC1100028564

浏览量:16222

下载量:205

平均得分:
本文档适用于这些产品
相关文档
相关版本
分享
上一页 下一页