所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

NE40E V800R010C00 配置指南 - 用户接入 01

评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置在VPN上建立L2TP隧道的用户接入示例

配置在VPN上建立L2TP隧道的用户接入示例

介绍一个在VPN上建立L2TP隧道的配置示例,结合配置组网图来理解业务的配置过程。配置示例包括组网需求、思路准备、操作步骤和配置文件。

组网需求

图10-14所示,运营商不希望使用公网地址建立L2TP隧道(由于公网地址有限),所以希望L2TP隧道的地址都采用私网地址,这样可以减少L2TP隧道对公网地址的占用。

图10-14  在VPN上建立L2TP隧道的用户接入组网图
说明:

本例中interface1、interface2、interface3代表GE 1/0/1、GE2/0/0.100、GE1/0/2



设备 隧道接口 IP地址 环回接口 IP地址
DeviceA GE 1/0/1 10.0.0.1/24 loopback0 1.1.1.1
DeviceB GE 1/0/1 10.0.0.2/24 loopback0 3.3.3.3
DeviceB GE 1/0/2 10.10.0.2/24 loopback1 4.4.4.4
DeviceC GE 1/0/1 10.10.0.1/24 loopback1 2.2.2.2

配置思路

  1. 在用户侧进行拨号配置。

  2. 配置LAC。

  3. 配置LNS。

数据准备

为完成此配置例,需准备如下的数据:

  • PC1用户名、口令;PC2用户名、口令

  • 隧道的密码、LNS侧本端名称和远端名称

  • VPN实例名称

  • 两个虚拟接口模板编号及两个L2TP组编号

  • 远端地址池编号、范围及掩码

操作步骤

  1. 用户侧的配置

    建立一个拨号网络,号码为DeviceA的接入号码,接收由LNS服务器端分配的地址。

    对于PC1而言,在弹出的拨号终端窗口中输入用户名user1@isp1,口令(此用户名与口令已在LNS中注册)。

    对于PC2而言,在弹出的拨号终端窗口中输入用户名use1@isp2,口令(此用户名与口令已在LNS中注册)。

  2. DeviceA(LAC侧)的配置

    # 配置虚模板接口1。

    <Device> system-view
    [~Device] sysname DeviceA
    [*DeviceA] interface virtual-template 1
    [*DeviceA-Virtual-Template1] ppp authentication-mode chap
    [*DeviceA-Virtual-Template1] commit
    [~DeviceA-Virtual-Template1] quit

    # 在GE 2/0/0.100接口上绑定虚模板接口1。

    [~DeviceA] interface gigabitethernet 2/0/0.100
    [*DeviceA-GigabitEthernet2/0/0.100] pppoe-server bind virtual-template 1
    [*DeviceA-GigabitEthernet2/0/0.100] user-vlan 1 100
    [*DeviceA-GigabitEthernet2/0/0.100-vlan-1-100] commit
    [~DeviceA-GigabitEthernet2/0/0.100-vlan-1-100] quit

    # 配置BAS接口。

    [~DeviceA-GigabitEthernet2/0/0.100] bas
    [*DeviceA-GigabitEthernet2/0/0.100-bas] access-type layer2-subscriber
    [*DeviceA-GigabitEthernet2/0/0.100-bas] authentication-method ppp
    [*DeviceA-GigabitEthernet2/0/0.100-bas] commit
    [~DeviceA-GigabitEthernet2/0/0.100-bas] quit
    [~DeviceA-GigabitEthernet2/0/0.100] quit

    # 创建VPN-instance。

    [~DeviceA] ip vpn-instance vrf1
    [*DeviceA-vpn-instance-vrf1] route-distinguisher 100:1
    [*DeviceA-vpn-instance-vrf1] vpn-target 100:1 both
    [*DeviceA–vpn-instance-vrf1] commit
    [~DeviceA–vpn-instance-vrf1] quit

    # LAC与LNS相连的接口与VPN-instance绑定。

    [~DeviceA] interface gigabitethernet1/0/1
    [*DeviceA-GigabitEthernet1/0/1] ip binding vpn-instance vrf1
    [*DeviceA--GigabitEthernet1/0/1] ip address 10.0.0.1 255.255.255.0
    [*DeviceA--GigabitEthernet1/0/1] commit
    [~DeviceA--GigabitEthernet1/0/1] quit

    # 创建环回接口。

    [~DeviceA] interface loopback0
    [*DeviceA-LoopBack0] ip binding vpn-instance vrf1
    [*DeviceA-LoopBack0] ip address 1.1.1.1 255.255.255.255
    [*DeviceA-LoopBack0] commit
    [~DeviceA-LoopBack0] quit

    # 设置L2TP组并配置相关属性。

    [~DeviceA] l2tp enable
    [~DeviceA] l2tp-group lac1
    [*DeviceA-l2tp-lac1] tunnel name lac1
    [*DeviceA-l2tp-lac1] start l2tp ip 3.3.3.3
    [*DeviceA-l2tp-lac1] tunnel authentication
    [*DeviceA-l2tp-lac1] tunnel password simple 1qaz#EDC
    [*DeviceA-l2tp-lac1] tunnel source loopback0
    [*DeviceA-l2tp-lac1] commit
    [~DeviceA-l2tp-lac1] quit

    # LAC1配置RADIUS服务器。

    [~DeviceA] radius-server group radius1
    [*DeviceA-radius-radius1] radius-server authentication 10.0.0.249 1812
    [*DeviceA-radius-radius1] radius-server accounting 10.0.0.249 1813
    [*DeviceA-radius-radius1] radius-server shared-key itellin
    [*DeviceA-radius-radius1] commit
    [~DeviceA-radius-radius1] quit

    # LAC1配置用户所在域。

    [~DeviceA] aaa
    [*DeviceA-aaa] domain isp1
    [*DeviceA-aaa-domain-isp1] l2tp-group lac1
    [*DeviceA-aaa-domain-isp1] radius-server group radius1
    [*DeviceA-aaa-domain-isp1] authentication-scheme default1
    [*DeviceA-aaa-domain-isp1] accounting-scheme default1
    [* DeviceA-aaa-domain-isp1] commit
    [~DeviceA-aaa-domain-isp1] quit
    [~DeviceA-aaa] quit

    # 配置路由。

    [~DeviceA] ip route-static vpn-instance vrf1 3.3.3.3 255.255.255.255 10.0.0.2

  3. DeviceC(LAC侧)的配置

    # 配置虚模板接口1。

    <Device> system-view
    [~Device] sysname DeviceC
    [*DeviceC] interface virtual-template 1
    [*DeviceC-Virtual-Template1] ppp authentication-mode chap
    [*DeviceC-Virtual-Template1] commit
    [~DeviceC-Virtual-Template1] quit

    # 在GE 2/0/0.100接口上绑定虚模板接口1。

    [~DeviceC] interface gigabitethernet 2/0/0.100
    [*DeviceC-GigabitEthernet2/0/0.100] pppoe-server bind virtual-template 1
    [*DeviceA-GigabitEthernet2/0/0.100] user-vlan 1 100
    [*DeviceA-GigabitEthernet2/0/0.100-vlan-1-100] commit
    [~DeviceA-GigabitEthernet2/0/0.100-vlan-1-100] quit

    # 配置BAS接口。

    [~DeviceC-GigabitEthernet2/0/0.100] bas
    [*DeviceC-GigabitEthernet2/0/0.100-bas] access-type layer2-subscriber
    [*DeviceC-GigabitEthernet2/0/0.100-bas] authentication-method ppp
    [*DeviceC-GigabitEthernet2/0/0.100-bas] commit
    [~DeviceC-GigabitEthernet2/0/0.100-bas] quit
    [~DeviceC-GigabitEthernet2/0/0.100] quit

    # 创建VPN-instance。

    [~DeviceC] ip vpn-instance vrf2
    [*DeviceC-vpn-instance-vrf2] route-distinguisher 100:2
    [*DeviceC-vpn-instance-vrf2] vpn-target 100:2 both
    [*DeviceC–vpn-instance-vrf2] commit
    [~DeviceC–vpn-instance-vrf2] quit

    # LAC与LNS相连的接口与VPN-instance绑定。

    [~DeviceC] interface gigabitethernet1/0/1
    [*DeviceC-GigabitEthernet1/0/1] ip binding vpn-instance vrf2
    [*DeviceC-GigabitEthernet1/0/1] ip address 10.10.0.1 255.255.255.0
    [*DeviceC-GigabitEthernet1/0/1] commit
    [~DeviceC-GigabitEthernet1/0/1] quit

    # 创建环回接口。

    [~DeviceC] interface loopback1
    [*DeviceC-LoopBack1] ip binding vpn-instance vrf2
    [*DeviceC-LoopBack1] ip address 2.2.2.2 255.255.255.255
    [*DeviceC-LoopBack1] commit
    [~DeviceC-LoopBack1] quit

    # 设置L2TP组并配置相关属性。

    [~DeviceC] l2tp enable
    [~DeviceC] l2tp-group lac2
    [*DeviceC-l2tp-lac2] tunnel name lac2
    [*DeviceC-l2tp-lac2] start l2tp ip 4.4.4.4
    [*DeviceC-l2tp-lac2] tunnel authentication
    [*DeviceC-l2tp-lac2] tunnel password simple 1qaz#EDC
    [*DeviceC-l2tp-lac2] tunnel source loopback1
    [*DeviceC-l2tp-lac2] commit
    [~DeviceC-l2tp-lac2] quit

    # LAC2配置RADIUS服务器。

    [~DeviceC] radius-server group radius1
    [*DeviceC-radius-radius1] radius-server authentication 10.10.0.249 1812
    [*DeviceC-radius-radius1] radius-server accounting 10.10.0.249 1813
    [*DeviceC-radius-radius1] radius-server shared-key itellin
    [*DeviceC-radius-radius1] commit
    [~DeviceC-radius-radius1] quit

    # LAC2配置用户所在域。

    [~DeviceC] aaa
    [*DeviceC-aaa] domain isp2
    [*DeviceC-aaa-domain-isp2] l2tp-group lac2
    [*DeviceC-aaa-domain-isp2] radius-server group radius1
    [*DeviceC-aaa-domain-isp2] authentication-scheme default1
    [*DeviceC-aaa-domain-isp2] accounting-scheme default1
    [*DeviceC-aaa-domain-isp2] commit
    [~DeviceC-aaa-domain-isp2] quit
    [~DeviceC-aaa] quit

    # 配置路由。

    [~DeviceC] ip route-static vpn-instance vrf2 4.4.4.4 255.255.255.255 10.10.0.2

  4. DeviceB(LNS侧)的配置

    # 创建两个VPN-instance。

    [~DeviceB] ip vpn-instance vrf1
    [*DeviceB-vpn-instance-vrf1] route-distinguisher 100:1
    [*DeviceB-vpn-instance-vrf1] vpn-target 100:1 both
    [*DeviceB–vpn-instance-vrf1] commit
    [~DeviceB–vpn-instance-vrf1] quit
    [~DeviceB] ip vpn-instance vrf2
    [*DeviceB-vpn-instance-vrf2] route-distinguisher 100:2
    [*DeviceB-vpn-instance-vrf2] vpn-target 100:2 both
    [*DeviceB–vpn-instance-vrf2] commit
    [~DeviceB–vpn-instance-vrf2] quit

    # 创建两个接口。

    [~DeviceB] interface gigabitethernet1/0/1
    [*DeviceB-GigabitEthernet1/0/1] ip binding vpn-instance vrf1
    [*DeviceB--GigabitEthernet1/0/1] ip address 10.0.0.2 255.255.255.0
    [*DeviceB--GigabitEthernet1/0/1] commit
    [~DeviceB--GigabitEthernet1/0/1] quit
    [~DeviceB] interface gigabitethernet1/0/2
    [*DeviceB-GigabitEthernet1/0/2] ip binding vpn-instance vrf2
    [*DeviceB-GigabitEthernet1/0/2] ip address 10.10.0.2 255.255.255.0
    [*DeviceB-GigabitEthernet1/0/2] commit
    [~DeviceB-GigabitEthernet1/0/2] quit

    # 创建环回接口。

    [~DeviceB] interface loopback0
    [*DeviceB-LoopBack0] ip binding vpn-instance vrf1
    [*DeviceB-LoopBack0] ip address 3.3.3.3 255.255.255.255
    [*DeviceB-LoopBack0] commit
    [~DeviceB-LoopBack0] quit
    [~DeviceB] interface loopback1
    [*DeviceB-LoopBack1] ip binding vpn-instance vrf2
    [*DeviceB-LoopBack1] ip address 4.4.4.4 255.255.255.255
    [*DeviceB-LoopBack1] commit
    [~DeviceB-LoopBack1] quit

    # 创建虚模板接口1。

    [~DeviceB] interface virtual-template 1
    [*DeviceB-Virtual-Template1] ppp authentication-mode chap
    [*DeviceB-Virtual-Template1] commit
    [~DeviceB-Virtual-Template1] quit

    # 使能L2TP服务,并配置L2TP组。

    [~DeviceB] l2tp enable
    [~DeviceB] l2tp-group lns1
    [*DeviceB-l2tp-lns1] tunnel name lns1
    [*DeviceB-l2tp-lns1] allow l2tp virtual-template 1 remote lac1
    [*DeviceB-l2tp-lns1] tunnel authentication
    [*DeviceB-l2tp-lns1] tunnel password simple 1qaz#EDC
    [*DeviceB-l2tp-lns1] commit
    [~DeviceB-l2tp-lns1] quit
    [~DeviceB] l2tp-group lns2
    [*DeviceB-l2tp-lns1] tunnel name lns2
    [*DeviceB-l2tp-lns1] allow l2tp virtual-template 1 remote lac2
    [*DeviceB-l2tp-lns1] tunnel authentication
    [*DeviceB-l2tp-lns1] tunnel password simple 1qaz#EDC
    [*DeviceB-l2tp-lns1] commit
    [~DeviceB-l2tp-lns1] quit

    # 创建并配置LNS组group1,绑定隧道源接口和隧道板。

    [~DeviceB] lns-group group1
    [*DeviceB-lns-group-group1] bind slot 1 
    [*DeviceB-lns-group-group1] bind source LoopBack0
    [*DeviceB-lns-group-group1] bind source LoopBack1
    [*DeviceB-lns-group-group1] commit
    [~DeviceB-lns-group-group1] quit

    # 配置给用户分配的地址池。

    [~DeviceB] ip pool pool1 bas local
    [*DeviceB-ip-pool-pool1] gateway 210.10.0.1 255.255.255.0
    [*DeviceB-ip-pool-pool1] section 0 210.10.0.10 210.10.0.100
    [*DeviceB-ip-pool-pool1] commit
    [~DeviceB-ip-pool-pool1] quit
    [~DeviceB] ip pool pool2 bas local
    [*DeviceB-ip-pool-pool2] gateway 155.10.0.1 255.255.255.0
    [*DeviceB-ip-pool-pool2] section 0 155.10.0.10 155.10.0.100
    [*DeviceB-ip-pool-pool2] commit
    [~DeviceB-ip-pool-pool2] quit

    # 配置RADIUS服务器。

    [~DeviceB] radius-server group radius1
    [*DeviceB-radius-radius1] radius-server authentication 10.0.0.249 1812
    [*DeviceB-radius-radius1] radius-server accounting 10.0.0.249 1813
    [*DeviceB-radius-radius1] radius-server shared-key itellin
    [*DeviceB-radius-radius1] commit
    [~DeviceB-radius-radius1] quit

    # 配置用户所在域。

    [~DeviceB] aaa
    [*DeviceB-aaa] domain isp1
    [*DeviceB-aaa-domain-isp1] radius-server group radius1
    [*DeviceB-aaa-domain-isp1] authentication-scheme default1
    [*DeviceB-aaa-domain-isp1] accounting-scheme default1
    [*DeviceB-aaa-domain-isp1] ip-pool pool1
    [*DeviceB-aaa-domain-isp1] commit
    [~DeviceB-aaa-domain-isp1] quit
    [~DeviceB-aaa] domain isp2
    [*DeviceB-aaa-domain-isp2] radius-server group radius1
    [*DeviceB-aaa-domain-isp2] authentication-scheme default1
    [*DeviceB-aaa-domain-isp2] accounting-scheme default1
    [*DeviceB-aaa-domain-isp2] ip-pool pool2
    [*DeviceB-aaa-domain-isp2] commit
    [~DeviceB-aaa-domain-isp2] quit
    [~DeviceB-aaa] quit

    # 配置路由。

    [~DeviceB] ip route-static vpn-instance vrf1 1.1.1.1 255.255.255.255 10.0.0.1
    [~DeviceB] ip route-static vpn-instance vrf2 2.2.2.2 255.255.255.255 10.10.0.1

  5. 检查配置结果

    [~DeviceA] ping -vpn-instance vrf1 3.3.3.3
    PING 3.3.3.3: 56  data bytes, press CTRL_C to break                           
        Reply from 3.3.3.3: bytes=56 Sequence=1 ttl=255 time=12 ms                  
        Reply from 3.3.3.3: bytes=56 Sequence=2 ttl=255 time=10 ms                  
        Reply from 3.3.3.3: bytes=56 Sequence=3 ttl=255 time=5 ms                   
        Reply from 3.3.3.3: bytes=56 Sequence=4 ttl=255 time=8 ms                   
                                                                                    
      --- 3.3.3.3 ping statistics ---                                               
        4 packet(s) transmitted                                                     
        4 packet(s) received                                                        
        0.00% packet loss                                                           
        round-trip min/avg/max = 5/8/12 ms                           
    [~DeviceC] ping -vpn-instance vrf2 4.4.4.4
    PING 4.4.4.4: 56  data bytes, press CTRL_C to break                           
        Reply from 4.4.4.4: bytes=56 Sequence=1 ttl=255 time=12 ms                  
        Reply from 4.4.4.4: bytes=56 Sequence=2 ttl=255 time=10 ms                  
        Reply from 4.4.4.4: bytes=56 Sequence=3 ttl=255 time=5 ms                   
        Reply from 4.4.4.4: bytes=56 Sequence=4 ttl=255 time=8 ms                   
                                                                                    
      --- 4.4.4.4 ping statistics ---                                               
        4 packet(s) transmitted                                                     
        4 packet(s) received                                                        
        0.00% packet loss                                                           
        round-trip min/avg/max = 5/8/12 ms                           
    [~DeviceA] test l2tp-tunnel l2tp-group lac1 ip-address 3.3.3.3
    Testing L2TP tunnel connectivity now....... 
    Test L2TP tunnel connectivity success.
    [~DeviceC] test l2tp-tunnel l2tp-group lac2 ip-address 4.4.4.4
    Testing L2TP tunnel connectivity now....... 
    Test L2TP tunnel connectivity success.

配置文件

  • DeviceA的配置文件

    #
     sysname DeviceA
    #
     l2tp enable
    #
    radius-server group radius1
     radius-server authentication 10.0.0.249 1812 
     radius-server accounting 10.0.0.249 1813 
     radius-server shared-key itellin
    #
    interface Virtual-Template1
    ppp authentication-mode chap
    #
    interface GigabitEthernet2/0/0
     undo shutdown 
    #
    interface GigabitEthernet2/0/0.100
     undo shutdown
     pppoe-server bind Virtual-Template 1
     user-vlan 1 100
     bas
      access-type layer2-subscriber
    #
    ip vpn-instance vrf1
    route-distinguisher 100:1
     vpn-target 100:1 export-extcommunity
     vpn-target 100:1 import-extcommunity
    #
    interface LoopBack0
     ip binding vpn-instance vrf1
     ip address 1.1.1.1 255.255.255.255
    l2tp-group lac1
     tunnel password simple 1qaz#EDC
     tunnel name lac1
     start l2tp ip 3.3.3.3
     tunnel source LoopBack0
    #
    aaa
    domain isp1
      authentication-scheme default1
      accounting-scheme default1
      radius-server group radius1
      l2tp-group lac1
    #
    interface GigabitEthernet1/0/1
     undo shutdown
     ip binding vpn-instance vrf1
     ip address 10.0.0.1 255.255.255.0
    #
     ip route-static vpn-instance vrf1 3.3.3.3 255.255.255.255 10.0.0.2
    #
    return
  • DeviceC的配置文件

    #
     sysname DeviceC
    #
     l2tp enable
    #
    radius-server group radius1
     radius-server authentication 10.10.0.249 1812 
     radius-server accounting 10.10.0.249 1813 
     radius-server shared-key itellin
    #
    interface Virtual-Template1
    ppp authentication-mode chap
    #
    interface GigabitEthernet2/0/0
     undo shutdown 
    #
    interface GigabitEthernet2/0/0.100
     undo shutdown
     pppoe-server bind Virtual-Template 1
     user-vlan 1 100
     bas
      access-type layer2-subscriber
    #
    ip vpn-instance vrf2
    route-distinguisher 200:1
     vpn-target 200:1 export-extcommunity
     vpn-target 200:1 import-extcommunity
    #
    interface LoopBack0
     ip binding vpn-instance vrf2
     ip address 2.2.2.2 255.255.255.255
    l2tp-group lac2
     tunnel password simple 1qaz#EDC
     tunnel name lac2
     start l2tp ip 4.4.4.4
     tunnel source LoopBack0
    #
    aaa
    domain isp2
      authentication-scheme default1
      accounting-scheme default1
      radius-server group radius1
      l2tp-group lac2
    #
    interface GigabitEthernet1/0/1
     undo shutdown
     ip binding vpn-instance vrf2
     ip address 10.10.0.1 255.255.255.0
    #
     ip route-static vpn-instance vrf2 4.4.4.4 255.255.255.255 10.10.0.2
    #
    return
  • DeviceB的配置文件

    #
     sysname DeviceB
    #
     l2tp enable
    #
    radius-server group radius1
     radius-server authentication 20.20.20.1 1812 
     radius-server accounting 20.20.20.1 1813 
     radius-server shared-key itellin
    #
    interface Virtual-Template1
    ppp authentication-mode chap
    #
    ip vpn-instance vrf1
    route-distinguisher 100:1
     vpn-target 100:1 export-extcommunity
     vpn-target 100:1 import-extcommunity
    #
    ip vpn-instance vrf2
    route-distinguisher 100:2
     vpn-target 100:2 export-extcommunity
     vpn-target 100:2 import-extcommunity
    #
    interface LoopBack0
     ip binding vpn-instance vrf1
     ip address 3.3.3.3 255.255.255.255
    #
    interface LoopBack1
     ip binding vpn-instance vrf2
     ip address 4.4.4.4 255.255.255.255
    #
    l2tp-group lns1
     allow l2tp virtual-template 1 remote lac1
     tunnel password simple 1qaz#EDC
     tunnel name lns1
    #
    l2tp-group lns2
     allow l2tp virtual-template 1 remote lac2
     tunnel password simple 1qaz#EDC
     tunnel name lns2
    #
    lns-group group1
     bind slot 1 
     bind source LoopBack0
     bind source LoopBack1
    #
    ip pool pool1 bas local
     gateway 210.10.0.1 255.255.255.0
     section 0 210.10.0.10 10.10.0.100
    #
    ip pool pool2 bas local
     gateway 155.10.0.1 255.255.255.0
     section 0 155.10.0.10 10.10.0.100
    #
    aaa
    domain  isp1
      radius-server group  radius1
      authentication-scheme   default1
      accounting-scheme   default1
      ip-pool pool1
    domain  isp2
      radius-server group  radius1
      authentication-scheme   default1
      accounting-scheme   default1
      ip-pool pool2
    #
    interface GigabitEthernet1/0/1
     undo shutdown
     ip binding vpn-instance vrf1
     ip address 10.0.0.2 255.255.255.0
    #
    interface GigabitEthernet1/0/2
     undo shutdown
     ip binding vpn-instance vrf2
     ip address 10.10.0.2 255.255.255.0
    #
     ip route-static vpn-instance vrf1 1.1.1.1 255.255.255.255 10.0.0.1
     ip route-static vpn-instance vrf2 2.2.2.2 255.255.255.255 10.10.0.1
    #
    return
下载文档
更新时间:2018-07-12

文档编号:EDOC1100028564

浏览量:16388

下载量:207

平均得分:
本文档适用于这些产品
相关文档
相关版本
分享
上一页 下一页