所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级
AR500, AR510, AR531, AR550, AR1500, AR2500 V200R010 配置指南-接口管理(命令行)

本文档介绍了接口管理特性,从原理、配置过程和配置举例等方面对特性进行介绍。

评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置使用双SIM卡接入不同3G网络

配置使用双SIM卡接入不同3G网络

组网需求

图4-6所示,某企业的总部和分支机构分布在不同地域。Router作为分支机构的出口网关,通过WCDMA网络(图中的3G网络1)接入总部。

为了提高3G链路进行数据传输的可靠性,分支机构选择可以插入两个SIM卡的3G Cellular接口,一个SIM卡作为主SIM卡接入3G网络1,另一个SIM卡作为备份SIM卡接入3G网络2,这样,当主SIM卡费用不足、发生故障、形成的3G链路信号质量差或者接入的3G网络发生故障,流量就自动切换到备份SIM卡,从而保证企业业务不发生中断。

图4-6  使用双SIM卡接入不同3G网络示意图

配置思路

采用如下的配置思路:

  • 创建两个APN模板,一个模板关联主SIM卡,另一个模板关联备份SIM卡。
  • 在3G Cellular接口上配置轮询DCC拨号连接。
  • 在3G Cellular接口上绑定APN模板。
  • 配置企业内网,由Router为该企业分支内网用户分配IP地址。
  • 配置NAT功能,指定3G Cellular接口的IP地址作为该企业分支公网地址。
  • 配置缺省路由,指定出接口为3G Cellular接口,使该企业分支内网的流量通过3G Cellular上行传输到3G网络。

操作步骤

  1. 配置APN模板

    # 配置APN模板mainCard,该模板用来关联主SIM卡,接入3G网络1。从运营商处获取3G网络1的APN是3GNET1。

    <Huawei> system-view
    [Huawei] sysname Router
    [Router] apn profile mainCard
    [Router-apn-profile-mainCard] sim-id 1
    [Router-apn-profile-mainCard] apn 3GNET1
    [Router-apn-profile-mainCard] quit

    # 配置APN模板backupCard,该模板用来关联备份SIM卡,接入3G网络2。从运营商处获取3G网络2的APN是3GNET2。

    [Router] apn profile backupCard
    [Router-apn-profile-backupCard] sim-id 2
    [Router-apn-profile-backupCard] apn 3GNET2
    [Router-apn-profile-backupCard] quit

  2. 在3G Cellular接口上配置轮询DCC拨号连接

    # 配置拨号控制列表。

    [Router] dialer-rule
    [Router-dialer-rule] dialer-rule 1 ip permit
    [Router-dialer-rule] quit

    # 在3G Cellular接口上配置轮询DCC拨号连接。

    [Router] interface cellular 0/0/0
    [Router-Cellular0/0/0] ip address negotiate
    [Router-Cellular0/0/0] mode wcdma wcdma-precedence
    [Router-Cellular0/0/0] dialer enable-circular
    [Router-Cellular0/0/0] dialer-group 1
    [Router-Cellular0/0/0] dialer timer autodial 20
    [Router-Cellular0/0/0] dialer number *99# autodial

  3. 在3G Cellular接口上绑定APN模板。

    [Router-Cellular0/0/0] apn-profile mainCard priority 150
    [Router-Cellular0/0/0] apn-profile backupCard priority 120
    [Router-Cellular0/0/0] sim switch rssi-threshold 105
    [Router-Cellular0/0/0] sim switch-back enable timer 1440
    [Router-Cellular0/0/0] shutdown
    [Router-Cellular0/0/0] undo shutdown
    [Router-Cellular0/0/0] quit

  4. 配置企业内网

    # 创建VLAN10,将Ethernet2/0/0接口加入VLAN10。

    [Router] vlan 10
    [Router-vlan10] quit
    [Router] interface ethernet 2/0/0
    [Router-Ethernet2/0/0] port link-type trunk
    [Router-Ethernet2/0/0] port trunk allow-pass vlan 10
    [Router-Ethernet2/0/0] quit

    # 使能DHCP功能。

    [Router] dhcp enable

    # 创建全局地址池。

    [Router] ip pool 3gpool
    [Router-ip-pool-3gpool] network 192.168.100.0 mask 255.255.255.0
    [Router-ip-pool-3gpool] gateway-list 192.168.100.1
    [Router-ip-pool-3gpool] quit

    # 配置接口工作在全局地址池模式。

    [Router] interface vlanif 10
    [Router-Vlanif10] ip address 192.168.100.1 255.255.255.0
    [Router-Vlanif10] dhcp select global
    [Router-Vlanif10] quit

  5. 配置NAT功能

    [Router] acl number 3002
    [Router-acl-adv-3002] rule 5 permit ip source 192.168.100.0 0.0.0.255
    [Router-acl-adv-3002] quit
    [Router] interface cellular 0/0/0
    [Router-Cellular0/0/0] nat outbound 3002
    [Router-Cellular0/0/0] quit
    

  6. 配置缺省路由,指定出接口为3G Cellular

    [Router] ip route-static 0.0.0.0 0 cellular 0/0/0

  7. 验证配置结果

    配置完成后,企业分支内网的流量通过主SIM卡上行传输到3G网络1,当主SIM卡费用不足、发生故障、形成的3G链路信号质量差或者接入的3G网络发生故障,流量就自动切换到备份SIM卡,通过备份SIM卡上行传输到3G网络2。

任务示例

  • Router的配置文件

    #
     sysname Router
    #                                                                               
    vlan batch 10                       
    #
    dhcp enable  
    #                                                                               
    acl number 3002                                                                
     rule 5 permit ip source 192.168.100.0 0.0.0.255  
    #
    apn profile mainCard
     apn 3GNET1 
    apn profile backupCard
     apn 3GNET2 
     sim-id 2
    #
    interface Cellular0/0/0
     dialer enable-circular 
     dialer-group 1
     apn-profile mainCard priority 150 
     apn-profile backupCard priority 120 
     dialer timer autodial 20 
     dialer number *99# autodial
     nat outbound 3002  
     ip address negotiate
     sim switch-back enable timer 1440
     sim switch rssi-threshold 105  
    #
    interface Ethernet2/0/0   
     port link-type trunk  
     port trunk allow-pass vlan 10  
    #
    interface Vlanif10
     ip address 192.168.100.1 255.255.255.0   
     dhcp select global   
    #
    ip pool 3gpool  
     gateway-list 192.168.100.1  
     network 192.168.100.0 mask 255.255.255.0  
    #
    dialer-rule 
     dialer-rule 1 ip permit
    #
    ip route-static 0.0.0.0 0.0.0.0 Cellular0/0/0
    #
    return
翻译
下载文档
更新时间:2019-11-21

文档编号:EDOC1100034263

浏览量:13146

下载量:83

平均得分:
本文档适用于这些产品

相关版本

相关文档

Share
上一页 下一页