所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级
AR500, AR510, AR531, AR550, AR1500, AR2500 V200R010 配置指南-接口管理(命令行)

本文档介绍了接口管理特性,从原理、配置过程和配置举例等方面对特性进行介绍。

评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置LTE Cellular接口作为主接口接入Internet示例

配置LTE Cellular接口作为主接口接入Internet示例

组网需求

企业的某个分支位于偏远区域,无法获取有线广域接入服务,但该分支需要与外界进行较大流量的业务传输。如图5-9所示,为了满足业务传输的需求,该分支使用Router作为出口网关,使用LTE Cellular接口通过LTE网络接入Internet。

分支内网所属网段为192.168.100.0/24,主机都加入VLAN10,该分支希望Router能够为该分支内网用户分配IP地址,并且希望内网用户可以访问外网。

该企业分支办理了包年业务,采用自动拨号方式接入Internet。该企业分支从运营商获取到的信息如下:

  • APN为ltenet。
  • 拨号串为*99#。
图5-9  LTE Cellular接口作为主接口接入Internet组网图

配置思路

采用如下的配置思路:

  1. 配置LTE接口的连接参数。
  2. 配置轮询DCC拨号连接,实现LTE cellular接口接入LTE网络。
  3. 配置企业内网,由Router为该企业分支内网用户分配IP地址。
  4. 配置NAT功能,实现分支的内网用户可以访问外网。
  5. 配置缺省路由,指定出接口为LTE Cellular接口,使该企业分支内网的流量通过LTE Cellular接口上行传输到Internet。

执行命令dialer enable-circular,设备会自动配置拨号串和IP地址协商,无需配置拨号控制列表。

操作步骤

  1. 配置LTE接口的连接参数。

    # 创建APN模板。

    <Huawei> system-view
    [Huawei] sysname Router
    [Router] apn profile lteprofile
    [Router-apn-profile-lteprofile] apn ltenet
    [Router-apn-profile-lteprofile] quit

    # 配置网络连接方式。

    [Router] interface cellular 0/0/0
    [Router-Cellular0/0/0] mode lte auto

    # 在LTE Cellular接口上绑定APN模板。

    [Router-Cellular0/0/0] dialer enable-circular
    [Router-Cellular0/0/0] apn-profile lteprofile
    [Router-Cellular0/0/0] shutdown
    [Router-Cellular0/0/0] undo shutdown
    [Router-Cellular0/0/0] quit

  2. 配置轮询DCC拨号连接。

    # 配置拨号控制列表。

    [Router] dialer-rule
    [Router-dialer-rule] dialer-rule 1 ip permit
    [Router-dialer-rule] quit

    # 配置动态获取IP地址。

    [Router] interface cellular 0/0/0
    [Router-Cellular0/0/0] ip address negotiate

    # 配置拨号控制列表关联Cellular0/0/0。

    [Router-Cellular0/0/0] dialer-group 1

    命令dialer-group中的参数group-number和命令dialer-rule中的dialer-rule-number必须一致。

    # 配置到达对端的拨号串。

    [Router-Cellular0/0/0] dialer number *99# autodial
    [Router-Cellular0/0/0] quit

  3. 配置企业内网。

    # 创建VLAN10,将Ethernet2/0/0接口加入VLAN10。

    [Router] vlan 10
    [Router-vlan10] quit
    [Router] interface ethernet 2/0/0
    [Router-Ethernet2/0/0] port link-type trunk
    [Router-Ethernet2/0/0] port trunk allow-pass vlan 10
    [Router-Ethernet2/0/0] quit

    # 使能DHCP功能。

    [Router] dhcp enable

    # 创建全局地址池。

    [Router] ip pool 4gpool
    [Router-ip-pool-4gpool] network 192.168.100.0 mask 255.255.255.0
    [Router-ip-pool-4gpool] gateway-list 192.168.100.1
    [Router-ip-pool-4gpool] quit

    # 配置接口工作在全局地址池模式。

    [Router] interface vlanif 10
    [Router-Vlanif10] ip address 192.168.100.1 255.255.255.0
    [Router-Vlanif10] dhcp select global
    [Router-Vlanif10] quit

  4. 配置NAT功能。

    [Router] acl number 3002
    [Router-acl-adv-3002] rule 5 permit ip source 192.168.100.0 0.0.0.255
    [Router-acl-adv-3002] quit
    [Router] interface cellular 0/0/0
    [Router-Cellular0/0/0] nat outbound 3002
    [Router-Cellular0/0/0] quit

  5. 配置缺省路由,指定出接口为Cellular0/0/0。

    [Router] ip route-static 0.0.0.0 0 cellular 0/0/0

  6. 验证配置结果。

    # 查看接口的详细信息,当接口上有流量传送时,可以看到接口的物理状态和链路层协议状态都是Up,接口动态获得的IP地址为10.1.1.2/24。

    [Router] display interface cellular 0/0/0
    Cellular0/0/0 current state : UP                                                
    Line protocol current state : UP                                     
    Description:HUAWEI,  Series, Cellular0/0/0 Interface                          
    Route Port,The Maximum Transmit Unit is 1500, Hold timer is 10(sec)                                      
    Internet Address is 10.1.1.2/24                                                   
    Current system time: 2011-06-08 11:35:23                                        
    Modem State: Present                                                        
    Last 300 seconds input rate 555 bytes/sec 4440 bits/sec 12 packets/sec 
    Last 300 seconds output rate 11230 bytes/sec 89840 bits/sec 311 packets/sec 
        Input: 210 packets, 87205 bytes
          Unicast:                  200,       Ununicast:                  10
        Output:225340 packets, 6760917 bytes
          Unicast:                  225300,    Ununicast:                  40
        Input bandwidth utilization  : 0.01%
        Output bandwidth utilization : 0.01%
    

    # 查看LTE数据卡的呼叫连接信息,可以看到APN为ltenet、无线网络类型为Automatic以及网络连接方式为LTE(LTE)。

    <Huawei> display cellular 0/0/0 all
    Modem State:                                                                    
    Hardware Information.                                                           
    =====================                                                           
    Model = E392                                                                    
    Modem Firmware Version =  11.833.15.00.000                                      
    Hardware Version = CD2E392UM                                                  
    Integrate circuit card identity (ICCID) = 98681011274300909893                
    International Mobile Subscriber Identity (IMSI) = 460016002731442               
    International Mobile Equipment Identity (IMEI) = 861230010006485                
    Factory Serial Number (FSN) = T2Y01A9211900298                                  
    Modem Status = Online                                                           
    Profile Information.                                                            
    ====================                                                            
    Profile 1 = ACTIVE                                                              
    --------                                                                        
    PDP Type = IPv4, Header Compression = OFF                                       
    Data Compression = OFF                                                          
    Access Point Name (APN) = ltenet                                                
    Packet Session Status = Active                                                
    * - Default profile                                                             
    Network Information.                                                            
    ====================                                                            
    Current Service Status = Service available                                      
    Current Service = Combined                                                      
    Packet Service = Attached                                                       
    Packet Session Status = Active                                                
    Current Roaming Status = Home                                                   
    Network Selection Mode = Automatic                                              
    Network Connection Mode = Automatic                                             
    Current Network Connection = LTE(LTE)                                       
    Mobile Country Code (MCC) = 460                                                 
    Mobile Network Code (MNC) = 01                                                  
    Mobile Operator Information = "CHN-CULTE"                                       
    Cell ID = 55924                                                                 
    Upstream Bandwidth = 50mbps                                                    
    Downstream Bandwidth = 100mbps                                                  
    Radio Information.                                                              
    ==================                                                              
    Current Band = AUTO                                                             
    Current RSSI = -55 dBm                                                          
    Modem Security Information.                                                     
    ===========================                                                     
    PIN Verification = Disabled                                                     
    PIN Status = Ready                                                              
    Number of Retries remaining = 3                                                 
    SIM Status = OK             
    

任务示例

  • Router的配置文件

    #
     sysname Router
    #                                                                               
    vlan batch 10  
    #
    dhcp enable  
    #                                                                               
    acl number 3002                                                                
     rule 5 permit ip source 192.168.100.0 0.0.0.255  
    #
    ip pool 4gpool  
     gateway-list 192.168.100.1  
     network 192.168.100.0 mask 255.255.255.0  
    #
    interface Vlanif10
     ip address 192.168.100.1 255.255.255.0   
     dhcp select global   
    #
    interface Ethernet2/0/0   
     port link-type trunk  
     port trunk allow-pass vlan 10  
    #
    interface Cellular0/0/0
     dialer enable-circular
     dialer-group 1
     apn-profile lteprofile
     dialer number *99# autodial
     nat outbound 3002  
     ip address negotiate
    #
    dialer-rule
     dialer-rule 1 ip permit
    #
    apn profile lteprofile      
     apn ltenet      
    #
    ip route-static 0.0.0.0 0.0.0.0 Cellular0/0/0
    #
    return
翻译
下载文档
更新时间:2019-11-21

文档编号:EDOC1100034263

浏览量:13147

下载量:83

平均得分:
本文档适用于这些产品

相关版本

相关文档

Share
上一页 下一页