所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级
AR500, AR510, AR531, AR550, AR1500, AR2500 V200R010 配置指南-接口管理(命令行)

本文档介绍了接口管理特性,从原理、配置过程和配置举例等方面对特性进行介绍。

评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置企业分支将3G Cellular接口作为主链路接入Internet示例(针对WCDMA网络)

配置企业分支将3G Cellular接口作为主链路接入Internet示例(针对WCDMA网络)

组网需求

企业分支机构地理位置偏僻,固定网络不易部署。如图4-5所示,为了满足业务传输的需求,该分支使用Router作为出口网关,使用3G Cellular接口通过WCDMA网络接入Internet。

企业分支内网所属网段为10.10.10.0/24,主机加入VLAN10,该分支希望Router能够为该分支内网用户分配IP地址,并且希望分支用户可以访问外网。

已知企业办理了包年业务,该分支从运营商获取到的信息如下:

  • 用户名和密码为3guser和Password@123。
  • APN为3GNET。
  • 拨号串为*99#。
图4-5  配置3G Cellular接口作为主链路接入Internet组网图(针对WCDMA网络)

配置思路

采用如下的配置思路:

  1. 配置轮询DCC拨号连接,实现3G Cellular接口接入WCDMA网络。
  2. 配置企业内网,由Router为企业内网用户分配IP地址。
  3. 配置NAT功能,实现分支用户可以访问外网。
  4. 配置缺省路由,指定出接口为3G Cellular接口,使企业分支内网的流量通过3G Cellular接口上行传输到Internet。

操作步骤

  1. 配置轮询DCC拨号连接

    # 创建APN模板。

    <Huawei> system-view
    [Huawei] sysname Router
    [Router] apn profile 3gprofile
    [Router-apn-profile-3gprofile] apn 3GNET
    [Router-apn-profile-3gprofile] user name 3guser password cipher Password@123 authentication-mode auto
    [Router-apn-profile-3gprofile] quit

    # 配置动态获取IP地址。

    [Router] interface cellular 0/0/0
    [Router-Cellular0/0/0] ip address negotiate

    # 配置PPP协商DNS服务器地址。

    [Router-Cellular0/0/0] ppp ipcp dns request

    # 使能轮询DCC。

    [Router-Cellular0/0/0] dialer enable-circular

    # 配置到达对端的拨号串。

    [Router-Cellular0/0/0] dialer number *99# autodial

    # 配置网络连接方式。

    [Router-Cellular0/0/0] mode wcdma wcdma-precedence

    # 在3G Cellular接口上绑定APN模板。

    [Router-Cellular0/0/0] apn-profile 3gprofile
    [Router-Cellular0/0/0] shutdown
    [Router-Cellular0/0/0] undo shutdown
    [Router-Cellular0/0/0] quit

  2. 配置企业内网

    # 创建VLAN10,将Ethernet2/0/0接口加入VLAN10。

    [Router] vlan 10
    [Router-vlan10] quit
    [Router] interface ethernet 2/0/0
    [Router-Ethernet2/0/0] port link-type trunk
    [Router-Ethernet2/0/0] port trunk allow-pass vlan 10
    [Router-Ethernet2/0/0] quit

    # 使能DHCP功能。

    [Router] dhcp enable

    # 创建全局地址池。

    [Router] ip pool 3gpool
    [Router-ip-pool-3gpool] network 10.10.10.0 mask 255.255.255.0
    [Router-ip-pool-3gpool] gateway-list 10.10.10.254
    [Router-ip-pool-3gpool] quit

    # 配置接口使用全局地址池为用户分配IP地址。

    [Router] interface vlanif 10
    [Router-Vlanif10] ip address 10.10.10.1 255.255.255.0
    [Router-Vlanif10] dhcp select global
    [Router-Vlanif10] quit

  3. 配置NAT功能

    [Router] acl number 3002
    [Router-acl-adv-3002] rule 5 permit ip source 10.10.10.0 0.0.0.255
    [Router-acl-adv-3002] quit
    [Router] interface cellular 0/0/0
    [Router-Cellular0/0/0] nat outbound 3002
    [Router-Cellular0/0/0] quit

  4. 配置缺省路由,指定出接口为Cellular0/0/0

    [Router] ip route-static 0.0.0.0 0 cellular 0/0/0

  5. 验证配置结果

    # 执行display interface cellular命令查看接口的详细信息,当接口上有流量传送时,可以看到接口的物理层和链路层的状态都是Up状态以及动态获得的IP地址为10.1.1.2/24。

    [Router] display interface cellular 0/0/0
    Cellular0/0/0 current state : UP
    Line protocol current state : UP (spoofing)
    Description:HUAWEI, AR Series, Cellular0/0/0 Interface
    Route Port,The Maximum Transmit Unit is 1500, Hold timer is 10(sec)
    Internet Address is negotiated, 10.1.1.2/24
    Link layer protocol is PPP   
    LCP opened, IPCP opened
    Current system time: 2011-06-08 11:35:23
    Modem State: Present
    Model = MC509
    Current Network Connection = WCDMA(WCDMA)
    Current RSSI = -69 dBm
    Current SINR = 6 dB (weak)
    Last 300 seconds input rate 555 bytes/sec 4440 bits/sec 12 packets/sec 
    Last 300 seconds output rate 11230 bytes/sec 89840 bits/sec 311 packets/sec 
        Input: 210 packets, 87205 bytes
          Unicast:                  200,       Ununicast:                  10
        Output:225340 packets, 6760917 bytes
          Unicast:                  225300,    Ununicast:                  40
        Input bandwidth utilization  : 0.01%
        Output bandwidth utilization : 0.01%
    

    # 执行display cellular命令查看3G modem的呼叫连接信息,可以看到APN为3GNET、无线网络类型为WCDMA以及网络连接方式为WCDMA precedence。

    [Router] display cellular 0/0/0 all
    Modem State:
    Hardware Information.
    =====================
    Model = MC509
    Modem Type = WCDMA USB modem
    Modem Firmware Version = 11.106.15.17.000
    Hardware Version = CP12TCPU
    Integrate circuit card identity (ICCID) = 98681011274300909893  
    International Mobile Subscriber Identity (IMSI) = 460016002707237
    International Mobile Equipment Identity (IMEI) = 354661034412719
    Factory Serial Number (FSN) = MLA7NA1093003693
    Modem Status = Online
    Profile Information.
    ====================
    Profile 1 = ACTIVE
    --------
    PDP Type = IPv4, Header Compression = OFF
    Data Compression = OFF
    Access Point Name (APN) = 3GNET
    Packet Session Status = Active
    * - Default profile
    Network Information.
    ====================
    Current Service Status = Service available
    Service Domain = Combined
    Current Service = Combined
    Packet Service = Attached
    Packet Session Status = Active
    Current Roaming Status = Home
    Network Selection Mode = Automatic
    Network Connection Mode = WCDMA precedence
    Current Network Connection = WCDMA(WCDMA)
    Mobile Country Code (MCC) = 460
    Mobile Network Code (MNC) = 01
    Mobile Operator Information = "CHN-CUGSM"                        
    Location Area Code (LAC) = 53505
    Cell ID = 6012
    Upstream Bandwidth = 5.7mbps
    Downstream Bandwidth = 384kbps
    Radio Information.
    ==================
    Current Band = ANY
    Current RSSI = -69 dBm (good)
    Bands supported :                                
      GSM: GSM850 GSM900 GSM1800 GSM1900             
      WCDMA: WCDMA850 WCDMA900 WCDMA2100 WCDMA1900   
    Modem Security Information.
    ===========================
    PIN Verification = Disabled
    PIN Status = Ready
    Number of Retries remaining = 3
    SIM Status = OK            

配置文件

  • Router的配置文件

    #
     sysname Router
    #
    vlan batch 10  
    #
    dhcp enable  
    #
    acl number 3002
     rule 5 permit ip source 10.10.10.0 0.0.0.255
    #
    ip pool 3gpool
     gateway-list 10.10.10.254
     network 10.10.10.0 mask 255.255.255.0
    #
    interface Vlanif10
     ip address 10.10.10.1 255.255.255.0
     dhcp select global   
    #
    interface Ethernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 10  
    #
    interface Cellular0/0/0
     link-protocol ppp
     ppp ipcp dns request
     dialer enable-circular
     apn-profile 3gprofile
     dialer timer autodial 10  
     dialer number *99# autodial
     nat outbound 3002  
     ip address negotiate
    #
    apn profile 3gprofile
     user name 3guser password cipher %@%@Gy-Z:-sDMYJ`qiLe/gJG)}hP%@%@
     apn 3GNET
    #
    ip route-static 0.0.0.0 0.0.0.0 Cellular0/0/0
    #
    return
翻译
下载文档
更新时间:2019-11-21

文档编号:EDOC1100034263

浏览量:13357

下载量:83

平均得分:
本文档适用于这些产品

相关版本

相关文档

Share
上一页 下一页