所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级
AR500, AR510, AR531, AR550, AR1500, AR2500 V200R010 配置指南-接口管理(命令行)

本文档介绍了接口管理特性,从原理、配置过程和配置举例等方面对特性进行介绍。

评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置LTE Cellular接口通过双APN通道进行数据通信和VoIP语音通信示例

配置LTE Cellular接口通过双APN通道进行数据通信和VoIP语音通信示例

组网需求

企业的某个分支位于偏远区域,无法获取有线广域接入服务。但该分支需要与总部进行较大流量的业务传输,因此分支希望通过Internet与总部进行数据通信。另外,分支与总部间有语音通话的需求,且不希望有较大的通话成本,因此分支希望能够与总部之间进行VoIP语音通信。

分支内网所属网段为192.168.100.0/24,主机都加入VLAN10,该分支希望Router能够为该分支内网用户分配IP地址,并且希望内网用户可以访问外网。

由于该企业分支位于偏远区域,无法获取有线广域接入服务,因此不能使用传统的有线广域接入服务来提供数据通信和VoIP语音通信。如图5-10所示,为了满足业务传输的需求,该分支使用Router为出口网关,使用LTE Cellular接口通过LTE网络接入PGW。PGW通过Internet网关接入Internet,通过IMS网关接入IMS网络。

图5-10  LTE Cellular接口通过配置双APN通道进行数据通信和VoIP语音通信示意图

配置思路

企业分支可以使用LTE Cellular接口的双APN通道来实现同时进行数据通信和VoIP语音通信的需求。LTE Cellular接口支持配置两个LTE通道接口,用户可以在LTE通道接口上各自绑定一个APN,APN不能相同。其中一个APN用来接入Internet进行数据通信,另一个APN用来接入IMS网络进行VoIP语音通信。PGW会为LTE Cellular接口的每个LTE通道接口各自分配一个IP地址。

采用如下的配置思路:

  • 创建两个APN模板,一个模板名称对应接入Internet的APN,另一个模板名称对应接入IMS网络的APN。
  • 配置LTE Cellular接口,并在LTE Cellular接口下配置网络连接方式,以及使能多APN功能。
  • 在LTE通道接口上配置轮询DCC拨号连接。
  • 在LTE通道接口上绑定APN模板。
  • 配置企业内网,由Router为该企业分支内网用户分配IP地址。
  • 配置NAT功能,指定LTE通道接口的IP地址作为该企业分支公网地址。
  • 配置缺省路由,指定出接口为LTE通道接口,使该企业分支内网的流量通过LTE通道接口上行传输到LTE网络。

操作步骤

  1. 配置APN模板

    # 配置APN模板datanet,该模板用来接入Internet。

    <Huawei> system-view
    [Huawei] sysname Router
    [Router] apn profile datanet
    [Router-apn-profile-datanet] user name lte-example password cipher 123456 authentication-mode chap
    [Router-apn-profile-datanet] apn data
    [Router-apn-profile-datanet] quit

    # 配置APN模板voicenet,该模板用来接入IMS网络。

    [Router] apn profile voicenet
    [Router-apn-profile-voicenet] apn voice
    [Router-apn-profile-voicenet] quit

  2. 配置LTE Cellular接口

    # 配置网络连接方式。

    [Router] interface cellular 1/0/0
    [Router-Cellular1/0/0] mode lte auto

    # 使能LTE Cellular接口的多APN功能。

    [Router-Cellular1/0/0] multi-apn enable
    [Router-Cellular1/0/0] quit

  3. 在LTE通道接口上配置轮询DCC拨号连接

    # 配置拨号控制列表。

    [Router] dialer-rule
    [Router-dialer-rule] dialer-rule 1 ip permit
    [Router-dialer-rule] quit

    # 在编号为1的LTE通道接口上配置轮询DCC拨号连接,并在LTE通道接口1上绑定APN模板datanet。

    [Router] interface cellular 1/0/0:1
    [Router-Cellular1/0/0:1] ip address negotiate
    [Router-Cellular1/0/0:1] dialer enable-circular
    [Router-Cellular1/0/0:1] dialer-group 1
    [Router-Cellular1/0/0:1] dialer timer autodial 20
    [Router-Cellular1/0/0:1] dialer number *99# autodial
    [Router-Cellular1/0/0:1] apn-profile datanet
    [Router-Cellular1/0/0:1] shutdown
    [Router-Cellular1/0/0:1] undo shutdown
    [Router-Cellular1/0/0:1] quit

    # 在编号为2的LTE通道接口上配置轮询DCC拨号连接,并在LTE通道接口2上绑定APN模板voicenet。

    [Router] interface cellular 1/0/0:2
    [Router-Cellular1/0/0:2] ip address negotiate
    [Router-Cellular1/0/0:2] dialer enable-circular
    [Router-Cellular1/0/0:2] dialer-group 1
    [Router-Cellular1/0/0:2] dialer timer autodial 20
    [Router-Cellular1/0/0:2] dialer number *99# autodial
    [Router-Cellular1/0/0:2] apn-profile voicenet
    [Router-Cellular1/0/0:2] shutdown
    [Router-Cellular1/0/0:2] undo shutdown
    [Router-Cellular1/0/0:2] quit

  4. 配置企业内网

    # 创建VLAN10,将Ethernet2/0/0接口加入VLAN10。

    [Router] vlan 10
    [Router-vlan10] quit
    [Router] interface ethernet 2/0/0
    [Router-Ethernet2/0/0] port link-type trunk
    [Router-Ethernet2/0/0] port trunk allow-pass vlan 10
    [Router-Ethernet2/0/0] quit

    # 使能DHCP功能。

    [Router] dhcp enable

    # 创建全局地址池。

    [Router] ip pool 4gpool
    [Router-ip-pool-4gpool] network 192.168.100.0 mask 255.255.255.0
    [Router-ip-pool-4gpool] gateway-list 192.168.100.1
    [Router-ip-pool-4gpool] quit

    # 配置接口工作在全局地址池模式。

    [Router] interface vlanif 10
    [Router-Vlanif10] ip address 192.168.100.1 255.255.255.0
    [Router-Vlanif10] dhcp select global
    [Router-Vlanif10] quit

  5. 配置NAT功能

    [Router] acl number 3002
    [Router-acl-adv-3002] rule 5 permit ip source 192.168.100.0 0.0.0.255
    [Router-acl-adv-3002] quit
    [Router] interface cellular 1/0/0:1
    [Router-Cellular1/0/0:1] nat outbound 3002
    [Router-Cellular1/0/0:1] quit
    [Router] interface cellular 1/0/0:2
    [Router-Cellular1/0/0:2] nat outbound 3002
    [Router-Cellular1/0/0:2] quit

  6. 配置缺省路由,指定出接口为LTE通道接口

    [Router] ip route-static 1.1.1.0 255.255.255.0 cellular 0/0/0:1
    [Router] ip route-static 2.2.2.0 255.255.255.0 cellular 0/0/0:2

  7. 验证配置结果

    # 配置完成后,企业分支内网的流量通过LTE Cellular接口上行传输到LTE网络,可以通过LTE Cellular接口同时进行数据通信和VoIP语音通信。

任务示例

  • Router的配置文件

    #
     sysname Router
    #                                                                               
    vlan batch 10                       
    #
    dhcp enable  
    #                                                                               
    acl number 3002                                                                
     rule 5 permit ip source 192.168.100.0 0.0.0.255  
    #
    apn profile datanet   
     apn data  
     user name lte-example password cipher %^%#Xhc5=7"mU5o)7]/JST4$8\0CD`~a{O0Z~p+YWvY~%^%# authentication-mode chap
    apn profile voicenet  
     apn voice
    #
    interface Cellular1/0/0
     mode lte auto
     multi-apn enable
    #
    interface Cellular1/0/0:1
     dialer enable-circular 
     dialer-group 1
     apn-profile datanet 
     dialer timer autodial 20 
     dialer number *99# autodial
     nat outbound 3002  
     ip address negotiate
    #
    interface Cellular1/0/0:2
     dialer enable-circular 
     dialer-group 1 
     apn-profile voicenet 
     dialer timer autodial 20
     dialer number *99# autodial
     nat outbound 3002  
     ip address negotiate
    #
    interface Ethernet2/0/0   
     port link-type trunk  
     port trunk allow-pass vlan 10  
    #
    interface Vlanif10
     ip address 192.168.100.1 255.255.255.0   
     dhcp select global   
    #
    ip pool 4gpool  
     gateway-list 192.168.100.1  
     network 192.168.100.0 mask 255.255.255.0  
    #
    dialer-rule 
     dialer-rule 1 ip permit
    #
    ip route-static 1.1.1.0 255.255.255.0 Cellular1/0/0:1
    ip route-static 2.2.2.0 255.255.255.0 Cellular1/0/0:2
    #
    return
翻译
下载文档
更新时间:2019-11-21

文档编号:EDOC1100034263

浏览量:13162

下载量:83

平均得分:
本文档适用于这些产品

相关版本

相关文档

Share
上一页 下一页