所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S1720, S2700, S5700, S6720 V200R012(C00&C20) 配置指南-安全

本文档介绍了安全的配置,具体包括ACL配置、本机防攻击配置、MFF配置、攻击防范配置、流量抑制及风暴控制配置、ARP安全配置、端口安全配置、DHCP Snooping配置、ND Snooping配置、PPPoE+配置、IPSG配置、SAVI配置、URPF配置、Keychain配置、MPAC配置、PKI配置、业务与管理隔离配置、安全风险查询配置
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置MFF功能实现用户的二层隔离和三层互通示例

配置MFF功能实现用户的二层隔离和三层互通示例

组网需求

图3-3所示,企业某部门使用SwitchA和SwitchB作为用户主机的接入设备,SwitchC作为汇聚设备。管理员希望位于VLAN10内的用户主机在接入设备上二层隔离,并且只能通过网关进行三层通信,从而达到网关对用户流量进行监控的目的。由于主机数量较多,为了便于统一管理IP地址,该部门的用户主机均通过DHCP方式获取IP地址,管理员希望应用服务器(DHCP Server)访问用户的流量可以二层透传给用户,避免网关因转发过多应用服务器的流量而影响网关性能。

图3-3  配置MFF功能组网图

配置思路

采用如下的思路进行配置:

  1. 在SwitchA和SwitchB上配置DHCP Snooping功能,为二层隔离和三层互通功能的实现提供包含IP地址、MAC地址、VLAN等动态用户的信息。

  2. 在SwitchA和SwitchB上配置MFF功能,强制用户流量由网关进行转发,实现用户主机之间的二层隔离和三层互通,同时达到网关对用户流量进行监控的目的。

  3. 在SwitchA和SwitchB上配置DHCP Server的IP地址,使DHCP Server访问用户的流量可以二层透传给用户,从而减轻网关的负担。

操作步骤

  1. 创建VLAN并配置各接口加入VLAN

    # 在SwitchA上创建VLAN10,并将接口GE0/0/1、GE0/0/2、GE0/0/3加入到VLAN10中。

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan batch 10
    [SwitchA] interface gigabitethernet 0/0/1
    [SwitchA-GigabitEthernet0/0/1] port link-type access
    [SwitchA-GigabitEthernet0/0/1] port default vlan 10
    [SwitchA-GigabitEthernet0/0/1] quit
    [SwitchA] interface gigabitethernet 0/0/2
    [SwitchA-GigabitEthernet0/0/2] port link-type access
    [SwitchA-GigabitEthernet0/0/2] port default vlan 10
    [SwitchA-GigabitEthernet0/0/2] quit
    [SwitchA] interface gigabitethernet 0/0/3
    [SwitchA-GigabitEthernet0/0/3] port link-type trunk
    [SwitchA-GigabitEthernet0/0/3] port trunk allow-pass vlan 10
    [SwitchA-GigabitEthernet0/0/3] quit
    

    # 在SwitchB上创建VLAN10,并将接口GE0/0/1、GE0/0/2、GE0/0/3加入到VLAN10中。

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchB
    [SwitchB] vlan batch 10
    [SwitchB] interface gigabitethernet 0/0/1
    [SwitchB-GigabitEthernet0/0/1] port link-type access
    [SwitchB-GigabitEthernet0/0/1] port default vlan 10
    [SwitchB-GigabitEthernet0/0/1] quit
    [SwitchB] interface gigabitethernet 0/0/2
    [SwitchB-GigabitEthernet0/0/2] port link-type access
    [SwitchB-GigabitEthernet0/0/2] port default vlan 10
    [SwitchB-GigabitEthernet0/0/2] quit
    [SwitchB] interface gigabitethernet 0/0/3
    [SwitchB-GigabitEthernet0/0/3] port link-type trunk
    [SwitchB-GigabitEthernet0/0/3] port trunk allow-pass vlan 10
    [SwitchB-GigabitEthernet0/0/3] quit
    

  2. 配置DHCP Snooping功能

    # 在SwitchA上全局使能DHCP Snooping功能。

    [SwitchA] dhcp enable
    [SwitchA] dhcp snooping enable

    # 因所有用户主机均位于VLAN10,所以在SwitchA上使能VLAN10的DHCP Snooping功能。

    [SwitchA] vlan 10
    [SwitchA-vlan10] dhcp snooping enable
    [SwitchA-vlan10] quit
    

    # 在SwitchA上配置接口GE0/0/3为DHCP Snooping信任接口。

    [SwitchA] interface gigabitethernet 0/0/3
    [SwitchA-GigabitEthernet0/0/3] dhcp snooping trusted
    [SwitchA-GigabitEthernet0/0/3] quit
    

    # 在SwitchB上全局使能DHCP Snooping功能。

    [SwitchB] dhcp enable
    [SwitchB] dhcp snooping enable

    # 因所有用户主机均位于VLAN10,所以在SwitchB上使能VLAN10的DHCP Snooping功能。

    [SwitchB] vlan 10
    [SwitchB-vlan10] dhcp snooping enable
    [SwitchB-vlan10] quit
    

    # 在SwitchB上配置接口GE0/0/3为DHCP Snooping信任接口。

    [SwitchB] interface gigabitethernet 0/0/3
    [SwitchB-GigabitEthernet0/0/3] dhcp snooping trusted
    [SwitchB-GigabitEthernet0/0/3] quit
    

  3. 配置MFF功能

    # 在SwitchA上全局使能MFF功能。

    [SwitchA] mac-forced-forwarding enable

    # 配置SwitchA的接口GE0/0/3为MFF的网络接口。

    [SwitchA] interface gigabitethernet 0/0/3
    [SwitchA-GigabitEthernet0/0/3] mac-forced-forwarding network-port
    [SwitchA-GigabitEthernet0/0/3] quit

    # 在SwitchA上使能VLAN10的MFF功能。

    [SwitchA] vlan 10
    [SwitchA-vlan10] mac-forced-forwarding enable
    

    # 在SwitchB上全局使能MFF功能。

    [SwitchB] mac-forced-forwarding enable

    # 配置SwitchB的接口GE0/0/3为MFF的网络接口。

    [SwitchB] interface gigabitethernet 0/0/3
    [SwitchB-GigabitEthernet0/0/3] mac-forced-forwarding network-port
    [SwitchB-GigabitEthernet0/0/3] quit

    # 在SwitchB上使能VLAN10的MFF功能。

    [SwitchB] vlan 10
    [SwitchB-vlan10] mac-forced-forwarding enable

  4. 配置DHCP Server的IP地址

    # 在SwitchA上配置DHCP Server的IP地址。

    [SwitchA-vlan10] mac-forced-forwarding server 10.10.10.2
    [SwitchA-vlan10] quit

    # 在SwitchB上配置DHCP Server的IP地址。

    [SwitchB-vlan10] mac-forced-forwarding server 10.10.10.2
    [SwitchB-vlan10] quit

  5. 验证配置结果

    # 以SwitchB为例,执行命令display mac-forced-forwarding vlan 10查看VLAN10下的MFF配置情况。

    [SwitchB] display mac-forced-forwarding vlan 10
    [Vlan 10] MFF host total count = 1 
    --------------------------------------------------------------------------------
    Servers         10.10.10.2 
    --------------------------------------------------------------------------------
    User IP         User MAC                Gateway IP      Gateway MAC
    --------------------------------------------------------------------------------
    10.10.10.11     0001-0001-0001          10.10.10.1      0002-0002-0001
    --------------------------------------------------------------------------------
    

    # 以SwitchB为例,执行命令display mac-forced-forwarding network-port查看MFF的网络接口信息。

    [SwitchB] display mac-forced-forwarding network-port
    --------------------------------------------------------------------------------                
    VLAN ID                  Network-ports                       
    --------------------------------------------------------------------------------                        
    VLAN 10                  GigabitEthernet0/0/3   
    --------------------------------------------------------------------------------
    

    # 此时如果将网关连接SwitchC的接口shut down,则VLAN10内的任意两个用户主机之间不能Ping通,而将该接口恢复为正常状态后,用户就能相互Ping通,即表明已实现用户的二层隔离和三层互通,MFF功能已生效。

配置文件

  • SwitchA的配置文件

    #
    sysname SwitchA
    #
    vlan batch 10
    #
    mac-forced-forwarding enable
    #                                                                
    dhcp enable                                                     
    #                                                               
    dhcp snooping enable  
    #
    vlan 10
     dhcp snooping enable  
     mac-forced-forwarding enable
     mac-forced-forwarding server 10.10.10.2
    #
    interface GigabitEthernet0/0/1
     port link-type access
     port default vlan 10
    #
    interface GigabitEthernet0/0/2
     port link-type access
     port default vlan 10
    #
    interface GigabitEthernet0/0/3
     port link-type trunk 
     port trunk allow-pass vlan 10 
     mac-forced-forwarding network-port
     dhcp snooping trusted
    #
    return
    
  • SwitchB的配置文件

    #
    sysname SwitchB
    #
    vlan batch 10
    #
    mac-forced-forwarding enable
    #                                                     
    dhcp enable                                                 
    #                                       
    dhcp snooping enable  
    #
    vlan 10
     dhcp snooping enable  
     mac-forced-forwarding enable
     mac-forced-forwarding server 10.10.10.2
    #
    interface GigabitEthernet0/0/1
     port link-type access
     port default vlan 10
    #
    interface GigabitEthernet0/0/2
     port link-type access
     port default vlan 10
    #
    interface GigabitEthernet0/0/3
     port link-type trunk 
     port trunk allow-pass vlan 10 
     mac-forced-forwarding network-port
     dhcp snooping trusted
    #
    return
    
翻译
下载文档
更新时间:2018-12-24

文档编号:EDOC1100038434

浏览量:32328

下载量:937

平均得分:
本文档适用于这些产品
相关版本
相关文档
Share
上一页 下一页