所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S1720, S2700, S5700, S6720 V200R012(C00&C20) 配置指南-安全

本文档介绍了安全的配置,具体包括ACL配置、本机防攻击配置、MFF配置、攻击防范配置、流量抑制及风暴控制配置、ARP安全配置、端口安全配置、DHCP Snooping配置、ND Snooping配置、PPPoE+配置、IPSG配置、SAVI配置、URPF配置、Keychain配置、MPAC配置、PKI配置、业务与管理隔离配置、安全风险查询配置
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置IPSG防止主机私自更改IP地址示例(DHCP Snooping动态绑定)

配置IPSG防止主机私自更改IP地址示例(DHCP Snooping动态绑定)

组网需求

图11-14所示,Host通过Switch_1接入网络,Switch_2作为DHCP Server为Host动态分配IP地址,Gateway为企业出口网关。管理员希望Host使用动态分配的地址,不允许私自配置静态IP地址,如果私自指定IP地址将无法访问网络。

图11-14  配置IPSG防止主机私自更改IP地址(DHCP Snooping动态绑定)组网图

配置思路

采用如下的思路配置IPSG功能,实现上述需求。

  1. 在Switch_2上配置DHCP Server功能(假设地址池为10.1.1.0/24),为Host动态分配IP地址。
  2. 在Switch_1上配置DHCP Snooping功能,保证Host从合法的DHCP Server获取IP地址,同时生成DHCP Snooping动态绑定表,记录Host的IP地址、MAC地址、VLAN、接口的绑定关系。
  3. 在Switch_1连接Host的VLAN上使能IPSG功能,防止Host通过私自配置IP地址的方式访问网络。

操作步骤

  1. 在Switch_2上配置DHCP Server功能

    <HUAWEI> system-view
    [HUAWEI] sysname Switch_2
    [Switch_2] vlan batch 10
    [Switch_2] interface gigabitethernet 0/0/1 
    [Switch_2-GigabitEthernet0/0/1] port link-type trunk
    [Switch_2-GigabitEthernet0/0/1] port trunk allow-pass vlan 10
    [Switch_2-GigabitEthernet0/0/1] quit
    [Switch_2] dhcp enable
    [Switch_2] ip pool 10
    [Switch_2-ip-pool-10] network 10.1.1.0 mask 24
    [Switch_2-ip-pool-10] gateway-list 10.1.1.1
    [Switch_2-ip-pool-10] quit
    [Switch_2] interface vlanif 10
    [Switch_2-Vlanif10] ip address 10.1.1.1 255.255.255.0
    [Switch_2-Vlanif10] dhcp select global
    [Switch_2-Vlanif10] quit
    

  2. 在Switch_1上配置DHCP Snooping功能

    # 配置各接口所属VLAN。

    <HUAWEI> system-view
    [HUAWEI] sysname Switch_1
    [Switch_1] vlan batch 10
    [Switch_1] interface gigabitethernet 0/0/1 
    [Switch_1-GigabitEthernet0/0/1] port link-type access
    [Switch_1-GigabitEthernet0/0/1] port default vlan 10
    [Switch_1-GigabitEthernet0/0/1] quit
    [Switch_1] interface gigabitethernet 0/0/2 
    [Switch_1-GigabitEthernet0/0/2] port link-type access
    [Switch_1-GigabitEthernet0/0/2] port default vlan 10
    [Switch_1-GigabitEthernet0/0/2] quit
    [Switch_1] interface gigabitethernet 0/0/3 
    [Switch_1-GigabitEthernet0/0/3] port link-type trunk
    [Switch_1-GigabitEthernet0/0/3] port trunk allow-pass vlan 10
    [Switch_1-GigabitEthernet0/0/3] quit
    

    # 使能DHCP Snooping功能,并将连接DHCP Server的GE0/0/3接口配置为信任接口。

    [Switch_1] dhcp enable
    [Switch_1] dhcp snooping enable
    [Switch_1] vlan 10
    [Switch_1-vlan10] dhcp snooping enable
    [Switch_1-vlan10] dhcp snooping trusted interface gigabitethernet 0/0/3
    

  3. 在Switch_1的VLAN10上使能IPSG功能

    [Switch_1-vlan10] ip source check user-bind enable
    [Switch_1-vlan10] quit
    

  4. 验证配置结果

    Host上线后,在Switch_1上执行display dhcp snooping user-bind all命令,可以查看Host的动态绑定表信息。

    [Switch_1] display dhcp snooping user-bind all
    DHCP Dynamic Bind-table:
    Flags:O - outer vlan ,I - inner vlan ,P - Vlan-mapping
    IP Address       MAC Address     VSI/VLAN(O/I/P) Interface      Lease           
    --------------------------------------------------------------------------------
    10.1.1.254       0001-0001-0001  --  /10  /--    GE0/0/1        2014.08.17-07:31
    10.1.1.253       0002-0002-0002  --  /10  /--    GE0/0/2        2014.08.17-07:34
    --------------------------------------------------------------------------------
    print count:      2     total count:      2

    Host使用DHCP服务器动态分配的IP地址可以正常访问网络,将Host更改为与动态获得的IP地址不一样的静态IP地址后无法访问网络。

配置文件

  • Switch_1的配置文件

    #
    sysname Switch_1
    #
    vlan batch 10
    #
    dhcp enable 
    #
    dhcp snooping enable
    #
    vlan 10
     dhcp snooping enable 
     dhcp snooping trusted interface GigabitEthernet0/0/3
     ip source check user-bind enable
    #
    interface GigabitEthernet0/0/1
     port link-type access  
     port default vlan 10 
    #
    interface GigabitEthernet0/0/2
     port link-type access  
     port default vlan 10 
    #
    interface GigabitEthernet0/0/3
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    return
  • Switch_2的配置文件

    #
    sysname Switch_2
    #
    vlan batch 10 
    #
    dhcp enable 
    #
    ip pool 10
     gateway-list 10.1.1.1
     network 10.1.1.0 mask 255.255.255.0 
    #
    interface Vlanif10 
     ip address 10.1.1.1 255.255.255.0 
     dhcp select global
    # 
    interface GigabitEthernet0/0/1
     port link-type trunk 
     port trunk allow-pass vlan 10
    # 
    return
翻译
下载文档
更新时间:2018-12-24

文档编号:EDOC1100038434

浏览量:33483

下载量:966

平均得分:
本文档适用于这些产品
相关版本
相关文档
Share
上一页 下一页