所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S1720, S2700, S5700, S6720 V200R012(C00&C20) 配置指南-安全

本文档介绍了安全的配置,具体包括ACL配置、本机防攻击配置、MFF配置、攻击防范配置、流量抑制及风暴控制配置、ARP安全配置、端口安全配置、DHCP Snooping配置、ND Snooping配置、PPPoE+配置、IPSG配置、SAVI配置、URPF配置、Keychain配置、MPAC配置、PKI配置、业务与管理隔离配置、安全风险查询配置
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
在QoS中使用二层ACL实施流量监管示例

在QoS中使用二层ACL实施流量监管示例

组网需求

网络中的语音业务对应的VLAN ID为120,视频业务对应的VLAN ID为110,数据业务对应的VLAN ID为100。

Switch上需要对不同业务的报文分别进行流量监管,以将流量限制在一个合理的范围之内,并保证各业务的带宽需求。

具体配置需求如表1-26所示。

表1-26  Switch为上行流量提供的QoS保障

流量类型

CIR(kbps)

PIR(kbps)

语音

2000

10000

视频

4000

10000

数据

4000

10000

图1-19  流量监管配置组网图

配置思路

采用如下的思路配置基于ACL的简化流策略实现流量监管:
  1. 创建VLAN,并配置各接口,使用户能够通过Switch访问网络。
  2. Switch上配置ACL匹配不同的VLAN ID以区分不同的业务。
  3. Switch上配置基于ACL的流量监管,对报文分别限速。

操作步骤

  1. 创建VLAN并配置各接口

    # 在Switch上创建VLAN 100、110、120。

    <HUAWEI> system-view
    [HUAWEI] sysname Switch
    [Switch] vlan batch 100 110 120
    

    # 将接口GE0/0/1GE0/0/2的接入类型分别配置为trunk,并分别将接口GE0/0/1GE0/0/2加入VLAN 100、VLAN 110、VLAN 120。

    [Switch] interface gigabitethernet 0/0/1
    [Switch-GigabitEthernet0/0/1] port link-type trunk
    [Switch-GigabitEthernet0/0/1] port trunk allow-pass vlan 100 110 120
    [Switch-GigabitEthernet0/0/1] quit
    [Switch] interface gigabitethernet 0/0/2
    [Switch-GigabitEthernet0/0/2] port link-type trunk
    [Switch-GigabitEthernet0/0/2] port trunk allow-pass vlan 100 110 120
    [Switch-GigabitEthernet0/0/2] quit

  2. 配置ACL

    # 在Switch上创建二层ACL,对不同业务流按照其VLAN ID进行分类。

    [Switch] acl 4001
    [Switch-acl-L2-4001] rule 1 permit vlan-id 120 
    [Switch-acl-L2-4001] quit
    [Switch] acl 4002
    [Switch-acl-L2-4002] rule 1 permit vlan-id 110
    [Switch-acl-L2-4002] quit
    [Switch] acl 4003
    [Switch-acl-L2-4003] rule 1 permit vlan-id 100 
    [Switch-acl-L2-4003] quit
    

  3. 配置流量监管

    # 在Switch的接口GE0/0/1入方向上配置流量监管,对报文进行限速。

    [Switch] interface gigabitethernet 0/0/1
    [Switch-GigabitEthernet0/0/1] traffic-limit inbound acl 4001 cir 2000 pir 10000
    [Switch-GigabitEthernet0/0/1] traffic-limit inbound acl 4002 cir 4000 pir 10000
    [Switch-GigabitEthernet0/0/1] traffic-limit inbound acl 4003 cir 4000 pir 10000
    [Switch-GigabitEthernet0/0/1] quit
    

  4. 验证配置结果

    # 查看设备接口入方向上应用的ACL规则和流动作信息。

    [Switch] display traffic-applied interface gigabitethernet 0/0/1 inbound
    -----------------------------------------------------------                     
    ACL applied inbound interface GigabitEthernet0/0/1                              
                                                                                    
    ACL 4001                                                                        
     rule 1 permit vlan-id 120                                                      
    ACTIONS:                                                                        
     limit cir 2000 ,cbs 250000                                                     
           pir 10000 ,pbs 1250000                                                   
           green : pass                                                             
           yellow : pass                                                            
           red : drop                                                               
    -----------------------------------------------------------                     
                                                                                    
    ACL 4002                                                                        
     rule 1 permit vlan-id 110                                                      
    ACTIONS:                                                                        
     limit cir 4000 ,cbs 500000                                                     
           pir 10000 ,pbs 1250000                                                   
           green : pass                                                             
           yellow : pass                                                            
           red : drop                                                               
    -----------------------------------------------------------                     
                                                                                    
    ACL 4003                                                                        
     rule 1 permit vlan-id 100                                                      
    ACTIONS:                                                                        
     limit cir 4000 ,cbs 500000                                                     
           pir 10000 ,pbs 1250000                                                   
           green : pass                                                             
           yellow : pass                                                            
           red : drop                                                               
    -----------------------------------------------------------    

配置文件

Switch的配置文件

#
sysname Switch
#
vlan batch 100 110 120
#
acl number 4001  
 rule 1 permit vlan-id 120
acl number 4002  
 rule 1 permit vlan-id 110
acl number 4003  
 rule 1 permit vlan-id 100
#
interface GigabitEthernet0/0/1
 port link-type trunk
 port trunk allow-pass vlan 100 110 120
 traffic-limit inbound acl 4001 cir 2000 pir 10000 cbs 250000 pbs 1250000
 traffic-limit inbound acl 4002 cir 4000 pir 10000 cbs 500000 pbs 1250000
 traffic-limit inbound acl 4003 cir 4000 pir 10000 cbs 500000 pbs 1250000
#
interface GigabitEthernet0/0/2
 port link-type trunk
 port trunk allow-pass vlan 100 110 120
#
return
翻译
下载文档
更新时间:2018-12-24

文档编号:EDOC1100038434

浏览量:33512

下载量:969

平均得分:
本文档适用于这些产品
相关版本
相关文档
Share
上一页 下一页