所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S1720, S2700, S5700, S6720 V200R012(C00&C20) 配置指南-设备管理

本文档介绍了设备管理的配置,具体包括查看设备状态、 硬件管理、 堆叠配置、 SVF配置、 云管理、 PoE配置、 监控口配置、 OPS配置、 节能管理、 信息中心配置、 故障管理配置、 NTP配置、 以太时钟同步配置、 PTP配置。

评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置带验证的NTP广播模式示例

配置带验证的NTP广播模式示例

组网需求

图12-13所示的组网中,SwitchA、SwitchB和SwitchC在同一个局域网中。SwitchA通过无线电直接同步到权威时钟(卫星定位系统)。

用户由于计费业务需要,要求图12-13中的所有交换机的时间同步到标准时钟。

图12-13  带验证的NTP广播模式组网图

配置思路

配置NTP协议进行时间同步,采用带验证的NTP广播模式来满足客户的需求。配置思路如下:

  1. 选择SwitchA作为主时间服务器,使用本地时钟作为NTP主时钟,层数为3。

  2. 配置SwitchA为NTP广播服务器,从接口VLANIF10(对应的物理接口为GE0/0/1)向外发送广播报文。

  3. 配置SwitchB和SwitchC为NTP广播客户端。

  4. 为了加强NTP时钟同步的安全性,因此使能NTP认证功能。

操作步骤

  1. 配置各设备的IP地址

    # 在SwitchA上配置IP地址。SwitchB和SwitchC的配置与SwitchA类似,详见配置文件。

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan 10 
    [SwitchA-vlan10] quit
    [SwitchA] interface vlanif 10
    [SwitchA-Vlanif10] ip address 10.0.0.1 24
    [SwitchA-Vlanif10] quit
    [SwitchA] interface gigabitethernet 0/0/1
    [SwitchA-GigabitEthernet0/0/1] port link-type hybrid
    [SwitchA-GigabitEthernet0/0/1] port hybrid pvid vlan 10
    [SwitchA-GigabitEthernet0/0/1] port hybrid untagged vlan 10
    [SwitchA-GigabitEthernet0/0/1] quit
    

  2. 配置Switch的二层转发功能。

    <HUAWEI> system-view
    [HUAWEI] sysname Switch
    [Switch] vlan 10
    [Switch-vlan10] quit
    [Switch] interface gigabitethernet 0/0/1
    [Switch-GigabitEthernet0/0/1] port link-type hybrid
    [Switch-GigabitEthernet0/0/1] port hybrid untagged vlan 10
    [Switch-GigabitEthernet0/0/1] port hybrid pvid vlan 10
    [Switch-GigabitEthernet0/0/1] quit
    [Switch] interface gigabitethernet 0/0/2
    [Switch-GigabitEthernet0/0/2] port link-type hybrid
    [Switch-GigabitEthernet0/0/2] port hybrid untagged vlan 10
    [Switch-GigabitEthernet0/0/2] port hybrid pvid vlan 10
    [Switch-GigabitEthernet0/0/2] quit
    [Switch] interface gigabitethernet 0/0/3
    [Switch-GigabitEthernet0/0/3] port link-type hybrid
    [Switch-GigabitEthernet0/0/3] port hybrid untagged vlan 10
    [Switch-GigabitEthernet0/0/3] port hybrid pvid vlan 10
    [Switch-GigabitEthernet0/0/3] quit

  3. 配置NTP广播服务器,并启用验证

    # 配置SwitchA使用本地时钟作为NTP主时钟,层数为3。

    [SwitchA] ntp-service refclock-master 3

    # 启用NTP认证。

    [SwitchA] ntp-service authentication enable
    [SwitchA] ntp-service authentication-keyid 16 authentication-mode hmac-sha256 cipher Hello123
    [SwitchA] ntp-service reliable authentication-keyid 16

    # 配置SwitchA为NTP广播服务器,从VLANIF10发送NTP广播报文,并指定使用密钥ID 16加密。

    [SwitchA] interface vlanif 10
    [SwitchA-Vlanif10] ntp-service broadcast-server authentication-keyid 16
    [SwitchA-Vlanif10] quit

    # SwitchA作为NTP服务器,使能NTP服务器功能。

    [SwitchA] undo ntp-service server disable

  4. 配置与服务器在同一网段的NTP广播客户端SwitchB

    # 启用NTP认证。

    [SwitchB] ntp-service authentication enable
    [SwitchB] ntp-service authentication-keyid 16 authentication-mode hmac-sha256 cipher Hello123
    [SwitchB] ntp-service reliable authentication-keyid 16
    

    # 配置SwitchB为NTP广播客户端,从接口VLANIF10侦听NTP广播报文。

    [SwitchB] interface vlanif 10
    [SwitchB-Vlanif10] ntp-service broadcast-client
    [SwitchB-Vlanif10] quit

  5. 配置与服务器在同一网段的NTP广播客户端SwitchC

    # 启用NTP认证。

    [SwitchC] ntp-service authentication enable
    [SwitchC] ntp-service authentication-keyid 16 authentication-mode hmac-sha256 cipher Hello123
    [SwitchC] ntp-service reliable authentication-keyid 16
    

    # 配置SwitchC为NTP广播客户端,从接口VLANIF10侦听NTP广播报文。

    [SwitchC] interface vlanif 10
    [SwitchC-Vlanif10] ntp-service broadcast-client
    [SwitchC-Vlanif10] quit

  6. 验证配置结果

    完成以上配置后,SwitchB和SwitchC能够同步到SwitchA。

    # 查看SwitchC的NTP状态,可以看到时钟状态为“synchronized”,即,已经完成同步。时钟的层数为4,比服务器SwitchA低1级。

    [SwitchC] display ntp-service status
     clock status: synchronized
     clock stratum: 4
     reference clock ID: 10.0.0.1
     nominal frequency: 60.0002 Hz
     actual frequency: 60.0002 Hz
     clock precision: 2^18
     clock offset: 0.0000 ms
     root delay: 0.00 ms
     root dispersion: 0.42 ms
     peer dispersion: 0.00 ms
     reference time: 12:17:21.773 UTC Mar 7 2012(C7B7F851.C5EAF25B)
     synchronization state: clock synchronized  

配置文件

  • SwitchA的配置文件

    #
    sysname SwitchA
    #
    vlan batch 10
    #
    ntp-service ipv6 server disable 
    ntp-service authentication enable
    ntp-service authentication-keyid 16 authentication-mode hmac-sha256 cipher %^%#uLLi;!VFkMLO;SAD#:~GS=:/UzP~}1lS2'KT2,.T%^%# 
    ntp-service reliable authentication-keyid 16
    ntp-service refclock-master 3
    #
    interface Vlanif10
     ip address 10.0.0.1 255.255.255.0
     ntp-service broadcast-server authentication-keyid 16 
    #
    interface GigabitEthernet0/0/1
     port link-type hybrid
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
    #
    return
  • SwitchB的配置文件

    #
    sysname SwitchB
    #
    vlan batch 10
    #
    ntp-service server disable
    ntp-service ipv6 server disable 
    ntp-service authentication enable
    ntp-service authentication-keyid 16 authentication-mode hmac-sha256 cipher %^%#cVg6'G;i2*@[$uB@!^}:g$V6+~Hc}V,]M"Y/voeF%^%# 
    ntp-service reliable authentication-keyid 16
    #
    interface Vlanif10
     ip address 10.0.0.2 255.255.255.0
     ntp-service broadcast-client 
    #
    interface GigabitEthernet0/0/1
     port link-type hybrid
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
    #
    return
  • SwitchC的配置文件

    #
    sysname SwitchC
    #
    vlan batch 10
    #
    ntp-service server disable
    ntp-service ipv6 server disable 
    ntp-service authentication enable
    ntp-service authentication-keyid 16 authentication-mode hmac-sha256 cipher %^%#vLLi;!VFkMLO;SAD#:~GS=:/UzP~}1lS2'KT3,.T%^%#
    ntp-service reliable authentication-keyid 16
    #
    interface Vlanif10
     ip address 10.0.0.3 255.255.255.0
     ntp-service broadcast-client 
    #
    interface Vlanif20
     ip address 10.1.1.2 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port link-type hybrid
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
    #
    return
  • Switch的配置文件

    #
    sysname Switch
    #
    vlan batch 10
    #
    interface GigabitEthernet0/0/1
     port link-type hybrid
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
    #
    interface GigabitEthernet0/0/2
     port link-type hybrid
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
    #
    interface GigabitEthernet0/0/3
     port link-type hybrid
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
    #
    return
翻译
下载文档
更新时间:2018-12-24

文档编号:EDOC1100038438

浏览量:40277

下载量:2134

平均得分:
本文档适用于这些产品

相关版本

相关文档

Share
上一页 下一页