所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S1720, S2700, S5700, S6720 V200R012(C00&C20) 配置指南-设备管理

本文档介绍了设备管理的配置,具体包括查看设备状态、 硬件管理、 堆叠配置、 SVF配置、 云管理、 PoE配置、 监控口配置、 OPS配置、 节能管理、 信息中心配置、 故障管理配置、 NTP配置、 以太时钟同步配置、 PTP配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置通过监测用户输入实现风险提示示例

配置通过监测用户输入实现风险提示示例

组网需求

图8-4所示,用户通过远程网络对Switch进行管理,希望能够在执行风险较大的命令前,增加风险提示,经用户确认后,该命令才会执行下去,否则不执行,降低该命令行的风险。

图8-4  配置通过监测用户输入实现风险提示组网图

配置思路

采用如下的配置思路:
  1. 配置接口的IP地址作为设备的管理IP地址。

  2. 制作Python脚本riskwarning.py,在脚本中实现风险提示的功能。

  3. 通过IP地址10.2.1.1/24远程登录设备,上传Python脚本至Switch,安装脚本。

  4. 配置Python脚本助手。

操作步骤

  1. 配置接口的IP地址作为设备的管理IP地址

    # 配置接口所属VLAN。

    <HUAWEI> system-view
    [HUAWEI] sysname Switch
    [Switch] vlan batch 10
    [Switch] interface gigabitethernet 0/0/1
    [Switch-GigabitEthernet0/0/1] port link-type trunk
    [Switch-GigabitEthernet0/0/1] port trunk allow-pass vlan 10
    [Switch-GigabitEthernet0/0/1] quit

    # 配置接口的IP地址。

    [Switch] interface vlanif 10
    [Switch-Vlanif10] ip address 10.2.1.1 24
    [Switch-Vlanif10] quit
    [Switch] quit

  2. 制作Python脚本

    # 制作Python脚本riskwarning.py,主要实现以下功能:
    • 注册命令行事件,当用户执行风险命令时,触发告警信息提示。

    • 脚本可以根据用户输入,决定是否继续执行该风险命令。

  3. 上传Python脚本并安装

    # 通过IP地址10.2.1.1/24远程登录设备,将PC上的Python脚本上传到Switch上。上传文件的具体配置请参见S1720, S2700, S5700, S6720 V200R012(C00&C20) 配置指南-基础配置》中的“文件管理”。

    # 在Switch上安装Python脚本。

    <Switch> ops install file riskwarning.py

  4. 配置Python脚本助手

    # 配置Python脚本助手,注册riskwarning.py脚本中的命令行事件,等待事件触发。

    <Switch> system-view
    [Switch] ops
    [Switch-ops] script-assistant python riskwarning.py
    [Switch-ops] quit

  5. 验证配置结果

    # 上述配置完成后,用户可以执行指定风险命令,在设备查看是否有提示信息。当前脚本中指定的风险命令是系统视图下的arp learning multicast enable

    [Switch] arp learning multicast enable
    The device may be attacked by ARP attack packets with multicast MAC addresses. Are you sure to continue?[Y/N]:

    如果输入N,则设备不执行arp learning multicast enable命令。在任意视图下执行display current-configuration | include arp命令,显示结果中不包含“arp learning multicast enable”项。

    如果输入Y,则设备执行arp learning multicast enable命令。在任意视图下执行display current-configuration | include arp命令,显示结果中包含“arp learning multicast enable”项。

    说明:

    如果需要查看OPS脚本中print语句打印的信息,请通过串口登录设备。

配置文件及脚本示例

  • Switch的配置文件

    #
    sysname Switch
    #
    vlan batch 10
    #
    interface Vlanif10
     ip address 10.2.1.1 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    ops
     script-assistant python riskwarning.py
    #
    return
  • riskwarning.py脚本示例

    # -*- coding: utf-8 -*-
    import ops         # 导入ops模块
    import sys         # 导入sys模块
    import os          # 导入os模块
    # 订阅处理函数
    def ops_condition (ops):
    	# 匹配风险命令arp learning multicast enable
    	value, err_str = ops.cli.subscribe("cli1", "arp learning multicast enable", enter=True, sync=True, sync_wait=60)
    	return 0
    # 工作处理函数
    def ops_execute (ops):
    	# 获取系统环境变量_cli_vty,表示用户的通道
    	key, value = ops.environment.get("_cli_vty")
    	# 向终端打印命令行存在风险的提示信息
    	a, b = ops.terminal.write("The device may be attacked by ARP attack packets with multicast MAC addresses. Are you sure to continue?[Y/N]:", vty=key)
    	print a
    	print b
    	# 从终端读取交互过程中用户的输入
    	a, b = ops.terminal.read(maxLen=200, timeout=30, vty=key)
    	# 用户输入"Y"或"y"时,继续执行风险命令arp learning multicast enable
    	if a == "Y" or a == "y":
    		return 1
    	# 用户输入其他值时,风险命令不执行
    	else:
    		return 0
翻译
下载文档
更新时间:2018-12-24

文档编号:EDOC1100038438

浏览量:35130

下载量:2056

平均得分:
本文档适用于这些产品
相关版本
相关文档
Share
上一页 下一页