所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S1720, S2700, S5700, S6720 V200R012(C00&C20) 配置指南-设备管理

本文档介绍了设备管理的配置,具体包括查看设备状态、 硬件管理、 堆叠配置、 SVF配置、 云管理、 PoE配置、 监控口配置、 OPS配置、 节能管理、 信息中心配置、 故障管理配置、 NTP配置、 以太时钟同步配置、 PTP配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置向SNMP Agent输出Trap信息示例

配置向SNMP Agent输出Trap信息示例

组网需求

图10-9所示,SwitchA与网管站相连,SwitchA与网管站之间路由可达。网络管理员希望在网管站查看SwitchA产生的ARP模块的Trap信息,以便监控设备运行情况及定位故障信息。

图10-9  配置向SNMP Agent输出Trap信息组网图

配置思路

采用如下思路配置:

  1. 使能信息中心功能。

  2. 配置向SNMP Agent输出Trap信息的信息通道和输出规则,以实现SwitchA产生的Trap信息发往SNMP代理方向。

  3. 配置Trap信息输出到网管站,以实现网络管理员能够在网管站接收SwitchA产生的Trap信息。

操作步骤

  1. 使能信息中心功能

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] info-center enable
    

  2. 配置向SNMP代理发送Trap信息的信息通道和输出规则

    # 配置Trap信息输出到SNMP代理所使用的信息通道。

    [SwitchA] info-center snmp channel channel7
    

    # 配置向SNMP代理输出Trap信息的规则。

    [SwitchA] info-center source arp channel channel7 trap level informational state on 
    说明:

    缺省情况下,设备通过SNMP Agent输出所有模块的Trap信息。

  3. 配置发送Trap信息接口的IP地址

    [SwitchA] vlan batch 2
    [SwitchA] interface gigabitethernet 0/0/1
    [SwitchA-GigabitEthernet0/0/1] port link-type trunk
    [SwitchA-GigabitEthernet0/0/1] port trunk allow-pass vlan 2
    [SwitchA-GigabitEthernet0/0/1] quit
    [SwitchA] interface vlanif 2
    [SwitchA-Vlanif2] ip address 10.1.1.2 24
    [SwitchA-Vlanif2] quit

  4. 配置SNMP Agent输出Trap信息到网管站

    # 使能SNMP Agent,配置版本为SNMPv2c。

    [SwitchA] snmp-agent sys-info version v2c
    

    # 配置团体名。

    [SwitchA] snmp-agent community write adminnms1
    

    # 配置Trap功能。

    [SwitchA] snmp-agent trap enable
    Warning: All switches of SNMP trap/notification will be open. Continue? [Y/N]:y
    [SwitchA] snmp-agent target-host trap address udp-domain 10.1.1.1 params securityname public v2c
    [SwitchA] quit

  5. 验证配置结果

    # 查看SNMP Agent输出信息所使用的通道。

    <SwitchA> display info-center
    Information Center:enabled
    Log host:
    Console:
            channel number : 0, channel name : console
    Monitor:
            channel number : 1, channel name : monitor
    SNMP Agent:
            channel number : 7, channel name : channel7
    Log buffer:
            enabled,max buffer size 1024, current buffer size 512,
    current messages 512, channel number : 4, channel name : logbuffer
    dropped messages 0, overwritten messages 37
    Trap buffer:
            enabled,max buffer size 1024, current buffer size 256,
    current messages 185, channel number:3, channel name:trapbuffer
    dropped messages 0, overwritten messages 0
    logfile:
            channel number : 9, channel name : channel9, language : English  
    Information timestamp setting:
            log - date, trap - date, debug - date millisecond
    
     Sent messages = 273514, Received messages = 284905
    
     IO Reg messages = 2 IO Sent messages = 11392
    

    # 查看SNMP Agent所用通道输出的信息。

    <SwitchA> display channel 7
    channel number:7, channel name:channel7
    MODU_ID  NAME     ENABLE LOG_LEVEL     ENABLE TRAP_LEVEL    ENABLE DEBUG_LEVEL
    ffff0000 default  Y      debugging     Y      debugging     N      debugging
    416e0000 ARP      Y      debugging     Y      informational N      debugging
    

    # 查看SNMP Agent输出网管的信息。

    <SwitchA> display snmp-agent target-host
    Target-host NO. 1
    -----------------------------------------------------------
      IP-address    : 10.1.1.1
      Source interface : -
      VPN instance  : -
      Security name : %^%#uq/!YZfvW4*vf[~C|.:Cl}UqS(vXd#wwqR~5M(rU%%^%#
      Port          : 162
      Type          : trap
      Version       : v2c
      Level         : No authentication and privacy
      NMS type      : NMS
      With ext-vb   : No
    -----------------------------------------------------------
    

配置文件

SwitchA的配置文件

#
sysname SwitchA
# 
info-center source ARP channel 7 trap level informational
info-center snmp channel 7
#
vlan batch 2
#
interface Vlanif2
 ip address 10.1.1.2 255.255.255.0
#
interface GigabitEthernet0/0/1
 port link-type trunk
 port trunk allow-pass vlan 2
#
snmp-agent
snmp-agent local-engineid 000007DB7FFFFFFF00003B4C
snmp-agent community write cipher %^%#.T|&Whvyf$<Gd"I,wXi5SP_6~Nakk6<<+3H:N-h@aJ6d,l0md%HCeAY8~>X=>xV\JKNAL=124r839v<*%^%#
snmp-agent sys-info version v2c v3
snmp-agent target-host trap address udp-domain 10.1.1.1 params securityname cipher %^%#uq/!YZfvW4*vf[~C|.:Cl}UqS(vXd#wwqR~5M(rU%%^%# v2c
snmp-agent trap enable
#
return
翻译
下载文档
更新时间:2018-12-24

文档编号:EDOC1100038438

浏览量:34454

下载量:2036

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页