所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S1720, S2700, S5700, S6720 V200R012(C00&C20) 配置指南-设备管理

本文档介绍了设备管理的配置,具体包括查看设备状态、 硬件管理、 堆叠配置、 SVF配置、 云管理、 PoE配置、 监控口配置、 OPS配置、 节能管理、 信息中心配置、 故障管理配置、 NTP配置、 以太时钟同步配置、 PTP配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置NTP对等体模式的示例

配置NTP对等体模式的示例

组网需求

图12-12所示,在同一个局域网中有3台设备。

用户要求局域网中设备时间同步,以便网管对设备管理。其中SwitchA已经通过网络和权威时钟(卫星定位系统)同步,用户要求SwitchB和SwitchC都同步到SwitchA。

图12-12  对等体模式组网图

配置思路

配置NTP协议进行时间同步,采用NTP对等体模式来满足客户时间同步的需求。配置思路如下:

  1. 选择SwitchA的本地时钟作为NTP主时钟
  2. SwitchB和SwitchA之间采用单播NTP服务器/客户端模实现时钟同步。SwitchA作为服务器,SwitchB作为客户端。
  3. SwitchB和SwitchC之间采用对等体模式实现时钟同步,SwitchC作为主动对等体向SwitchB发起时钟同步请求。

操作步骤

  1. 配置SwitchA、SwitchB、SwitchC的IP地址

    按照图12-12给每个接口配置IP地址。配置完成后,3台Switch之间可以互相ping通。

    # 在SwitchA上配置IP地址。SwitchB和SwitchC的配置与SwitchA类似,详见配置文件。

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan 10
    [SwitchA-vlan10] quit
    [SwitchA] interface vlanif 10
    [SwitchA-Vlanif10] ip address 10.0.0.1 24
    [SwitchA-Vlanif10] quit
    [SwitchA] interface gigabitethernet 0/0/1
    [SwitchA-GigabitEthernet0/0/1] port link-type hybrid
    [SwitchA-GigabitEthernet0/0/1] port hybrid untagged vlan 10
    [SwitchA-GigabitEthernet0/0/1] port hybrid pvid vlan 10
    [SwitchA-GigabitEthernet0/0/1] quit

  2. 配置Switch的二层转发功能。

    <HUAWEI> system-view
    [HUAWEI] sysname Switch
    [Switch] vlan 10
    [Switch-vlan10] quit
    [Switch] interface gigabitethernet 0/0/1
    [Switch-GigabitEthernet0/0/1] port link-type hybrid
    [Switch-GigabitEthernet0/0/1] port hybrid untagged vlan 10
    [Switch-GigabitEthernet0/0/1] port hybrid pvid vlan 10
    [Switch-GigabitEthernet0/0/1] quit
    [Switch] interface gigabitethernet 0/0/2
    [Switch-GigabitEthernet0/0/2] port link-type hybrid
    [Switch-GigabitEthernet0/0/2] port hybrid untagged vlan 10
    [Switch-GigabitEthernet0/0/2] port hybrid pvid vlan 10
    [Switch-GigabitEthernet0/0/2] quit
    [Switch] interface gigabitethernet 0/0/3
    [Switch-GigabitEthernet0/0/3] port link-type hybrid
    [Switch-GigabitEthernet0/0/3] port hybrid untagged vlan 10
    [Switch-GigabitEthernet0/0/3] port hybrid pvid vlan 10
    [Switch-GigabitEthernet0/0/3] quit

  3. 配置NTP客户端/服务器模式

    # 将SwitchA的本地时钟设为NTP主时钟,层数为2。

    [SwitchA] ntp-service refclock-master 2

    # SwitchA作为NTP服务器,使能NTP服务器功能。

    [SwitchA] undo ntp-service server disable

    # 在SwitchB上指定SwitchA作为SwitchB的NTP服务器。

    [SwitchB] ntp-service unicast-server 10.0.0.1

    # 使能NTP服务器功能。

    [SwitchB] undo ntp-service server disable

    完成上述配置后,SwitchB可以同步SwitchA的时钟。

    查看SwitchB的NTP状态,可以看到时钟状态为“synchronized”,即,已经完成同步。时钟的层数为3,比SwitchA低1级。

    [SwitchB] display ntp-service status
     clock status: synchronized
     clock stratum: 3
     reference clock ID: 10.0.0.1
     nominal frequency: 64.0029 Hz
     actual frequency: 64.0029 Hz
     clock precision: 2^7
     clock offset: 0.0000 ms
     root delay: 62.50 ms
     root dispersion: 0.20 ms
     peer dispersion: 7.81 ms
     reference time: 06:52:33.465 UTC Mar 7 2006(C7B7AC31.773E89A8)
     synchronization state: clock set

  4. 配置NTP对等体模式

    # 在SwitchC上指定SwitchB作为自己的被动对等体。

    [SwitchC] ntp-service unicast-peer 10.0.0.2

    # 使能NTP服务器功能。

    [SwitchC] undo ntp-service server disable

    由于SwitchC没有配置主时钟,并且其时钟层数低于SwitchB,所以SwitchC向SwitchB同步。

  5. 验证配置结果

    # 查看SwitchC的时钟状态,时钟状态为“synchronized”,层数为4,比被动对等体SwitchB低1级。

    [SwitchC] display ntp-service status
     clock status: synchronized
     clock stratum: 4
     reference clock ID: 10.0.0.2
     nominal frequency: 64.0029 Hz
     actual frequency: 64.0029 Hz
     clock precision: 2^7
     clock offset: 0.0000 ms
     root delay: 124.98 ms
     root dispersion: 0.15 ms
     peer dispersion: 10.96 ms
     reference time: 06:55:50.784 UTC Mar 7 2006(C7B7ACF6.C8D002E2)
     synchronization state: clock set but frequency not determined

配置文件

  • SwitchA的配置文件

    #
    sysname SwitchA
    #
    vlan batch 10
    #
    ntp-service ipv6 server disable 
    ntp-service refclock-master 2 
    #
    interface Vlanif10
     ip address 10.0.0.1 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port link-type hybrid
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
    #
    return
  • SwitchB的配置文件

    #
    sysname SwitchB
    #
    vlan batch 10
    #
    ntp-service ipv6 server disable 
    ntp-service unicast-server 10.0.0.1
    #
    interface Vlanif10
     ip address 10.0.0.2 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port link-type hybrid
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
    #
    return
  • SwitchC的配置文件

    #
    sysname SwitchC
    #
    vlan batch 10
    #
    ntp-service ipv6 server disable 
    ntp-service unicast-peer 10.0.0.2
    #
    interface Vlanif10
     ip address 10.0.0.3 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port link-type hybrid
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
    #
    return
  • Switch的配置文件

    #
    sysname Switch
    #
    vlan batch 10
    #
    interface GigabitEthernet0/0/1
     port link-type hybrid
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
    #
    interface GigabitEthernet0/0/2
     port link-type hybrid
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
    #
    interface GigabitEthernet0/0/3
     port link-type hybrid
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
    #
    return
翻译
下载文档
更新时间:2018-12-24

文档编号:EDOC1100038438

浏览量:34828

下载量:2050

平均得分:
本文档适用于这些产品
相关版本
相关文档
Share
上一页 下一页