所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S1720, S2700, S5700, S6720 V200R012(C00&C20) 配置指南-设备管理

本文档介绍了设备管理的配置,具体包括查看设备状态、 硬件管理、 堆叠配置、 SVF配置、 云管理、 PoE配置、 监控口配置、 OPS配置、 节能管理、 信息中心配置、 故障管理配置、 NTP配置、 以太时钟同步配置、 PTP配置。

评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置通过用户自定义环境变量监测堆叠系统状态变化示例

配置通过用户自定义环境变量监测堆叠系统状态变化示例

组网需求

图8-5所示,用户通过远程网络对堆叠系统进行管理,希望能够在堆叠系统中指定的成员交换机重启时及时感知该变化,并记录日志。

图8-5  配置监测堆叠系统状态变化记录日志组网图

配置思路

采用如下的配置思路:
  1. 配置堆叠系统主交换机Switch上接口VLANIF 10的IP地址为堆叠系统的管理IP地址。

  2. 制作Python脚本slot_syslog.py,在脚本中实现监测堆叠系统成员交换机是否重启并记录日志的功能。

  3. 通过IP地址10.2.1.1/24远程登录设备,上传Python脚本至Switch,安装脚本。

  4. 配置用户自定义环境变量,指定需要监测的成员交换机的堆叠ID。通过自定义环境变量,用户可以切换需要监测的成员交换机而无需重新编写Python脚本。

  5. 配置Python脚本助手。

操作步骤

  1. 配置堆叠系统主交换机Switch上接口VLANIF 10的IP地址为堆叠系统的管理IP地址

    # 配置接口所属VLAN。

    <HUAWEI> system-view
    [HUAWEI] sysname Switch
    [Switch] vlan batch 10
    [Switch] interface gigabitethernet 1/0/1
    [Switch-GigabitEthernet1/0/1] port link-type trunk
    [Switch-GigabitEthernet1/0/1] port trunk allow-pass vlan 10
    [Switch-GigabitEthernet1/0/1] quit

    # 配置接口的IP地址。

    [Switch] interface vlanif 10
    [Switch-Vlanif10] ip address 10.2.1.1 24
    [Switch-Vlanif10] quit
    [Switch] quit

  2. 制作Python脚本

    # 制作Python脚本slot_syslog.py,主要实现以下功能:
    • 订阅堆叠系统状态变化事件,监测堆叠系统成员交换机是否重启,当重启时记录日志。

    • 用户可以指定需要监测的成员交换机的堆叠ID

  3. 上传Python脚本并安装

    # 通过IP地址10.2.1.1/24远程登录设备,将PC上的Python脚本上传到Switch上。上传文件的具体配置请参见S1720, S2700, S5700, S6720 V200R012(C00&C20) 配置指南-基础配置》中的“文件管理”。

    # 在Switch上安装Python脚本。

    <Switch> ops install file slot_syslog.py

  4. 配置用户自定义环境变量

    # 通过配置用户自定义环境变量slotid,指定需要监测的成员交换机的堆叠ID,并且无需重新编写Python脚本即可切换需要监测的成员交换机。例如,当需要监测成员交换机SwitchB时,配置slotid的值为2;当需要监测的成员交换机改成SwitchC时,配置slotid的值为3。这里以slotid取值为2为例。

    <Switch> system-view
    [Switch] ops
    [Switch-ops] environment slotid 2

  5. 配置Python脚本助手

    # 配置Python脚本助手,注册slot_syslog.py脚本中订阅的事件,等待事件触发。

    [Switch-ops] script-assistant python slot_syslog.py
    [Switch-ops] quit

  6. 验证配置结果

    # 打开日志开关,当用户自定义环境变量slotid取值为2,且成员交换机SwitchB重启时,Switch会输出日志。

    [Switch] info-center enable
    [Switch] quit
    <Switch> terminal monitor
    <Switch> terminal logging
    <Switch>
    Apr 08 2018 14:29:17+08:00 Switch %%01OPSA/6/SCRIPT_LOG: OPS: Slot 2 has been reset. (user="slot_syslog.py", session=864036019).

配置文件及脚本示例

  • Switch的配置文件

    #
    sysname Switch
    #
    vlan batch 10
    #
    interface Vlanif10
     ip address 10.2.1.1 255.255.255.0
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    ops
     script-assistant python slot_syslog.py
     environment slotid 2
    #
    return
  • slot_syslog.py脚本示例

    # -*- coding: utf-8 -*-
    import ops         # 导入ops模块
    import sys         # 导入sys模块
    import os          # 导入os模块
    # 订阅处理函数
    def ops_condition (ops):
    	# 获取用户自定义环境变量slotid的值
    	slotid, errstr = ops.environment.get("slotid")
    	# 监测对应slot的成员交换机重启事件
    	slot = "slot " + slotid
    	value1, err_str1 = ops.device.subscribe("a12", slot, "RESET")
    	return 0
    # 工作处理函数
    def ops_execute (ops):
    	# 获取用户自定义环境变量slotid的值
    	slotid, errstr = ops.environment.get("slotid")
    	slot = "slot " + slotid
    	logstring = "Slot %s has been reset." %slotid
    	#打印用户日志Slot x has been reset.
    	status, err_log = ops.syslog(logstring, "informational", "syslog")
翻译
下载文档
更新时间:2018-12-24

文档编号:EDOC1100038438

浏览量:39424

下载量:2128

平均得分:
本文档适用于这些产品

相关版本

相关文档

Share
上一页 下一页