所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S1720, S2700, S5700, S6720 V200R012(C00&C20) 配置指南-设备管理

本文档介绍了设备管理的配置,具体包括查看设备状态、 硬件管理、 堆叠配置、 SVF配置、 云管理、 PoE配置、 监控口配置、 OPS配置、 节能管理、 信息中心配置、 故障管理配置、 NTP配置、 以太时钟同步配置、 PTP配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置带验证的单播NTP服务器/客户端模式示例

配置带验证的单播NTP服务器/客户端模式示例

组网需求

图12-11所示的组网中,SwitchA、SwitchB和SwitchC相连。SwitchA的时间已经同步到权威时钟(卫星定位系统)。

用户要求由SwitchB和SwitchC时间同步到SwitchA以保证计费业务的准确性。

图12-11  单播NTP客户端/服务器模式组网图

配置思路

配置带验证的单播服务器/客户端模式来满足客户对局域网时间同步的需求。配置思路如下:

  1. 选择SwitchA作为主时间服务器。

  2. SwitchA与SwitchB和SwitchC之间采用单播NTP服务器/客户端模实现时钟同步。SwitchA作为服务器,SwitchB和SwitchC作为客户端。

  3. 为了加强NTP时钟同步的安全性,因此使能NTP认证功能。

说明:

在单播服务器/客户端模式下配置NTP认证时,必须首先在客户端使能NTP认证,然后再指定NTP服务器地址,并同时指定发给服务器的验证密钥。否则将不进行验证,直接同步。

操作步骤

  1. 配置SwitchA、SwitchB和SwitchC地址,保证SwitchA,SwitchB和SwitchC路由可达

    # 在SwitchA上配置IP地址和路由。

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan 100
    [SwitchA-vlan100] quit
    [SwitchA] interface vlanif 100
    [SwitchA-Vlanif100] ip address 10.1.1.1 24
    [SwitchA-Vlanif100] quit
    [SwitchA] interface gigabitethernet 0/0/1
    [SwitchA-GigabitEthernet0/0/1] port link-type trunk
    [SwitchA-GigabitEthernet0/0/1] port trunk allow-pass vlan 100
    [SwitchA-GigabitEthernet0/0/1] quit
    [SwitchA] ip route-static 10.1.2.0 24 10.1.1.2

    # 在SwitchB上配置IP地址。

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchB
    [SwitchB] vlan 100
    [SwitchB-vlan100] quit
    [SwitchB] interface vlanif 100
    [SwitchB-Vlanif100] ip address 10.1.1.2 24
    [SwitchB-Vlanif100] quit
    [SwitchB] vlan 10
    [SwitchB-vlan10] quit
    [SwitchB] interface vlanif 10
    [SwitchB-Vlanif10] ip address 10.1.2.1 24
    [SwitchB-Vlanif10] quit
    [SwitchB] interface gigabitethernet 0/0/1
    [SwitchB-GigabitEthernet0/0/1] port link-type trunk
    [SwitchB-GigabitEthernet0/0/1] port trunk allow-pass vlan 100
    [SwitchB-GigabitEthernet0/0/1] quit
    [SwitchB] interface gigabitethernet 0/0/2
    [SwitchB-GigabitEthernet0/0/2] port link-type trunk
    [SwitchB-GigabitEthernet0/0/2] port trunk allow-pass vlan 10
    [SwitchB-GigabitEthernet0/0/2] quit

    # 在SwitchC上配置IP地址和路由。

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchC
    [SwitchC] vlan 10
    [SwitchC-vlan10] quit
    [SwitchC] interface vlanif 10
    [SwitchC-Vlanif10] ip address 10.1.2.2 24
    [SwitchC-Vlanif10] quit
    [SwitchC] interface gigabitethernet 0/0/1
    [SwitchC-GigabitEthernet0/0/1] port link-type trunk
    [SwitchC-GigabitEthernet0/0/1] port trunk allow-pass vlan 10
    [SwitchC-GigabitEthernet0/0/1] quit
    [SwitchC] ip route-static 10.1.1.0 24 10.1.2.1

  2. SwitchA上配置NTP主时钟并启动NTP认证功能

    # 在SwitchA上指定使用自己的本地时钟作为主时钟,层数为2。

    [SwitchA] ntp-service refclock-master 2

    # 使能NTP认证功能、配置验证密钥并声明该密钥可信。

    [SwitchA] ntp-service authentication enable
    [SwitchA] ntp-service authentication-keyid 42 authentication-mode hmac-sha256 cipher Hello123
    [SwitchA] ntp-service reliable authentication-keyid 42

    # SwitchA作为服务器需要使能NTP服务器功能。

    [SwitchA] undo ntp-service server disable
    

  3. SwitchB上使能NTP认证功能并配置验证密钥并声明该密钥可信,指定SwitchA作为NTP服务器

    [SwitchB] ntp-service authentication enable
    [SwitchB] ntp-service authentication-keyid 42 authentication-mode hmac-sha256 cipher Hello123
    [SwitchB] ntp-service reliable authentication-keyid 42
    [SwitchB] ntp-service unicast-server 10.1.1.1 authentication-keyid 42

  4. SwitchC上使能NTP认证功能并配置验证密钥并声明该密钥可信,指定SwitchA作为NTP服务器

    [SwitchC] ntp-service authentication enable
    [SwitchC] ntp-service authentication-keyid 42 authentication-mode hmac-sha256 cipher Hello123
    [SwitchC] ntp-service reliable authentication-keyid 42
    [SwitchC] ntp-service unicast-server 10.1.1.1 authentication-keyid 42

  5. 验证配置结果

    # 查看SwitchA的NTP状态。

    [SwitchA] display ntp-service status
     clock status: synchronized
     clock stratum: 2
     reference clock ID: LOCAL(0)        
     nominal frequency: 100.0000 Hz          
     actual frequency: 100.0000 Hz              
     clock precision: 2^17             
     clock offset: 0.0000 ms          
     root delay: 0.00 ms                
     root dispersion: 10.96 ms        
     peer dispersion: 10.00 ms             
     reference time: 08:54:40.010 UTC Nov 22 2013(D6399696.029E9079)
     synchronization state: clock synchronized 

    # 查看SwitchB的NTP状态,可以看到时钟状态为“synchronized”,即,已经完成同步。时钟的层数为3,比服务器SwitchA低1级。

    [SwitchB] display ntp-service status
     clock status: synchronized
     clock stratum: 3
     reference clock ID: 10.1.1.1
     nominal frequency: 100.0000 Hz        
     actual frequency: 100.0000 Hz        
     clock precision: 2^18        
     clock offset: -1.6796 ms      
     root delay: 2.71 ms         
     root dispersion: 21.87 ms           
     peer dispersion: 10.94 ms          
     reference time: 08:54:44.160 UTC Nov 22 2013(D6399A54.29247CB7)    
     synchronization state: clock synchronized 

    # 查看SwitchC的NTP状态,可以看到时钟状态为“synchronized”,即,已经完成同步。时钟的层数为3,比服务器SwitchA低1级。

    [SwitchC] display ntp-service status
     clock status: synchronized
     clock stratum: 3
     reference clock ID: 10.1.1.1
     nominal frequency: 100.0000 Hz        
     actual frequency: 100.0000 Hz        
     clock precision: 2^18        
     clock offset: 13.6320 ms      
     root delay: 2.71 ms         
     root dispersion: 2.76 ms           
     peer dispersion: 10.94 ms          
     reference time: 08:57:44.160 UTC Nov 22 2013(D6399E4E.052B2BFD)    
     synchronization state: clock synchronized 

配置文件

  • SwitchA的配置文件

    #
    sysname SwitchA
    #
    vlan batch 100
    #
    ntp-service ipv6 server disable   
    ntp-service authentication enable
    ntp-service authentication-keyid 42 authentication-mode hmac-sha256 cipher %^%#uLLi;!VFkMLO;SAD#:~GS=:/UzP~}1lS2'KT2,.T%^%#
    ntp-service reliable authentication-keyid 42                                    
    ntp-service refclock-master 2 
    #
    interface Vlanif100
     ip address 10.1.1.1 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    ip route-static 10.1.1.0 255.255.255.0 10.1.2.1 
    #
    return
  • SwitchB的配置文件

    #
    sysname SwitchB
    #
    vlan batch 10 100
    #
    ntp-service server disable
    ntp-service ipv6 server disable
    ntp-service authentication enable
    ntp-service authentication-keyid 42 authentication-mode hmac-sha256 cipher %^%#cVg6'G;i2*@[$uB@!^}:g$V6+~Hc}V,]M"Y/voeF%^%#
    ntp-service reliable authentication-keyid 42
    ntp-service unicast-server 10.1.1.1 authentication-keyid 42
    #
    interface Vlanif100
     ip address 10.1.1.2 255.255.255.0
    #
    interface Vlanif10
     ip address 10.1.2.1 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    return
  • SwitchC的配置文件

    #
    sysname SwitchC
    #
    vlan batch 10
    #
    ntp-service server disable
    ntp-service ipv6 server disable
    ntp-service authentication enable
    ntp-service authentication-keyid 42 authentication-mode hmac-sha256 cipher %^%#G;i2;!VFkMLO;SAD#:~GS=:/UzP~}1lS2'KT2,.T%^%#
    ntp-service reliable authentication-keyid 42
    ntp-service unicast-server 10.1.1.1 authentication-keyid 42
    #
    interface Vlanif10
     ip address 10.1.2.2 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    ip route-static 10.1.1.0 255.255.255.0 10.1.2.1
    #
    return
翻译
下载文档
更新时间:2018-12-24

文档编号:EDOC1100038438

浏览量:36180

下载量:2084

平均得分:
本文档适用于这些产品
相关版本
相关文档
Share
上一页 下一页