所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S1720, S2700, S5700, S6720 V200R012(C00&C20) 配置指南-用户接入与认证

本文档介绍了用户接入与认证的配置,具体包括AAA配置、NAC配置和策略联动配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置用户通过Telnet登录设备的身份认证示例(AAA本地认证)

配置用户通过Telnet登录设备的身份认证示例(AAA本地认证)

组网需求

图1-29所示,企业希望管理员能简单方便并且安全地远程管理设备,可以配置通过Telnet登录设备时使用AAA本地认证:

  1. 管理员输入正确的用户名和密码才能通过Telnet登录设备。
  2. 管理员通过Telnet登录设备后,可以执行命令级别为0~15的所有命令行。
图1-29  配置用户通过Telnet登录设备的身份认证组网图(AAA本地认证)

配置思路

采用如下思路配置用户通过Telnet登录设备的身份认证:

  1. 配置Switch的接口IP地址。
  2. 使能Telnet服务器功能。
  3. 配置VTY用户界面的验证方式为aaa。
  4. 配置AAA本地认证:创建用户名和密码、配置用户的接入类型、配置用户级别。

操作步骤

  1. 配置Switch的接口IP地址

    <HUAWEI> system-view
    [HUAWEI] sysname Switch
    [Switch] vlan batch 100
    [Switch] interface vlanif 100
    [Switch-Vlanif100] ip address 10.1.2.10 24
    [Switch-Vlanif100] quit
    [Switch] interface gigabitethernet 0/0/1
    [Switch-GigabitEthernet0/0/1] port link-type hybrid
    [Switch-GigabitEthernet0/0/1] port hybrid pvid vlan 100
    [Switch-GigabitEthernet0/0/1] port hybrid untagged vlan 100
    [Switch-GigabitEthernet0/0/1] quit
    

  2. 使能Telnet服务器功能

    [Switch] telnet server enable
    

  3. 配置VTY用户界面的验证方式为aaa

    [Switch] user-interface maximum-vty 15
    [Switch] user-interface vty 0 14
    [Switch-ui-vty0-14] authentication-mode aaa  
    [Switch-ui-vty0-14] protocol inbound telnet 
    [Switch-ui-vty0-14] quit
    

  4. 配置AAA本地认证

    [Switch] aaa
    [Switch-aaa] local-user user1 password irreversible-cipher Huawei@123
    [Switch-aaa] local-user user1 service-type telnet
    [Switch-aaa] local-user user1 privilege level 15
    [Switch-aaa] quit
    
    说明:

    管理员输入的用户名不包含域名时,使用全局默认管理域default_admin认证,default_admin使用缺省的认证方案default和计费方案default。

    • 认证方案default:采用本地认证方式。
    • 计费方案default:采用不计费方式。

  5. 验证配置结果

    管理员在PC上单击“运行”->输入“cmd”,进入Windows的命令行提示符界面,执行telnet命令,并输入用户名user1和密码Huawei@123,通过Telnet方式登录设备。

    C:\Documents and Settings\Administrator> telnet 10.1.2.10
    Username:user1
    Password:***********

配置文件

Switch的配置文件

#
sysname Switch
#
vlan batch 100
#
telnet server enable
#
aaa                                                                             
 local-user user1 password irreversible-cipher $1a$+:!j;\;$Z!$&%}p%ctzj"W`GM;APoC=XPLB=L-vJG3-'3Dhyci;$
 local-user user1 privilege level 15                                                       
 local-user user1 service-type telnet
#
 interface Vlanif100
 ip address 10.1.2.10 255.255.255.0                                          
#
interface GigabitEthernet0/0/1
 port link-type hybrid
 port hybrid pvid vlan 100
 port hybrid untagged vlan 100   
# 
user-interface maximum-vty 15                                                   
user-interface vty 0 14                                                         
 authentication-mode aaa 
 protocol inbound telnet                                                     
#
return 
翻译
下载文档
更新时间:2018-12-24

文档编号:EDOC1100038441

浏览量:30657

下载量:1237

平均得分:
本文档适用于这些产品
相关版本
相关文档
Share
上一页 下一页