所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S1720, S2700, S5700, S6720 V200R012(C00&C20) 配置指南-用户接入与认证

本文档介绍了用户接入与认证的配置,具体包括AAA配置、NAC配置和策略联动配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置二层端口的混合认证示例

配置二层端口的混合认证示例

组网需求

图3-21所示,某公司内部大量用户终端通过Switch(作为接入设备)的接口GE0/0/1接入网络。为了更有效的管理用户,该公司决定控制用户接入网络,要求只有通过认证的用户才能接入网络。同时,考虑到用户终端的多样性,管理员需要部署混合认证方式对用户进行接入控制。

图3-21  配置混合认证组网图

配置思路

采用如下思路配置混合认证:

  1. 创建并配置RADIUS服务器模板、AAA方案以及认证域,并在认证域下绑定RADIUS服务器模板与AAA方案。保证了Switch与RADIUS服务器之间的信息交互。
  2. 配置内置Portal认证,使用户终端能够通过Portal认证方式接入网络。
  3. 配置802.1X认证,使用户终端能够通过802.1X认证方式接入网络。
  4. 配置MAC认证,使用户终端能够通过MAC认证方式接入网络。
说明:

本举例只包括Switch上的配置,LAN Switch和RADIUS服务器的配置这里不做相关说明。

操作步骤

  1. 创建VLAN并配置接口允许通过的VLAN,保证网络通畅。

    # 创建VLAN10和VLAN20。

    <HUAWEI> system-view
    [HUAWEI] sysname Switch
    [Switch] vlan batch 10 20
    

    # 配置Switch与用户连接的接口GE0/0/1为Access类型接口,并将GE0/0/1加入VLAN10。

    [Switch] interface gigabitethernet 0/0/1
    [Switch-GigabitEthernet0/0/1] port link-type access
    [Switch-GigabitEthernet0/0/1] port default vlan 10 
    [Switch-GigabitEthernet0/0/1] quit
    说明:

    设备与用户连接的接口类型与接口加入的VLAN应以用户实际所属VLAN为准,此处假设所有的用户都被划分到VLAN10。

    # 配置Switch连接RADIUS服务器的接口GE0/0/2为Access类型接口,并将GE0/0/2加入VLAN20。

    [Switch] interface gigabitethernet 0/0/2
    [Switch-GigabitEthernet0/0/2] port link-type access
    [Switch-GigabitEthernet0/0/2] port default vlan 20
    [Switch-GigabitEthernet0/0/2] quit

  2. 创建并配置RADIUS服务器模板、AAA认证方案以及认证域。

    # 创建并配置RADIUS服务器模板“rd1”。

    [Switch] radius-server template rd1
    [Switch-radius-rd1] radius-server authentication 192.168.2.30 1812
    [Switch-radius-rd1] radius-server shared-key cipher Huawei@2012
    [Switch-radius-rd1] quit

    # 创建AAA方案“abc”并配置认证方式为RADIUS。

    [Switch] aaa
    [Switch-aaa] authentication-scheme abc
    [Switch-aaa-authen-abc] authentication-mode radius
    [Switch-aaa-authen-abc] quit

    # 创建认证域“isp1”,并在其上绑定AAA认证方案“abc”与RADIUS服务器模板“rd1”。

    [Switch-aaa] domain isp1
    [Switch-aaa-domain-isp1] authentication-scheme abc
    [Switch-aaa-domain-isp1] radius-server rd1
    [Switch-aaa-domain-isp1] quit
    [Switch-aaa] quit

    # 配置全局默认域为“isp1”。用户进行接入认证时,以格式“user@isp1”输入用户名即可在isp1域下进行aaa认证。如果用户名中不携带域名或携带的域名不存在,用户将会在默认域中进行认证。

    [Switch] domain isp1

    # 测试用户是否能够通过RADIUS模板的认证。(已在RADIUS服务器上配置了测试用户test@huawei.com,用户密码Huawei2012)

    [Switch] test-aaa test@huawei.com Huawei2012 radius-template rd1
    Info: Account test succeed.

  3. 配置内置Portal认证。

    # 将NAC配置模式切换成传统模式。

    [Switch] undo authentication unified-mode
    Warning: Switching the authentication mode will take effect after system restart
    . Some configurations are invalid after the mode is switched. For the invalid co
    mmands, see the user manual. Save the configuration file and reboot now? [Y/N] y
    说明:
    • 缺省情况下,NAC配置模式为统一模式。
    • 统一模式切换到传统模式后,管理员必须保存配置并重启设备,新配置模式的各项功能才能生效。

    # 创建一个Loopback接口,并配置该Loopback接口的IP地址。

    [HUAWEI] interface loopback 6
    [HUAWEI-LoopBack6] ip address 192.168.1.30 32
    [HUAWEI-LoopBack6] quit

    # 配置内置Portal服务器的IP地址。

    [HUAWEI] portal local-server ip 192.168.1.30

    # 配置打开内置Portal认证网页时所需的SSL策略。

    [HUAWEI] ssl policy huawei
    [HUAWEI-ssl-policy-huawei] certificate load asn1-cert servercert.der key-pair dsa key-file serverkey.der
    [HUAWEI-ssl-policy-huawei] quit
    说明:

    为SSL策略加载证书时,需确保设备上已存在所需的证书文件和密钥对文件,否则加载不成功。另外,证书文件和密钥对文件必须保存在系统根目录下名为security的子目录下,如果没有security目录,则需要创建此目录。

    # 使能内置Portal认证功能。

    [HUAWEI] portal local-server https ssl-policy huawei
    [HUAWEI] interface gigabitethernet 0/0/1
    [HUAWEI-GigabitEthernet0/0/1] portal local-server enable
    [HUAWEI-GigabitEthernet0/0/1] quit

  4. 配置802.1X认证。

    # 全局下使能802.1X认证。

    [HUAWEI] dot1x enable
    

    # 在接口下使能802.1X认证。

    [HUAWEI] interface gigabitethernet 0/0/1
    [HUAWEI-GigabitEthernet0/0/1] dot1x enable
    [HUAWEI-GigabitEthernet0/0/1] quit

  5. 配置MAC认证。

    # 全局下使能MAC认证。

    [HUAWEI] mac-authen

    # 在接口下使能MAC认证。

    [HUAWEI] interface gigabitethernet 0/0/1
    [HUAWEI-GigabitEthernet0/0/1] mac-authen
    [HUAWEI-GigabitEthernet0/0/1] quit
    [HUAWEI] quit

  6. 验证配置结果。

    1. 执行命令display dot1xdisplay mac-authendisplay portal local-server能够查看到在接口GE0/0/1上已使能了802.1X认证、MAC认证以及内置Portal认证。
    2. 用户通过802.1X认证、MAC认证或内置Portal认证中的任意一种即可接入网络。
    3. 用户上线后,管理员可在设备上执行命令display access-user interface gigabitethernet0/0/1查看接口下所有在线用户信息。

配置文件

Switch的配置文件

#
sysname Switch 
#                                                                               
vlan batch 10 20
#                                                                               
undo authentication unified-mode
#                                                                               
domain isp1
#                                                                               
dot1x enable  
mac-authen
#                                                                                             
portal local-server ip 192.168.1.30                                             
portal local-server https ssl-policy huawei
#
radius-server template rd1
 radius-server shared-key cipher %^%#t67cDelRvAQg;*"4@P/3~q_31Sn{ST\V8'Ci633)%^%#
 radius-server authentication 192.168.2.30 1812 weight 80
#
aaa
 authentication-scheme abc
  authentication-mode radius
 domain isp1
  authentication-scheme abc
  radius-server rd1
#
interface GigabitEthernet0/0/1
 port link-type access
 port default vlan 10  
 portal local-server enable 
 dot1x enable                                                               
 mac-authen
#                                                                              
interface GigabitEthernet0/0/2            
 port link-type access                                                          
 port default vlan 20
#                                                                               
interface LoopBack6                                                             
 ip address 192.168.1.30 255.255.255.255 
#                                                                               
ssl policy huawei                                                                    
 certificate load asn1-cert servercert.der key-pair dsa key-file serverkey.der
#
return
翻译
下载文档
更新时间:2018-12-24

文档编号:EDOC1100038441

浏览量:29478

下载量:1201

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页