所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S7700, S7900, S9700 V200R012(C00&C10) 配置指南-IP业务

本文档介绍了IP业务的配置,具体包括IP地址配置、ARP配置、DHCP配置、DNS配置、mDNS网关配置、mDNS中继配置、UDP Helper配置、IP性能优化配置、IPv6基础配置、DHCPv6配置、IPv6 DNS配置、IPv6 over IPv4隧道配置和IPv4 over IPv6隧道配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置VLAN内Proxy ARP示例

配置VLAN内Proxy ARP示例

组网需求

图2-21所示,企业财务部的主机位于同一个VLAN内。部门主机访问外网时经常遭到病毒攻击,感染病毒的主机发送大量广播报文,在VLAN内产生广播风暴,严重时使部门主机不能正常通信。公司希望采取方法可以有效地隔离部门内的广播风暴,保证部门员工的正常通信以及信息安全。

图2-21  配置VLAN内Proxy ARP组网图

配置思路

VLAN内Proxy ARP的配置思路如下:

  1. 在交换机的下行接口上配置端口隔离,禁止部门的主机之间进行二层通信,消除VLAN内的广播风暴的影响。

  2. 在VLANIF接口上使能VLAN内Proxy ARP功能,在避免广播风暴的同时实现部门主机间的三层通信。

操作步骤

  1. 配置接口加入Sub-VLAN2,并配置端口隔离

    <HUAWEI> system-view
    [HUAWEI] sysname Switch
    [Switch] vlan batch 2
    [Switch] interface gigabitethernet 1/0/1
    [Switch-GigabitEthernet1/0/1] port-isolate enable
    [Switch-GigabitEthernet1/0/1] port link-type access
    [Switch-GigabitEthernet1/0/1] port default vlan 2
    [Switch-GigabitEthernet1/0/1] quit
    [Switch] interface gigabitethernet 1/0/2
    [Switch-GigabitEthernet1/0/2] port-isolate enable
    [Switch-GigabitEthernet1/0/2] port link-type access
    [Switch-GigabitEthernet1/0/2] port default vlan 2
    [Switch-GigabitEthernet1/0/2] quit
    

  2. 配置Super-VLAN3,并将Sub-VLAN2加入Super-VLAN3。配置接口VLANIF3的IP地址,并使能VLAN内Proxy ARP功能

    # 配置Super-VLAN3,并将Sub-VLAN2加入Super-VLAN3。

    [Switch] vlan 3
    [Switch-vlan3] aggregate-vlan
    [Switch-vlan3] access-vlan 2
    [Switch-vlan3] quit
    

    # 配置接口VLANIF3的IP地址,并使能VLAN内Proxy ARP功能

    [Switch] interface vlanif 3
    [Switch-Vlanif3] ip address 10.10.10.1 24
    [Switch-Vlanif3] arp-proxy inner-sub-vlan-proxy enable
    [Switch-Vlanif3] quit
    

  3. 配置主机的IP地址

    # 配置Host_1的IP地址为10.10.10.3/24。

    # 配置Host_2的IP地址为10.10.10.2/24。

  4. 验证配置结果

    # 在Switch上查看VLANIF3接口的ARP表项,可以看到VLANIF3接口的IP地址对应的MAC地址。

    [Switch] display arp interface vlanif 3
    IP ADDRESS      MAC ADDRESS     EXPIRE(M) TYPE        INTERFACE   VPN-INSTANCE                                                      
                                              VLAN/CEVLAN                                                                               
    ------------------------------------------------------------------------------                                                      
    10.10.10.1      101b-5441-5bf6            I -         Vlanif3                                                                     
    ------------------------------------------------------------------------------                                                      
    Total:1         Dynamic:0       Static:0     Interface:1  

    # 在主机Host_1(操作系统以Windows 7为例)上Ping主机Host_2的IP地址,可以Ping通。

    C:\Documents and Settings\Administrator> ping 10.10.10.2
    Pinging 10.10.10.2 with 32 bytes of data:
    Reply from 10.10.10.2: bytes=32 time<1ms TTL=128
    Reply from 10.10.10.2: bytes=32 time<1ms TTL=128
    Reply from 10.10.10.2: bytes=32 time<1ms TTL=128
    Reply from 10.10.10.2: bytes=32 time<1ms TTL=128
    
    Ping statistics for 10.10.10.2:
        Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
    Approximate round trip times in milli-seconds:
        Minimum = 0ms, Maximum = 0ms, Average = 0ms

    # 在Host_1上查看ARP表,可以看到主机Host_2的IP地址对应的MAC地址是Switch的VLANIF3接口的MAC地址,可见Host_1和Host_2之间是通过ARP代理实现互通的。

    C:\Documents and Settings\Administrator> arp -a
    Interface: 10.10.10.3 --- 0xd
      Internet Address      Physical Address      Type
      10.10.10.2            101b-5441-5bf6        dynamic
    ...

配置文件

Switch的配置文件

#
sysname Switch
#
vlan batch 2 to 3
#
vlan 3
 aggregate-vlan
 access-vlan 2
#
interface Vlanif3
 ip address 10.10.10.1 255.255.255.0
 arp-proxy inner-sub-vlan-proxy enable
#
interface GigabitEthernet1/0/1
 port link-type access
 port default vlan 2
 port-isolate enable group 1
#
interface GigabitEthernet1/0/2
 port link-type access
 port default vlan 2
 port-isolate enable group 1
#
return
翻译
下载文档
更新时间:2018-09-03

文档编号:EDOC1100038451

浏览量:5086

下载量:259

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页