所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S7700, S7900, S9700 V200R012(C00&C10) 配置指南-IP业务

本文档介绍了IP业务的配置,具体包括IP地址配置、ARP配置、DHCP配置、DNS配置、mDNS网关配置、mDNS中继配置、UDP Helper配置、IP性能优化配置、IPv6基础配置、DHCPv6配置、IPv6 DNS配置、IPv6 over IPv4隧道配置和IPv4 over IPv6隧道配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置DHCP客户端示例

配置DHCP客户端示例

组网需求

图3-19所示,Switch_1作为DHCP客户端,希望从DHCP服务器(Switch_2)中动态获取IP地址、DNS服务器、网关地址等信息。

图3-19  配置DHCP客户端组网图

配置思路

  1. 在Switch_1上使能DHCP客户端,实现Switch_1可以从DHCP服务器动态获取IP地址。
  2. 在Switch_2上配置DHCP服务器,实现为Switch_1动态分配IP地址等网络参数。

操作步骤

  1. 在Switch_1上配置DHCP客户端功能

    # 创建VLAN10并将GE1/0/1接口加入到VLAN10中。

    <HUAWEI> system-view
    [HUAWEI] sysname Switch_1
    [Switch_1] vlan 10
    [Switch_1-vlan10] quit
    [Switch_1] interface gigabitethernet 1/0/1
    [Switch_1-GigabitEthernet1/0/1] port link-type trunk
    [Switch_1-GigabitEthernet1/0/1] port trunk allow-pass vlan 10
    [Switch_1-GigabitEthernet1/0/1] quit

    # 在VLANIF10接口上使能DHCP客户端功能。

    [Switch_1] interface vlanif 10
    [Switch_1-Vlanif10] ip address dhcp-alloc
    [Switch_1-Vlanif10] quit

  2. 在Switch_2上创建DHCP服务器的全局地址池并配置网络参数
    1. 使能DHCP服务。

      <HUAWEI> system-view
      [HUAWEI] sysname Switch_2
      [Switch_2] dhcp enable

    2. 创建VLAN10并将GE1/0/1接口加入到VLAN10中。

      [Switch_2] vlan 10
      [Switch_2-vlan10] quit
      [Switch_2] interface gigabitethernet 1/0/1
      [Switch_2-GigabitEthernet1/0/1] port link-type trunk
      [Switch_2-GigabitEthernet1/0/1] port trunk allow-pass vlan 10
      [Switch_2-GigabitEthernet1/0/1] quit

    3. 配置VLANIF10接口工作在全局地址池模式。

      [Switch_2] interface vlanif 10
      [Switch_2-Vlanif10] ip address 192.168.1.1 24
      [Switch_2-Vlanif10] dhcp select global
      [Switch_2-Vlanif10] quit

    4. 创建地址池并配置相关属性。

      [Switch_2] ip pool pool1
      [Switch_2-ip-pool-pool1] network 192.168.1.0 mask 24
      [Switch_2-ip-pool-pool1] gateway-list 192.168.1.126
      [Switch_2-ip-pool-pool1] dns-list 192.168.1.2
      [Switch_2-ip-pool-pool1] excluded-ip-address 192.168.1.2
      [Switch_2-ip-pool-pool1] quit

  3. 验证配置结果

    # 在Switch_1的接口VLANIF10上执行display this命令,查看DHCP客户端功能的配置信息。

    [Switch_1] interface vlanif 10
    [Switch_1-Vlanif10] display this
    #
    interface Vlanif10
     ip address dhcp-alloc
    #
    return      

    # 当接口成功分配到IP地址,在Switch_1执行display dhcp client命令,查看DHCP客户端的状态信息。

    [Switch_1] display dhcp client
    DHCP client lease information on interface Vlanif10 :
     Current machine state         : Bound
     Internet address assigned via : DHCP
     Physical address              : 0025-9efb-be55
     IP address                    : 192.168.1.254
     Subnet mask                   : 255.255.255.0
     Gateway ip address            : 192.168.1.126
     DHCP server                   : 192.168.1.1
     Lease obtained at             : 2014-09-10 20:30:39
     Lease expires at              : 2014-09-11 20:30:39
     Lease renews at               : 2014-09-11 08:30:39
     Lease rebinds at              : 2014-09-11 17:30:39
     DNS                           : 192.168.1.2   

    # 在Switch_2上执行display ip pool name pool1命令,查看IP地址池的分配情况,“Used”字段表示已经分配出去的IP地址数量。

    [Switch_2] display ip pool name pool1
      Pool-name        : pool1
      Pool-No          : 0
      Lease            : 1 Days 0 Hours 0 Minutes
      Domain-name      : -
      DNS-server0      : 192.168.1.2
      NBNS-server0     : -
      Netbios-type     : -
      Position         : Local
      Status           : Unlocked
      Gateway-0        : 192.168.1.126
      Network          : 192.168.1.0
      Mask             : 255.255.255.0
      VPN instance     : --
      Logging          : Disable
      Conflicted address recycle interval: -
      Address Statistic: Total       :253       Used        :1
                         Idle        :251       Expired     :0
                         Conflict    :0         Disabled     :1
    
     -------------------------------------------------------------------------------
      Network section
             Start           End     Total  Used  Idle(Expired)  Conflict  Disabled
     -------------------------------------------------------------------------------
         192.168.1.1   192.168.1.254     253       1        251(0)       0     1
     -------------------------------------------------------------------------------

配置文件

  • Switch_1的配置文件

    #
    sysname Switch_1
    #
    vlan batch 10
    #
    interface Vlanif10
     ip address dhcp-alloc
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    return
  • Switch_2的配置文件

    #
    sysname Switch_2
    #
    vlan batch 10
    #
    dhcp enable
    #
    ip pool pool1
     gateway-list 192.168.1.126
     network 192.168.1.0 mask 255.255.255.0
     excluded-ip-address 192.168.1.2
     dns-list 192.168.1.2
    #
    interface Vlanif10
     ip address 192.168.1.1 255.255.255.0
     dhcp select global
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    return
    
翻译
下载文档
更新时间:2018-09-03

文档编号:EDOC1100038451

浏览量:5366

下载量:264

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页