所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S7700, S7900, S9700 V200R012(C00&C10) 配置指南-IP业务

本文档介绍了IP业务的配置,具体包括IP地址配置、ARP配置、DHCP配置、DNS配置、mDNS网关配置、mDNS中继配置、UDP Helper配置、IP性能优化配置、IPv6基础配置、DHCPv6配置、IPv6 DNS配置、IPv6 over IPv4隧道配置和IPv4 over IPv6隧道配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置mDNS中继示例

配置mDNS中继示例

组网需求

图6-6所示,某企业的移动终端通过WLAN连接网络,AP与AC之间采用三层转发。VLAN10和VLAN20内各有一台支持Bonjour技术的打印机。管理员希望企业内的用户终端能够通过Bonjour技术发现企业中所有可用的打印机服务。

图6-6  配置mDNS中继组网图

配置思路

  • 配置网络可达:通过配置AP、Switch和AC,实现Printer_1和iPhone通过WLAN接入Internet;通过配置Switch和AC,实现Printer_2通过有线接入Internet。
  • 在Switch上配置mDNS中继功能,在AC上配置mDNS网关功能。这样,mDNS网关上能够记录网络中所有可用服务信息,从而实现企业内的用户终端能够通过Bonjour技术发现企业中所有可用的打印机服务。
  • 在Switch上配置定时发现服务功能,以保证AC上服务信息列表的及时性和完整性。

本配置中的AC采用的是V200R005C00以上版本的华为无线接入控制器。

操作步骤

  1. 在Switch和AC上配置WLAN业务,实现iPhone和Printer_1通过WLAN接入Internet。具体配置步骤省略。

    针对Apple iOS v6.0以上版本的移动终端,如果通过DHCP服务器动态获取IP地址,需要在地址池中执行命令dns-list(基于全局地址池)或dhcp server dns-list(基于接口地址池)配置DNS服务器的IP地址。

  2. 在Switch和AC上配置网络可达,实现Printer_2通过有线接入Internet。假设Printer_2的IP地址静态配置为192.168.3.2/24。

    # 配置Switch。

    <HUAWEI> system-view
    [HUAWEI] sysname Switch
    [Switch] vlan batch 20 30
    [Switch] interface gigabitethernet 1/0/2
    [Switch-GigabitEthernet1/0/2] port link-type hybrid
    [Switch-GigabitEthernet1/0/2] port hybrid pvid vlan 20
    [Switch-GigabitEthernet1/0/2] port hybrid untagged vlan 20
    [Switch-GigabitEthernet1/0/2] quit
    [Switch] interface vlanif 20
    [Switch-Vlanif20] ip address 192.168.3.1 255.255.255.0
    [Switch-Vlanif20] quit
    [Switch] interface gigabitethernet 1/0/3
    [Switch-GigabitEthernet1/0/3] port link-type hybrid
    [Switch-GigabitEthernet1/0/3] port hybrid pvid vlan 30
    [Switch-GigabitEthernet1/0/3] port hybrid untagged vlan 30
    [Switch-GigabitEthernet1/0/3] quit
    [Switch] interface vlanif 30
    [Switch-Vlanif30] ip address 192.168.4.1 255.255.255.0
    [Switch-Vlanif30] quit

    # 配置AC。

    <HUAWEI> system-view
    [HUAWEI] sysname AC
    [AC] vlan batch 30
    [AC] interface gigabitethernet 0/0/1
    [AC-GigabitEthernet0/0/1] port link-type hybrid
    [AC-GigabitEthernet0/0/1] port hybrid pvid vlan 30
    [AC-GigabitEthernet0/0/1] port hybrid untagged vlan 30
    [AC-GigabitEthernet0/0/1] quit
    [AC] interface vlanif 30
    [AC-Vlanif30] ip address 192.168.4.2 255.255.255.0
    [AC-Vlanif30] quit
    [AC] ip route-static 192.168.3.0 255.255.255.0 192.168.4.1
    [AC] ip route-static 192.168.2.0 255.255.255.0 192.168.4.1 

  3. 在Switch上配置mDNS中继功能。

    [Switch] vlan 10
    [Switch-Vlan10] mdns relay enable
    [Switch-Vlan10] mdns probe interval 3600
    [Switch-Vlan10] quit
    [Switch] vlan 20
    [Switch-Vlan20] mdns relay enable
    [Switch-Vlan20] mdns probe interval 3600
    [Switch-Vlan20] quit
    [Switch] mdns gateway ip 192.168.4.2
    

  4. 在AC上配置mDNS网关功能。

    [AC] mdns gateway enable
    [AC] mdns gateway enable
    [AC] mdns permit service-type _raop._tcp.local id 0 
    [AC] mdns permit service-type _airplay._tcp.local id 1
    [AC] mdns permit service-type _printer._tcp.local id 2
    [AC] mdns permit service-type _device-info._tcp.local id 3
    [AC] mdns permit service-type _rfb._tcp.local id 4
    [AC] mdns permit service-type _sftp-ssh._tcp.local id 5
    [AC] mdns permit service-type _ssh._tcp.local id 6
    [AC] mdns permit service-type _smb._tcp.local id 7
    [AC] mdns permit service-type _afpovertcp._tcp.local id 8
    [AC] mdns permit service-type _universal._sub._ipp._tcp.local id 9
    [AC] mdns group group1 
    [AC-mdns-group-group1] user-vlan 10
    [AC-mdns-group-group1] service-vlan 20
    [AC-mdns-group-group1] quit
    

  5. 验证配置结果

    # 在Switch上执行命令display mdns relay,查看mDNS中继的配置信息。

    [Switch] display mdns relay          
    MDNS Relay Information:                                                         
    --------------------------------------------------------------------------------
     MDNS Gateway IP   :  192.168.4.2                                             
    --------------------------------------------------------------------------------
     Relay Enable Vlan :  vlan10  vlan20                                  
    --------------------------------------------------------------------------------
     Relay Probe Vlan  :  vlan10  vlan20                                          
    --------------------------------------------------------------------------------

    # 在AC上执行命令display mdns gateway,查看mDNS网关的配置信息。

    [AC] display mdns gateway          
    MDNS Information:                                                               
    --------------------------------------------------------------------------------
     MDNS Gateway Status  :  Enable                                                 
     MDNS Source IP       :  -                                          
    --------------------------------------------------------------------------------
     Gateway Probe Vlan   :  -                                                      
    --------------------------------------------------------------------------------

    # 在AC上执行命令display mdns service all,查看mDNS网关上记录的服务信息。

    [AC] display mdns service all          
    MDNS Service Info:                                                              
                                                                                    
    Service name : Officejet Pro 8100 [C12FFA] (6)._printer._tcp.local              
      TXT Info:                                                                     
          Data Length : 297                                                         
                                                                                    
    Service name : _printer._tcp.local                                              
      PTR Info:                                                                     
          Domain Name : Officejet Pro 8100 [C12FFA] (6)._printer._tcp.local         
                                                                                    
    Service name : Officejet Pro 8100 [C12FFA] (7)._ipp._tcp.local                  
      TXT Info:                                                                     
          Data Length : 408                                                         
                                                                                    
    Service name : _ipp._tcp.local                                                  
      PTR Info:                                                                     
          Domain Name : Officejet Pro 8100 [C12FFA] (7)._ipp._tcp.local             
                                                                                    
    Total: 4    

    # 配置完成后,在iPhone上能够找到Printer_1和Printer_2的打印服务。

配置文件

  • Switch的配置文件

    #
    sysname Switch
    #                                                                               
    vlan batch 10 20 30
    #                                                                               
    mdns gateway ip 192.168.4.2 
    #                                                                               
    vlan 10                                                                        
     mdns relay enable                                                              
     mdns probe interval 3600                                                         
    vlan 20                                                                        
     mdns relay enable                                                              
     mdns probe interval 3600  
    #                                                                               
    interface Vlanif20                                                             
     ip address 192.168.3.1 255.255.255.0                                             
    #                                                                               
    interface Vlanif30                                                             
     ip address 192.168.4.1 255.255.255.0                                             
    #                                                                               
    interface GigabitEthernet1/0/2                                                  
     port link-type hybrid
     port hybrid pvid vlan 20                                                       
     port hybrid untagged vlan 20                                  
    #                                                                               
    interface GigabitEthernet1/0/3                                                  
     port link-type hybrid
     port hybrid pvid vlan 30                                                       
     port hybrid untagged vlan 30                                  
    #
    return
  • AC的配置文件

    #
     sysname AC
    #                                                                               
    mdns gateway enable
    mdns permit service-type _raop._tcp.local id 0                                  
    mdns permit service-type _airplay._tcp.local id 1                               
    mdns permit service-type _printer._tcp.local id 2                               
    mdns permit service-type _device-info._tcp.local id 3                           
    mdns permit service-type _rfb._tcp.local id 4                                   
    mdns permit service-type _sftp-ssh._tcp.local id 5                              
    mdns permit service-type _ssh._tcp.local id 6                                   
    mdns permit service-type _smb._tcp.local id 7                                   
    mdns permit service-type _afpovertcp._tcp.local id 8                            
    mdns permit service-type _universal._sub._ipp._tcp.local id 9 
    #                                                                               
    mdns group group1                                                               
     user-vlan 10                                                                   
     service-vlan 20                                                                
    #                                                                               
    vlan batch 30
    #                                                                               
    interface Vlanif30                                                              
     ip address 192.168.4.2 255.255.255.0                                           
    #                                                                               
    interface GigabitEthernet0/0/1                                                  
     port hybrid pvid vlan 30                                                       
     port hybrid untagged vlan 30                                  
    #                                                                               
    ip route-static 192.168.3.0 255.255.255.0 192.168.4.1                           
    ip route-static 192.168.2.0 255.255.255.0 192.168.4.1                           
    #
    return
翻译
下载文档
更新时间:2018-09-03

文档编号:EDOC1100038451

浏览量:5382

下载量:264

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页