所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S7700, S7900, S9700 V200R012(C00&C10) 配置指南-IP业务

本文档介绍了IP业务的配置,具体包括IP地址配置、ARP配置、DHCP配置、DNS配置、mDNS网关配置、mDNS中继配置、UDP Helper配置、IP性能优化配置、IPv6基础配置、DHCPv6配置、IPv6 DNS配置、IPv6 over IPv4隧道配置和IPv4 over IPv6隧道配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置通过DHCPv6服务器分配IPv6地址和其他网络参数示例

配置通过DHCPv6服务器分配IPv6地址和其他网络参数示例

组网需求

如果大量的企业用户IPv6地址都是手动配置,那么网络管理员工作量大且可管理性差。管理员希望实现公司用户IPv6地址和网络配置参数的自动获取,便于统一管理。

图10-18  配置DHCPv6服务器组网图

配置思路

DHCPv6服务器的配置思路如下:
  1. 使能接口的IPv6功能,实现设备之间的IPv6通信。

  2. 配置DHCPv6服务器,实现设备分配IPv6地址和其他网络参数。

操作步骤

  1. 启动DHCP服务

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] dhcp enable

  2. 配置接口的IPv6功能

    [SwitchA] ipv6
    [SwitchA] vlan 100
    [SwitchA-vlan100] quit
    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] port link-type access
    [SwitchA-GigabitEthernet1/0/1] port default vlan 100
    [SwitchA-GigabitEthernet1/0/1] quit
    [SwitchA] interface vlanif 100
    [SwitchA-Vlanif100] ipv6 enable
    [SwitchA-Vlanif100] ipv6 address fc00:3::1/64
    [SwitchA-Vlanif100] quit 

  3. 配置DHCPv6服务器

    [SwitchA] dhcpv6 pool pool1 
    [SwitchA-dhcpv6-pool-pool1] address prefix fc00:3::/64
    [SwitchA-dhcpv6-pool-pool1] excluded-address fc00:3::1 
    [SwitchA-dhcpv6-pool-pool1] dns-server fc00:4::1
    [SwitchA-dhcpv6-pool-pool1] quit

  4. 配置DHCPv6服务器分配IPv6地址和其他网络参数

    [SwitchA] interface vlanif 100
    [SwitchA-Vlanif100] undo ipv6 nd ra halt
    [SwitchA-Vlanif100] ipv6 nd autoconfig managed-address-flag
    [SwitchA-Vlanif100] ipv6 nd autoconfig other-flag
    [SwitchA-Vlanif100] dhcpv6 server pool1
    [SwitchA-Vlanif100] quit
    [SwitchA] quit

  5. 验证配置结果

    # 在SwitchA上,通过命令display dhcpv6 pool查看IPv6地址池pool1的配置和地址分配信息。

    <SwitchA> display dhcpv6 pool pool1
    DHCPv6 pool: pool1
      Address prefix: FC00:3::/64
        Lifetime valid 172800 seconds, preferred 86400 seconds
        1 in use, 0 conflicts
      excluded-address FC00:3::1 
      1 excluded addresses 
      Information refresh time: 86400
      DNS server address: FC00:4::1
      conflict-address expire-time: 172800
      renew-time-percent : 50
      rebind-time-percent : 80
      Active normal clients: 1
    
    <SwitchA> display dhcpv6 pool pool1 allocated address
    Address                                 Valid    Expires             Left
    -------------------------------------------------------------------------------
    FC00:3::9                               172800   2016-04-03 07:59:22 162269
    -------------------------------------------------------------------------------
    Total : 1

配置文件

SwitchA的配置文件

#
sysname SwitchA
#
ipv6
#
vlan batch 100
#
dhcp enable
#
dhcpv6 pool pool1
 address prefix FC00:3::/64
 excluded-address FC00:3::1
 dns-server FC00:4::1
#
interface Vlanif100
 ipv6 enable
 ipv6 address FC00:3::1/64
 undo ipv6 nd ra halt
 ipv6 nd autoconfig managed-address-flag
 ipv6 nd autoconfig other-flag
 dhcpv6 server pool1
#
interface GigabitEthernet1/0/1
 port link-type access
 port default vlan 100
#
return
翻译
下载文档
更新时间:2018-09-03

文档编号:EDOC1100038451

浏览量:5057

下载量:259

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页