所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S7700, S7900, S9700 V200R012(C00&C10) 配置指南-IP业务

本文档介绍了IP业务的配置,具体包括IP地址配置、ARP配置、DHCP配置、DNS配置、mDNS网关配置、mDNS中继配置、UDP Helper配置、IP性能优化配置、IPv6基础配置、DHCPv6配置、IPv6 DNS配置、IPv6 over IPv4隧道配置和IPv4 over IPv6隧道配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置DHCPv6中继示例实现为一个网段的用户分配IPv6地址

配置DHCPv6中继示例实现为一个网段的用户分配IPv6地址

组网需求

图10-19所示,DHCPv6客户端所在网络地址为fc00:2::/64,DHCPv6服务器的地址为fc00:3::3/64。客户端和服务器不在同一个链路,需要通过DHCPv6中继转发报文。

要求将Switch作为DHCPv6中继,为客户端和服务器转发报文。Switch同时作为fc00:2::/64网络的网关设备,通过RA消息中的M标志位和O标志位指定该网络中的主机通过DHCPv6获取IPv6地址和其他网络配置参数。

图10-19  DHCPv6中继组网图

配置思路

DHCPv6中继的配置思路如下:
  1. 使能接口的IPv6功能,实现设备之间的IPv6通信功能。

  2. 使能DHCPv6中继功能,实现设备转发DHCPv6服务器和DHCPv6客户端之间报文功能。

操作步骤

  1. 启动DHCP服务

    <HUAWEI> system-view
    [HUAWEI] sysname Switch
    [Switch] dhcp enable

  2. 配置接口加入VLAN

    # 配置GigabitEthernet1/0/1接口加入VLAN10。

    [Switch] vlan batch 10 20
    [Switch] interface gigabitethernet 1/0/1
    [Switch-GigabitEthernet1/0/1] port link-type hybrid
    [Switch-GigabitEthernet1/0/1] port hybrid pvid vlan 10
    [Switch-GigabitEthernet1/0/1] port hybrid untagged vlan 10
    [Switch-GigabitEthernet1/0/1] quit

    # 配置GigabitEthernet1/0/2加接口入VLAN20。

    [Switch] interface gigabitethernet 1/0/2
    [Switch-GigabitEthernet1/0/2] port link-type hybrid
    [Switch-GigabitEthernet1/0/2] port hybrid pvid vlan 20
    [Switch-GigabitEthernet1/0/2] port hybrid untagged vlan 20
    [Switch-GigabitEthernet1/0/2] quit

  3. 配置VLANIF接口的IPv6地址

    # 使能IPv6报文转发功能。

    [Switch] ipv6

    # 配置VLANIF10接口的IPv6地址。

    [Switch] interface vlanif 10
    [Switch-Vlanif10] ipv6 enable
    [Switch-Vlanif10] ipv6 address fc00:2::1 64
    [Switch-Vlanif10] quit

    # 配置VLANIF20接口的IPv6地址。

    [Switch] interface vlanif 20
    [Switch-Vlanif20] ipv6 enable
    [Switch-Vlanif20] ipv6 address fc00:3::1 64
    [Switch-Vlanif20] quit

  4. 使能DHCPv6中继功能

    # 使能VLANIF10接口的DHCPv6中继功能,并配置DHCPv6服务器地址。

    [Switch] interface vlanif 10
    [Switch-Vlanif10] dhcpv6 relay destination fc00:3::3

  5. 配置Switch作为网关

    # 配置发布RA消息,并配置M和O标志位。

    [Switch-Vlanif10] undo ipv6 nd ra halt
    [Switch-Vlanif10] ipv6 nd autoconfig managed-address-flag
    [Switch-Vlanif10] ipv6 nd autoconfig other-flag
    [Switch-Vlanif10] quit

  6. 验证配置结果

    在Switch上使用display dhcpv6 relay命令用来查看DHCPv6中继配置情况。

    [Switch] display dhcpv6 relay
    --------------------------------------------------------------------------------
    Interface               Mode        Destination
    --------------------------------------------------------------------------------
    Vlanif10                Relay       FC00:3::3
    --------------------------------------------------------------------------------
     Print count : 1                    Total count : 1

    在Switch上使用display dhcpv6 relay statistics命令用来查看DHCPv6中继转发报文的统计信息。

    [Switch] display dhcpv6 relay statistics
    MessageType              Receive          Send             Error
     Solicit                  0                0                0
     Advertise                0                0                0
     Request                  0                0                0
     Confirm                  0                0                0
     Renew                    0                0                0
     Rebind                   0                0                0
     Reply                    0                0                0
     Release                  0                0                0
     Decline                  0                0                0
     Reconfigure              0                0                0
     Information-request      0                0                0
     Relay-forward            0                0                0
     Relay-reply              0                0                0
     UnknownType              0                0                0
    

配置文件

Switch的配置文件

#
sysname Switch
#
ipv6
#
vlan batch 10 20
#
dhcp enable
#
interface Vlanif10
 ipv6 enable
 ipv6 address FC00:2::1/64
 undo ipv6 nd ra halt
 ipv6 nd autoconfig managed-address-flag
 ipv6 nd autoconfig other-flag
 dhcpv6 relay destination FC00:3::3
#
interface Vlanif20
 ipv6 enable
 ipv6 address FC00:3::1/64
#
interface GigabitEthernet1/0/1
 port link-type hybrid
 port hybrid pvid vlan 10
 port hybrid untagged vlan 10
#
interface GigabitEthernet1/0/2
 port link-type hybrid
 port hybrid pvid vlan 20
 port hybrid untagged vlan 20
#
return
翻译
下载文档
更新时间:2018-09-03

文档编号:EDOC1100038451

浏览量:5157

下载量:259

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页