所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S7700, S7900, S9700 V200R012(C00&C10) 配置指南-IP业务

本文档介绍了IP业务的配置,具体包括IP地址配置、ARP配置、DHCP配置、DNS配置、mDNS网关配置、mDNS中继配置、UDP Helper配置、IP性能优化配置、IPv6基础配置、DHCPv6配置、IPv6 DNS配置、IPv6 over IPv4隧道配置和IPv4 over IPv6隧道配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置DHCPv6 PD客户端示例

配置DHCPv6 PD客户端示例

组网需求

图10-22所示,SwitchA与SwitchB在同一条链路上,SwitchB作为主机PC1~PCn的网关,通过接口GE2/0/1~GE2/0/n与主机PC1~PCn相连。部署SwitchA作为DHCPv6 PD服务器、SwitchB作为DHCPv6 PD客户端。主机PC1~PCn根据DHCPv6 PD客户端获取的IPv6地址前缀,通过路由通告的方式自动生成IPv6地址,实现主机IPv6地址的层次布局。

图10-22  DHCPv6 PD客户端组网图

配置思路

DHCPv6 PD客户端的配置思路如下:
  1. 在SwitchA上,配置DHCPv6 PD服务器,实现为DHCPv6 PD客户端动态分配IPv6地址前缀信息。具体配置包括:配置接口的IPv6地址、配置IPv6地址池、使能接口的DHCPv6 PD服务器功能。

  2. 在SwitchB上,配置DHCPv6 PD客户端,实现通过DHCPv6 PD服务器动态获取IPv6地址前缀信息。具体配置包括:配置接口的IPv6功能、使能接口的DHCPv6客户端功能。

  3. 在SwitchB上,绑定获取的IPv6地址前缀,实现下挂主机PC1~PCn通过路由通告的方式自动生成IPv6地址。

  4. 在主机PC1~PCn上,配置自动获取IPv6地址。

操作步骤

  1. 在SwitchA上,配置DHCPv6 PD服务器

    # 配置接口的IPv6地址。

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] ipv6
    [SwitchA] vlan 100
    [SwitchA-vlan100] quit
    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] port link-type trunk
    [SwitchA-GigabitEthernet1/0/1] port trunk allow-pass vlan 100
    [SwitchA-GigabitEthernet1/0/1] quit
    [SwitchA] interface vlanif 100
    [SwitchA-Vlanif100] ipv6 enable
    [SwitchA-Vlanif100] ipv6 address fc00:3::1/64
    [SwitchA-Vlanif100] quit

    # 配置IPv6 PD地址池。

    [SwitchA] dhcpv6 pool pool1
    [SwitchA-dhcpv6-pool-pool1] prefix-delegation fc00:2::/60 63
    [SwitchA-dhcpv6-pool-pool1] quit

    # 使能接口的DHCPv6 PD服务器功能。

    [SwitchA] dhcp enable
    [SwitchA] interface vlanif 100
    [SwitchA-Vlanif100] dhcpv6 server pool1
    [SwitchA-Vlanif100] quit
    

  2. 在SwitchB上,配置DHCPv6 PD客户端

    # 配置接口的IPv6功能。

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchB
    [SwitchB] dhcp enable
    [SwitchB] ipv6
    [SwitchB] vlan 100
    [SwitchB-vlan100] quit
    [SwitchB] interface gigabitethernet 1/0/1
    [SwitchB-GigabitEthernet1/0/1] port link-type trunk
    [SwitchB-GigabitEthernet1/0/1] port trunk allow-pass vlan 100
    [SwitchB-GigabitEthernet1/0/1] quit
    [SwitchB] interface vlanif 100
    [SwitchB-Vlanif100] ipv6 enable
    [SwitchB-Vlanif100] ipv6 address auto link-local

    # 使能接口的DHCPv6 PD客户端功能。

    [SwitchB-Vlanif100] dhcpv6 client pd myprefix
    [SwitchB-Vlanif100] quit

  3. 在SwitchB上,绑定获取的IPv6地址前缀。以接口GE2/0/1为例,其他接口的配置与GE2/0/1类似

    [SwitchB] vlan 200
    [SwitchB-vlan200] quit
    [SwitchB] interface gigabitethernet 2/0/1
    [SwitchB-GigabitEthernet2/0/1] port link-type access
    [SwitchB-GigabitEthernet2/0/1] port default vlan 200
    [SwitchB-GigabitEthernet2/0/1] quit
    [SwitchB] interface vlanif 200
    [SwitchB-Vlanif200] ipv6 enable
    [SwitchB-Vlanif200] ipv6 address auto link-local
    [SwitchB-Vlanif200] ipv6 address myprefix ::1/64
    [SwitchB-Vlanif200] undo ipv6 nd ra halt
    [SwitchB-Vlanif200] quit

  4. 配置主机PC1自动获取IPv6地址(操作系统Windows 7为例),其他主机的配置与PC1类似

    1. 右击桌面“网络”,单击“属性”,进入“网络和共享中心”窗口。
    2. 单击“本地连接”,进入“本地连接状态”窗口。
    3. 单击“属性”,进入“本地链接属性”窗口。
    4. 选择“Internet协议版本6(TCP/IPv6)”,点击“属性”,进入“Internet协议版本6(TCP/IPv6)属性”窗口,选择“自动获得IPv6地址”,单击“确定”。

  5. 验证配置结果

    # 在SwitchA上,通过命令display dhcpv6 pool查看IPv6 PD地址池pool1的配置和IPv6地址前缀分配信息。

    [SwitchA] display dhcpv6 pool pool1
    DHCPv6 pool: pool1
      Prefix delegation: FC00:2::/60 63
        Lifetime valid 172800 seconds, preferred 86400 seconds
        1 in use
      Information refresh time: 86400
      conflict-address expire-time: 172800
      renew-time-percent : 50
      rebind-time-percent : 80
      Active pd clients: 1
    
    [SwitchA] display dhcpv6 pool pool1 allocated prefix
    Prefix/length                              Valid    Expires             Left
    -------------------------------------------------------------------------------
    FC00:2::/63                                172800   2014-03-24 11:45:24 172462
    -------------------------------------------------------------------------------
    Total : 1 

    # 在SwitchB上,通过命令display dhcpv6 client查看DHCPv6 PD客户端的配置信息,通过命令display ipv6 interface查看主机侧接口VLANIF200的IPv6地址信息。

    [SwitchB] display dhcpv6 client
    Vlanif100 is in DHCPv6-PD client mode.
    DHCPv6-PD client is in BOUND state.
    Preferred server DUID   : 00030001000B0923198D
      Reachable via address : FE80::20B:9FF:FEED:14D4
    IA PD IA ID 0x00000751 T1 43200 T2 69120
      Prefix name  : myprefix
      Obtained     : 2014-04-24 09:36:38
      Renews       : 2014-04-24 21:36:38
      Rebinds      : 2014-04-25 04:48:38
      Prefix       : FC00:2::/63
        Lifetime valid 172800 seconds, preferred 86400 seconds
        Expires at 2067-09-26 09:36:37(172286 seconds left)
    
    [SwitchB] display ipv6 interface vlanif 200
    Vlanif200 current state : UP
    IPv6 protocol current state : UP
    IPv6 is enabled, link-local address is FE80::200:FF:FE00:212
      Global unicast address(es):
        FC00:2::1, subnet is FC00:2::/64  
      Joined group address(es):
        FF02::1:FF00:1
        FF02::1:FF00:212
        FF02::2
        FF02::1
      MTU is 1500 bytes
      ND DAD is enabled, number of DAD attempts: 1
      ND reachable time is 30000 milliseconds
      ND retransmit interval is 1000 milliseconds
      ND stale time is 1200 seconds
      ND advertised reachable time is 0 milliseconds
      ND advertised retransmit interval is 0 milliseconds
      ND router advertisement max interval 600 seconds, min interval 200 seconds
      ND router advertisements live for 1800 seconds
      ND router advertisements hop-limit 64
      ND default router preference medium
      Hosts use stateless autoconfig for addresses

    # 在用户PC上,查看IPv6地址的配置信息。本举例中,在PC1的“网络连接详细信息”窗口,可以看到其获取到IPv6地址fc00:2::d5b2:274:370b:4c6e。

配置文件

  • SwitchA的配置文件

    #
    sysname SwitchA
    #
    ipv6
    #
    vlan batch 100
    #
    dhcp enable
    #
    dhcpv6 pool pool1
     prefix-delegation FC00:2::/60 63
    #
    interface Vlanif100
     ipv6 enable
     ipv6 address FC00:3::1/64
     dhcpv6 server pool1
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    return
  • SwitchB的配置文件

    #
    sysname SwitchB
    #
    ipv6
    #
    vlan batch 100 200
    #
    dhcp enable
    #
    interface Vlanif100
     ipv6 enable
     ipv6 address auto link-local
     dhcpv6 client pd myprefix
    #
    interface Vlanif200
     ipv6 enable
     ipv6 address myprefix ::1/64
     ipv6 address auto link-local
     undo ipv6 nd ra halt
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface GigabitEthernet2/0/1
     port link-type access
     port default vlan 200
    #
    return
翻译
下载文档
更新时间:2018-09-03

文档编号:EDOC1100038451

浏览量:5203

下载量:259

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页