所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S12700 V200R012C00 配置指南-QoS

本文档介绍了如何配置QoS功能,主要包括MQC配置、优先级映射配置、流量监管配置、流量整形配置、接口限速配置、拥塞避免配置、拥塞管理配置、报文过滤配置、重定向配置、流量统计配置、基于ACL的简化流策略配置和HQoS配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置基于ACL的简化流策略进行优先级映射示例

配置基于ACL的简化流策略进行优先级映射示例

组网需求

图9-4所示,Switch通过接口GE2/0/1与路由器互连,企业部门1和企业部门2可经由Switch和路由器访问网络。企业部门1和企业部门2的VLAN ID分别为100、200。

由于企业部门1的服务等级高,需要得到更好的QoS保证。来自企业部门1和企业部门2的报文802.1p值均为0,通过定义优先级映射,将来自企业部门1的数据报文优先级映射为4,将来自企业部门2的数据报文优先级映射为2,以提供差分服务。

图9-4  优先级映射配置组网图

配置思路

采用如下的思路配置优先级映射:
  1. 创建VLAN,并配置各接口,保证用户能够通过Switch访问网络。
  2. 配置ACL,根据不同的VLAN区分不同的部门
  3. Switch入接口GE1/0/1GE1/0/2配置优先级映射。

操作步骤

  1. 创建VLAN并配置各接口

    # 创建VLAN 100和VLAN200。

    <HUAWEI> system-view
    [HUAWEI] sysname Switch
    [Switch] vlan batch 100 200
    

    # 将接口GE1/0/1GE1/0/2GE2/0/1的接入类型分别配置为trunk,并分别将接口GE1/0/1GE1/0/2加入VLAN 100、VLAN 200;接口GE2/0/1加入VLAN 100和VLAN 200。

    [Switch] interface gigabitethernet 1/0/1
    [Switch-GigabitEthernet1/0/1] port link-type trunk
    [Switch-GigabitEthernet1/0/1] port trunk allow-pass vlan 100
    [Switch-GigabitEthernet1/0/1] quit
    [Switch] interface gigabitethernet 1/0/2
    [Switch-GigabitEthernet1/0/2] port link-type trunk
    [Switch-GigabitEthernet1/0/2] port trunk allow-pass vlan 200
    [Switch-GigabitEthernet1/0/2] quit
    [Switch] interface gigabitethernet 2/0/1
    [Switch-GigabitEthernet2/0/1] port link-type trunk
    [Switch-GigabitEthernet2/0/1] port trunk allow-pass vlan 100 200
    [Switch-GigabitEthernet2/0/1] quit

  2. 配置优先级映射

    # 在Switch上配置ACL 4001和ACL 4002,根据VLAN ID区分不同的部门

    [Switch] acl 4001
    [Switch-acl-L2-4001] rule permit vlan-id 100
    [Switch-acl-L2-4001] quit
    [Switch] acl 4002
    [Switch-acl-L2-4002] rule permit vlan-id 200
    [Switch-acl-L2-4002] quit
    

  3. Switch入接口GE1/0/1GE1/0/2配置优先级映射

    [Switch] interface gigabitethernet 1/0/1
    [Switch-GigabitEthernet1/0/1] traffic-remark inbound acl 4001 8021p 4 
    [Switch-GigabitEthernet1/0/1] quit
    [Switch] interface gigabitethernet 1/0/2
    [Switch-GigabitEthernet1/0/2] traffic-remark inbound acl 4002 8021p 2 
    [Switch-GigabitEthernet1/0/2] quit
    

  4. 验证配置结果

    # 看设备接口入方向上应用的ACL规则和流动作信息。

    [Switch] display traffic-applied interface gigabitethernet 1/0/1 inbound
    -----------------------------------------------------------                     
    ACL applied inbound interface GigabitEthernet1/0/1                             
                                                                                    
    ACL 4001                                                                        
     rule 5 permit vlan-id 100                                                      
    ACTIONS:                                                                        
     remark 8021p 4                                                                 
    -----------------------------------------------------------  
    [Switch] display traffic-applied interface gigabitethernet 1/0/2 inbound
    -----------------------------------------------------------                     
    ACL applied inbound interface GigabitEthernet1/0/2
                                                                                    
    ACL 4002                                                                        
     rule 5 permit vlan-id 200                                                      
    ACTIONS:                                                                        
     remark 8021p 2                                                                 
    -----------------------------------------------------------
    

配置文件

  • Switch的配置文件

    #
    sysname Switch
    #
    vlan batch 100 200
    # 
    acl number 4001                                                                                                                  
     rule 5 permit vlan-id 100                                                                                                      
    acl number 4002                                                                                                          
     rule 5 permit vlan-id 200            
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 100
     traffic-remark inbound acl 4001 8021p 4   
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 200
     traffic-remark inbound acl 4002 8021p 2   
    #
    interface GigabitEthernet2/0/1
     port link-type trunk
     port trunk allow-pass vlan 100 200
    #
    return
    
翻译
下载文档
更新时间:2019-01-18

文档编号:EDOC1100038897

浏览量:3664

下载量:92

平均得分:
本文档适用于这些产品
相关文档
相关版本
分享
上一页 下一页