所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S12700 V200R012C00 配置指南-QoS

本文档介绍了如何配置QoS功能,主要包括MQC配置、优先级映射配置、流量监管配置、流量整形配置、接口限速配置、拥塞避免配置、拥塞管理配置、报文过滤配置、重定向配置、流量统计配置、基于ACL的简化流策略配置和HQoS配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置针对不同网段用户限速示例

配置针对不同网段用户限速示例

组网需求

Switch通过接口GE3/0/1与路由器互连,用户可经由Switch和路由器访问网络,如图4-13所示。

不同楼层的用户通过不同的接入交换机连接网络,且分别属于不同的网段,针对不同网段的用户提供不同的带宽。同一网段的所有用户共享带宽。

具体配置需求如表4-12所示。

表4-12  Switch为上行流量提供的QoS保障

用户

CIR(kbps)

PIR(kbps)

楼层一所有用户

4000

10000

楼层二所有用户

6000

10000

图4-13  配置针对不同网段用户限速组网图

配置思路

采用如下的思路配置针对不同网段用户限速:
  1. 创建VLAN,并配置各接口,使用户能够通过Switch访问网络。
  2. Switch上配置ACL分别匹配不同的网段。
  3. Switch上配置流分类匹配ACL规则。
  4. Switch上配置流行为,对来自不同楼层的用户报文进行限速。
  5. Switch上配置限速策略,绑定已配置的流行为和流分类,并应用到Switch与路由器连接的接口上。

操作步骤

  1. 创建VLAN并配置各接口

    # 在Switch上创建VLAN 100、200。

    <HUAWEI> system-view
    [HUAWEI] sysname Switch
    [Switch] vlan batch 100 200
    

    # 将接口GE1/0/1GE2/0/1的接入类型分别配置为Trunk,并分别将接口GE1/0/1GE2/0/1加入VLAN 100、VLAN 200。将接口GE3/0/1的接入类型配置为Trunk,并加入VLAN100和VLAN200。

    [Switch] interface gigabitethernet 1/0/1
    [Switch-GigabitEthernet1/0/1] port link-type trunk
    [Switch-GigabitEthernet1/0/1] port trunk allow-pass vlan 100
    [Switch-GigabitEthernet1/0/1] quit
    [Switch] interface gigabitethernet 2/0/1
    [Switch-GigabitEthernet2/0/1] port link-type trunk
    [Switch-GigabitEthernet2/0/1] port trunk allow-pass vlan 200
    [Switch-GigabitEthernet2/0/1] quit
    [Switch] interface gigabitethernet 3/0/1
    [Switch-GigabitEthernet3/0/1] port link-type trunk
    [Switch-GigabitEthernet3/0/1] port trunk allow-pass vlan 100 200
    [Switch-GigabitEthernet3/0/1] quit

  2. 配置ACL

    # 配置ACL规则匹配不同的网段。
    [Switch] acl 2000
    [Switch-acl-basic-2000] rule permit source 192.168.1.0 0.0.0.255
    [Switch-acl-basic-2000] quit
    [Switch] acl 2001
    [Switch-acl-basic-2001] rule permit source 192.168.2.0 0.0.0.255
    [Switch-acl-basic-2001] quit

  3. 配置流分类

    # 在Switch上创建流分类c1、c2,对来自不同楼层的用户进行分类。

    [Switch] traffic classifier c1 operator and
    [Switch-classifier-c1] if-match acl 2000
    [Switch-classifier-c1] quit
    [Switch] traffic classifier c2 operator and
    [Switch-classifier-c2] if-match acl 2001
    [Switch-classifier-c2] quit
    

  4. 配置流量监管行为

    # 在Switch上创建流行为b1、b2,对不同业务流进行流量监管。

    [Switch] traffic behavior b1
    [Switch-behavior-b1] car cir 4000 pir 10000 green pass
    [Switch-behavior-b1] quit
    [Switch] traffic behavior b2
    [Switch-behavior-b2] car cir 6000 pir 10000 green pass
    [Switch-behavior-b2] quit
    

  5. 配置流量监管策略并应用到接口上

    # 在Switch上创建流策略p1,将流分类和对应的流行为进行绑定,并将流策略应用到接口GE3/0/1出方向上,对报文进行流量监管。

    [Switch] traffic policy p1
    [Switch-trafficpolicy-p1] classifier c1 behavior b1
    [Switch-trafficpolicy-p1] classifier c2 behavior b2
    [Switch-trafficpolicy-p1] quit
    [Switch] interface gigabitethernet 3/0/1
    [Switch-GigabitEthernet3/0/1] traffic-policy p1 outbound
    [Switch-GigabitEthernet3/0/1] quit
    

  6. 验证配置结果

    # 查看流分类的配置信息。

    [Switch] display traffic classifier user-defined
      User Defined Classifier Information:                                          
       Classifier: c2                                                               
        Precedence: 10                                                              
        Operator: AND                                                               
        Rule(s) : if-match acl 2001                                                 
                                                                                    
       Classifier: c1                                                               
        Precedence: 5                                                               
        Operator: AND                                                               
        Rule(s) : if-match acl 2000                                                 
                                                                                    
    Total classifier number is 2                                                    

    # 查看流策略的配置信息。

    [Switch] display traffic policy user-defined p1
      User Defined Traffic Policy Information:                                      
      Policy: p1                                                                    
       Classifier: c1                                                               
        Operator: AND                                                               
         Behavior: b1                                                               
          Permit                                                                    
          Committed Access Rate:                                                    
            CIR 4000 (Kbps), PIR 10000 (Kbps), CBS 500000 (byte), PBS 1250000 (byte)
            Color Mode: color Blind                                                 
            Conform Action: pass                                                    
            Yellow  Action: pass                                                    
            Exceed  Action: discard                                                 
       Classifier: c2                                                               
        Operator: AND                                                               
         Behavior: b2                                                               
          Permit                                                                    
          Committed Access Rate:                                                    
            CIR 6000 (Kbps), PIR 10000 (Kbps), CBS 750000 (byte), PBS 1250000 (byte)
            Color Mode: color Blind                                                 
            Conform Action: pass                                                    
            Yellow  Action: pass                                                    
            Exceed  Action: discard                                                 

配置文件

  • Switch的配置文件

    #
    sysname Switch
    #
    vlan batch 100 200
    #
    acl number 2000  
     rule 5 permit source 192.168.1.0 0.0.0.255 
    acl number 2001  
     rule 5 permit source 192.168.2.0 0.0.0.255 
    #
    traffic classifier c1 operator and precedence 5
     if-match acl 2000
    traffic classifier c2 operator and precedence 10
     if-match acl 2001
    #
    traffic behavior b1
     permit
     car cir 4000 pir 10000 cbs 500000 pbs 1250000 mode color-blind green pass yellow pass red discard
    traffic behavior b2
     permit
     car cir 6000 pir 10000 cbs 750000 pbs 1250000 mode color-blind green pass yellow pass red discard
    #
    traffic policy p1 match-order config
     classifier c1 behavior b1
     classifier c2 behavior b2
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface GigabitEthernet2/0/1
     port link-type trunk
     port trunk allow-pass vlan 200
    #
    interface GigabitEthernet3/0/1
     port link-type trunk
     port trunk allow-pass vlan 100 200
     traffic-policy p1 outbound
    #
    return
    
翻译
下载文档
更新时间:2019-01-18

文档编号:EDOC1100038897

浏览量:3754

下载量:92

平均得分:
本文档适用于这些产品
相关文档
相关版本
分享
上一页 下一页