所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S12700 V200R012C00 配置指南-QoS

本文档介绍了如何配置QoS功能,主要包括MQC配置、优先级映射配置、流量监管配置、流量整形配置、接口限速配置、拥塞避免配置、拥塞管理配置、报文过滤配置、重定向配置、流量统计配置、基于ACL的简化流策略配置和HQoS配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置基于ACL的重定向示例

配置基于ACL的重定向示例

组网需求

图9-3所示,由于业务需要,用户有访问Internet的需求。用户通过接入层交换机SwitchB和核心层交换机SwitchA以及接入网关Router与Internet进行通信。

为了保证数据和网络的安全性,用户希望保证Internet到服务器全部流量的安全性,配置重定向将外网到内网的全部流量送至防火墙进行安全过滤。

图9-3  配置重定向的组网图

配置思路

  • 出于安全性考虑,在SwitchA上旁挂一台核心防火墙Firewall,对流量进行安全过滤。
  • 由于进入防火墙的流量是二层流量,因此通过重定向到接口将来自Internet的所有流量重定向到防火墙进行安全过滤。
  • 为了防止出现环路,在SwitchA与防火墙相连的接口上配置端口隔离,并配置禁止MAC地址学习防止MAC漂移。

操作步骤

  1. 创建VLAN并配置各接口,保证二层互通

    # 在SwitchB上创建VLAN100和VLAN200。

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchB
    [SwitchB] vlan batch 100 200
    

    # 配置SwitchB上接口GE1/0/2GE1/0/3的接口类型为Access,并将GE1/0/2加入VLAN200,将GE1/0/3加入VLAN100,配置GE1/0/1的接口类型为Trunk,并将GE1/0/1加入VLAN100和VLAN200。

    [SwitchB] interface gigabitethernet 1/0/2
    [SwitchB-GigabitEthernet1/0/2] port link-type access
    [SwitchB-GigabitEthernet1/0/2] port default vlan 200
    [SwitchB-GigabitEthernet1/0/2] quit
    [SwitchB] interface gigabitethernet 1/0/3
    [SwitchB-GigabitEthernet1/0/3] port link-type access
    [SwitchB-GigabitEthernet1/0/3] port default vlan 100
    [SwitchB-GigabitEthernet1/0/3] quit
    [SwitchB] interface gigabitethernet 1/0/1
    [SwitchB-GigabitEthernet1/0/1] port link-type trunk
    [SwitchB-GigabitEthernet1/0/1] port trunk allow-pass vlan 100 200
    [SwitchB-GigabitEthernet1/0/1] quit
    

    # 在SwitchA上创建VLAN100和VLAN200。

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan batch 100 200
    

    # 配置SwitchA上接口GE1/0/1GE1/0/2GE1/0/3GE1/0/4接口类型为Trunk,并将它们都加入VLAN100和VLAN200。将接口GE1/0/3GE1/0/4加入同一个端口隔离组,配置接口GE1/0/4禁止MAC地址学习防止MAC漂移。

    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] port link-type trunk
    [SwitchA-GigabitEthernet1/0/1] port trunk allow-pass vlan 100 200
    [SwitchA-GigabitEthernet1/0/1] quit
    [SwitchA] interface gigabitethernet 1/0/2
    [SwitchA-GigabitEthernet1/0/2] port link-type trunk
    [SwitchA-GigabitEthernet1/0/2] port trunk allow-pass vlan 100 200
    [SwitchA-GigabitEthernet1/0/2] quit
    [SwitchA] interface gigabitethernet 1/0/3
    [SwitchA-GigabitEthernet1/0/3] port link-type trunk
    [SwitchA-GigabitEthernet1/0/3] port trunk allow-pass vlan 100 200
    [SwitchA-GigabitEthernet1/0/3] port-isolate enable
    [SwitchA-GigabitEthernet1/0/3] quit
    [SwitchA] interface gigabitethernet 1/0/4
    [SwitchA-GigabitEthernet1/0/4] port link-type trunk
    [SwitchA-GigabitEthernet1/0/4] port trunk allow-pass vlan 100 200
    [SwitchA-GigabitEthernet1/0/4] port-isolate enable
    [SwitchA-GigabitEthernet1/0/4] mac-address learning disable
    [SwitchA-GigabitEthernet1/0/4] quit
    

  2. 配置基于ACL的重定向实现防火墙流量过滤

    # 配置基本ACL匹配所有允许通过的报文。
    [SwitchA] acl 4001
    [SwitchA-acl-L2-4001] rule permit vlan-id 100
    [SwitchA-acl-L2-4001] rule permit vlan-id 200
    [SwitchA-acl-L2-4001] quit
    
    # 在SwitchA的GigabitEthernet1/0/1入方向配置重定向报文到指定接口。
    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] traffic-redirect inbound acl 4001 interface gigabitethernet 1/0/3
    [SwitchA-GigabitEthernet1/0/1] quit
    

  3. 验证配置结果

    # 查看设备接口入方向上应用的ACL规则和流动作信息。

    [SwitchA] display traffic-applied interface gigabitethernet 1/0/1 inbound
    -----------------------------------------------------------                     
    ACL applied inbound interface GigabitEthernet1/0/1                              
                                                                                    
    ACL 4001                                                                        
     rule 5 permit vlan-id 100                                                      
    ACTIONS:                                                                        
     redirect interface GigabitEthernet1/0/3                                        
    -----------------------------------------------------------                     
                                                                                    
    ACL 4001                                                                        
     rule 10 permit vlan-id 200                                                     
    ACTIONS:                                                                        
     redirect interface GigabitEthernet1/0/3                                        
    ----------------------------------------------------------- 

配置文件

  • SwitchA的配置文件

    #
    sysname SwitchA
    #
    vlan batch 100 200
    #
    acl number 4001  
     rule 5 permit vlan-id 100
     rule 10 permit vlan-id 200
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 100 200
     traffic-redirect inbound acl 4001 interface GigabitEthernet1/0/3
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 100 200
    #
    interface GigabitEthernet1/0/3
     port link-type trunk
     port trunk allow-pass vlan 100 200
     port-isolate enable group 1
    #
    interface GigabitEthernet1/0/4
     port link-type trunk
     mac-address learning disable
     port trunk allow-pass vlan 100 200
     port-isolate enable group 1
    #
    return
    
  • SwitchB的配置文件

    #
    sysname SwitchB
    #
    vlan batch 100 200
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 100 200
    #
    interface GigabitEthernet1/0/2
     port link-type access 
     port default vlan 200
    #
    interface GigabitEthernet1/0/3
     port link-type access
     port default vlan 100
    #
    return
    
翻译
下载文档
更新时间:2019-01-18

文档编号:EDOC1100038897

浏览量:3722

下载量:92

平均得分:
本文档适用于这些产品
相关文档
相关版本
分享
上一页 下一页