所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

CloudEngine 12800, 12800E V200R005C00 配置指南-IP业务

本文档介绍了IP业务的配置,具体包括IPv4基础配置、ARP配置、DHCP配置、DNS配置、UDP Helper配置、IP性能配置、IPv6基础配置、DHCPv6配置、IPv6 DNS配置和IPv6过渡技术配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置DHCP中继示例

配置DHCP中继示例

组网需求

图3-18所示,某公司希望数据中心机房服务器由共同的DHCP服务器分配IP地址。本例以10.20.20.0/24网段的服务器为例说明DHCP中继的配置方法。

公司的服务器所在的网段为10.20.20.0/24,而DHCP服务器所在的网段为10.10.10.0/24。通过带DHCP中继功能的SwitchA转发DHCP报文,使得DHCP客户端可以从DHCP服务器上申请到IP地址等相关配置信息。

其中SwitchA上行接口为10GE1/0/2,VLANIF200的IP地址为10.10.20.1/24,对端IP地址为10.10.20.2/24。

DHCP Server的IP地址为10.10.10.1/24,对端IP地址为10.10.10.2/24。

图3-18 配置DHCP中继组网图

配置思路

DHCP中继的配置思路如下:

  1. 在SwitchA上配置DHCP中继功能,实现SwitchA转发不同网段的DHCP报文功能。

操作步骤

  1. 配置SwitchA的接口10GE1/0/2加入VLAN200

    <Huawei> system-view
    [~Huawei] sysname SwitchA
    [*Huawei] commit
    [~SwitchA] vlan batch 200
    [*SwitchA] interface 10ge 1/0/2
    [*SwitchA-10GE1/0/2] port link-type trunk
    [*SwitchA-10GE1/0/2] port trunk allow-pass vlan 200
    [*SwitchA-10GE1/0/2] quit
    [*SwitchA] interface vlanif 200
    [*SwitchA-Vlanif200] ip address 10.10.20.1 24
    [*SwitchA-Vlanif200] quit
    [*SwitchA] commit

  2. 在SwitchA上配置DHCP中继功能
    1. 创建DHCP服务器组并为服务器组添加DHCP服务器

      # 创建DHCP服务器组。

      [~SwitchA] dhcp relay server group dhcpgroup1

      # 为DHCP服务器组添加DHCP服务器。

      [*SwitchA-dhcp-relay-server-group-dhcpgroup1] server 10.10.10.1
      [*SwitchA-dhcp-relay-server-group-dhcpgroup1] quit
      [*SwitchA] commit

    2. 在接口下使能DHCP中继功能

      # 创建VLAN并将接口10GE1/0/1加入到VLAN中。

      [~SwitchA] vlan batch 100
      [*SwitchA] interface 10ge 1/0/1
      [*SwitchA-10GE1/0/1] port default vlan 100
      [*SwitchA-10GE1/0/1] quit
      [*SwitchA] commit

      # 使能全局DHCP功能,并使能接口下DHCP中继功能。

      [~SwitchA] dhcp enable
      [*SwitchA] interface vlanif 100
      [*SwitchA-Vlanif100] dhcp select relay 
      [*SwitchA-Vlanif100] quit
      [*SwitchA] commit

    3. 配置接口绑定DHCP服务器组

      # 配置接口的IP地址。

      [~SwitchA] interface vlanif 100
      [*SwitchA-Vlanif100] ip address 10.20.20.1 24

      # 配置接口绑定DHCP服务器组。

      [*SwitchA-Vlanif100] dhcp relay binding server group dhcpgroup1
      [*SwitchA-Vlanif100] quit
      [*SwitchA] commit

  3. 在SwitchA上配置缺省路由

    [~SwitchA] ip route-static 0.0.0.0 0.0.0.0 10.10.20.2
    [*SwitchA] commit
    

  4. 验证配置结果

    # 在SwitchA上使用display dhcp relay命令用来查看接口的DHCP中继配置情况。

    [~SwitchA] display dhcp relay interface vlanif 100
     DHCP relay agent running information of interface Vlanif100 :                  
     Server group name          : dhcpgroup1                                        
     Gateway address in use     : 10.20.20.1                                        
                  
    

配置文件

SwitchA的配置文件

#
sysname SwitchA
#
vlan batch 100 200
#
dhcp enable
#
dhcp relay server group dhcpgroup1
 server 10.10.10.1 0
#
interface Vlanif100
 ip address 10.20.20.1 255.255.255.0
 dhcp select relay
 dhcp relay binding server group dhcpgroup1
#
interface Vlanif200
 ip address 10.10.20.1 255.255.255.0
#
interface 10GE1/0/1
 port default vlan 100
#
interface 10GE1/0/2
 port link-type trunk
 port trunk allow-pass vlan 200
#
ip route-static 0.0.0.0 0.0.0.0 10.10.20.2                                    
#                                                                               
return
翻译
下载文档
更新时间:2019-04-19

文档编号:EDOC1100039516

浏览量:8035

下载量:205

平均得分:
本文档适用于这些产品
相关版本
相关文档
Share
上一页 下一页