所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

CloudEngine 12800, 12800E V200R005C00 配置指南-IP业务

本文档介绍了IP业务的配置,具体包括IPv4基础配置、ARP配置、DHCP配置、DNS配置、UDP Helper配置、IP性能配置、IPv6基础配置、DHCPv6配置、IPv6 DNS配置和IPv6过渡技术配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
同网段内配置基于全局地址池的DHCP服务器示例

同网段内配置基于全局地址池的DHCP服务器示例

组网需求

图3-16所示,某企业有两个处于同一网络内的办公室,为了节省资源,两个办公室内的主机由SwitchB作为DHCP服务器统一分配IP地址。

办公室1所属的网段为10.1.1.0/25,主机都加入VLAN10,办公室1的主机只使用DNS服务,不使用NetBIOS服务,地址租期为10天;办公室2所属的网段为10.1.1.128/25,主机都加入VLAN20,办公室2的主机使用DNS服务和NetBIOS服务,地址租期为2天。

在SwitchB上配置全局地址池,并采取动态地址分配方式为两个办公室的主机分配IP地址。

图3-16 配置基于全局地址池的DHCP服务器组网图

配置思路

DHCP服务器的配置思路如下:

  1. 在SwitchB上创建两个全局地址池,并配置各自的地址池相关属性,实现根据不同需求,为办公室1和办公室2动态分配地址。
  2. 在SwitchB上配置VLANIF接口下本地DHCP服务器的地址分配方式,实现DHCP服务器从全局地址池中给客户端分配IP地址。

操作步骤

  1. 使能DHCP服务。

    <Huawei> system-view
    [~Huawei] sysname SwitchB
    [*Huawei] commit
    [~SwitchB] dhcp enable
    [*SwitchB] commit

  2. 创建地址池并配置相关属性。

    # 配置IP地址池1的属性(地址池范围、DNS地址、出口网关和地址池租期)。

    [~SwitchB] ip pool pool1
    [*SwitchB-ip-pool-pool1] gateway-list 10.1.1.1
    [*SwitchB-ip-pool-pool1] network 10.1.1.0 mask 255.255.255.128
    [*SwitchB-ip-pool-pool1] dns-list 10.1.1.2
    [*SwitchB-ip-pool-pool1] excluded-ip-address 10.1.1.2
    [*SwitchB-ip-pool-pool1] excluded-ip-address 10.1.1.4
    [*SwitchB-ip-pool-pool1] lease day 10
    [*SwitchB-ip-pool-pool1] commit
    [~SwitchB-ip-pool-pool1] quit

    # 配置IP地址池2的属性(地址池范围、DNS地址、出口网关、NetBOIS地址和地址池租期)。

    [~SwitchB] ip pool pool2
    [*SwitchB-ip-pool-pool2] gateway-list 10.1.1.129
    [*SwitchB-ip-pool-pool2] network 10.1.1.128 mask 255.255.255.128
    [*SwitchB-ip-pool-pool2] dns-list 10.1.1.2
    [*SwitchB-ip-pool-pool2] nbns-list 10.1.1.4
    [*SwitchB-ip-pool-pool2] lease day 2
    [*SwitchB-ip-pool-pool2] commit
    [~SwitchB-ip-pool-pool2] quit

  3. 配置VLANIF接口下地址分配方式。

    # 配置接口10GE1/0/1和10GE1/0/2分别加入相应的VLAN。

    [~SwitchB] vlan batch 10 20
    [*SwitchB] interface 10ge 1/0/1 
    [*SwitchB-10GE1/0/1] port link-type trunk
    [*SwitchB-10GE1/0/1] port trunk allow-pass vlan 10
    [*SwitchB-10GE1/0/1] commit
    [~SwitchB-10GE1/0/1] quit
    [~SwitchB] interface 10ge 1/0/2 
    [~SwitchB-10GE1/0/2] port link-type trunk
    [*SwitchB-10GE1/0/2] port trunk allow-pass vlan 20
    [*SwitchB-10GE1/0/2] commit
    [~SwitchB-10GE1/0/2] quit
    

    # 配置接口VLANIF10的IP地址。

    [~SwitchB] interface vlanif 10
    [*SwitchB-Vlanif10] ip address 10.1.1.1 255.255.255.128
    [*SwitchB-Vlanif10] commit
    [~SwitchB-Vlanif10] quit

    # 配置接口VLANIF20的IP地址。

    [~SwitchB] interface vlanif 20
    [*SwitchB-Vlanif20] ip address 10.1.1.129 255.255.255.128
    [*SwitchB-Vlanif20] commit
    [~SwitchB-Vlanif20] quit

  4. 验证配置结果。

    在SwitchB上使用display ip pool命令用来查看IP地址池配置情况。

    [~SwitchB] display ip pool
     -----------------------------------------------------------------------------  
      Pool name      : pool1                                                        
      Pool number    : 0                                                           
      Position       : Local           Status           : Unlocked               
      Gateway        : 10.1.1.1                                                 
      Mask           : 255.255.255.128                                          
      VPN instance   : --                                                       
                                                                                
     ----------------------------------------------------------------------------- 
      Pool name      : pool2                                                      
      Pool number    : 1                                                           
      Position       : Local           Status           : Unlocked             
      Gateway        : 10.1.1.129                                              
      Mask           : 255.255.255.128                                     
      VPN instance   : --                                                
                                                                           
                                                                          
      IP address Statistic                                                
        Total       :250                                                  
        Used        :6          Idle        :242        Expired     :0     
        Conflict    :0          Disable   :2     
    

配置文件

SwitchB的配置文件

#
sysname SwitchB
#
vlan batch 10 20
#
dhcp enable
#
ip pool pool1
 gateway-list 10.1.1.1
 network 10.1.1.0 mask 255.255.255.128
 lease day 10 hour 0 minute 0
 dns-list 10.1.1.2
 excluded-ip-address 10.1.1.2
 excluded-ip-address 10.1.1.4
#
ip pool pool2
 gateway-list 10.1.1.129
 network 10.1.1.128 mask 255.255.255.128
 lease day 2 hour 0 minute 0
 dns-list 10.1.1.2
 nbns-list 10.1.1.4
#
interface Vlanif10
 ip address 10.1.1.1 255.255.255.128
#
interface Vlanif20
 ip address 10.1.1.129 255.255.255.128
#
interface 10GE1/0/1
 port link-type trunk
 port trunk allow-pass vlan 10
#
interface 10GE1/0/2
 port link-type trunk
 port trunk allow-pass vlan 20
#
return
翻译
下载文档
更新时间:2019-04-19

文档编号:EDOC1100039516

浏览量:8116

下载量:205

平均得分:
本文档适用于这些产品
相关版本
相关文档
Share
上一页 下一页