所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

CloudEngine 12800, 12800E V200R005C00 配置指南-IP业务

本文档介绍了IP业务的配置,具体包括IPv4基础配置、ARP配置、DHCP配置、DNS配置、UDP Helper配置、IP性能配置、IPv6基础配置、DHCPv6配置、IPv6 DNS配置和IPv6过渡技术配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置VLAN间Proxy ARP示例

配置VLAN间Proxy ARP示例

组网需求

图2-22所示,VLAN2和VLAN3组成super-VLAN4。要求:
  • 作为sub-VLAN的VLAN2和VLAN3内的服务器之间不能互相Ping通。
  • 配置VLAN间Proxy ARP后,VLAN2和VLAN3内的服务器之间可以互相Ping通。
图2-22 配置VLAN间Proxy ARP组网图

配置思路

VLAN间Proxy ARP的配置思路如下:

  1. 配置super-VLAN和sub-VLAN。
  2. 将接口加入到从sub-VLAN中。
  3. 创建super-VLAN的VLANIF接口并配置其IP地址。
  4. 启动VLAN间Proxy ARP。

操作步骤

  1. 配置super-VLAN和sub-VLAN

    # 配置sub-VLAN2。
    <HUAWEI> system-view
    [~HUAWEI] sysname Switch
    [*HUAWEI] commit
    [~Switch] vlan 2
    [*Switch-vlan2] commit
    [~Switch-vlan2] quit
    # 将10GE1/0/1和10GE1/0/2加入到sub-VLAN2中。
    [~Switch] interface 10ge 1/0/2
    [~Switch-10GE1/0/2] port default vlan 2
    [*Switch-10GE1/0/2] quit
    [*Switch] interface 10ge 1/0/1
    [*Switch-10GE1/0/1] port default vlan 2
    [*Switch-10GE1/0/1] quit
    [*Switch] commit
    # 配置sub-VLAN3。
    [~Switch] vlan 3
    [*Switch-vlan3] commit
    [~Switch-vlan3] quit
    # 将10GE1/0/3和10GE1/0/4加入到sub-VLAN3中。
    [~Switch] interface 10ge 1/0/3
    [*Switch-10GE1/0/3] port default vlan 3
    [*Switch-10GE1/0/3] quit
    [*Switch] interface 10ge 1/0/4
    [*Switch-10GE1/0/4] port default vlan 3
    [*Switch-10GE1/0/4] quit
    [*Switch] commit
    # 配置super-VLAN4,并将sub-VLAN2和sub-VLAN3增加到super-VLAN中。
    [~Switch] vlan 4
    [*Switch-vlan4] aggregate-vlan
    [*Switch-vlan4] access-vlan 2
    [*Switch-vlan4] access-vlan 3
    [*Switch-vlan4] quit
    [*Switch] commit

  2. 创建和配置接口VLANIF4

    # 创建接口VLANIF4。

    [~Switch] interface vlanif 4

    # 配置接口VLANIF4的IP地址。

    [*Switch-Vlanif4] ip address 10.10.10.1 24

  3. 在接口VLANIF4启动VLAN间Proxy ARP

    [*Switch-Vlanif4] arp proxy inter-vlan enable
    [*Switch-Vlanif4] quit
    [*Switch] commit
    [~Switch] quit

  4. 配置服务器

    # 配置ServerA的IP地址为10.10.10.2/24。

    # 配置ServerB的IP地址为10.10.10.3/24。

    # 配置ServerC的IP地址为10.10.10.4/24。

    # 配置ServerD的IP地址为10.10.10.5/24。

  5. 验证配置结果

    # 执行命令display arp,查看所有ARP表项。

    <Switch> display arp
    ARP Entry Types: D - Dynamic, S - Static, I - Interface                                                                             
    EXP: Expire-time
                                                                                                                                        
    IP ADDRESS      MAC ADDRESS    EXP(M) TYPE/VLAN INTERFACE       VPN-INSTANCE                                                        
    ------------------------------------------------------------------------------                                                      
    10.10.10.1      0018-2000-0083        I         Vlanif4                                                                             
    10.10.10.2      00e0-fc00-0002   19   D/2       10GE1/0/1                                                                           
    10.10.10.3      00e0-fc00-0003   19   D/2       10GE1/0/2                                                                           
    10.10.10.4      00e0-fc00-0004   19   D/3       10GE1/0/3                                                                           
    10.10.10.5      00e0-fc00-0005   19   D/3       10GE1/0/4                                                                           
    ------------------------------------------------------------------------------                                                      
    Total:5          Dynamic:4       Static:0    Interface:1  

    # VLAN2和VLAN3内的服务器之间可以互相Ping通。

配置文件

Switch的配置文件

#
sysname Switch
#
vlan batch 2 to 4 
#
vlan 4
 aggregate-vlan
 access-vlan 2 to 3
#
interface Vlanif4
 ip address 10.10.10.1 255.255.255.0
 arp proxy inter-vlan enable
#
interface 10GE1/0/1
 port default vlan 2
#
interface 10GE1/0/2
 port default vlan 2
#
interface 10GE1/0/3
 port default vlan 3
#
interface 10GE1/0/4
 port default vlan 3
#
return
翻译
下载文档
更新时间:2019-04-19

文档编号:EDOC1100039516

浏览量:7959

下载量:205

平均得分:
本文档适用于这些产品
相关版本
相关文档
Share
上一页 下一页