所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

CloudEngine 12800, 12800E V200R005C00 配置指南-IP业务

本文档介绍了IP业务的配置,具体包括IPv4基础配置、ARP配置、DHCP配置、DNS配置、UDP Helper配置、IP性能配置、IPv6基础配置、DHCPv6配置、IPv6 DNS配置和IPv6过渡技术配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置IPv6 DNS客户端示例

配置IPv6 DNS客户端示例

组网需求

图9-2所示,设备SwitchA作为IPv6 DNS客户端,与IPv6 DNS服务器配合使用,用户希望SwitchA通过域名(huawei.com)能够访问IPv6地址为fc00:2::1/64的服务器。

在SwitchA上配置SwitchB的IPv6静态域名解析表项,用户希望SwitchA能够使用域名(SwitchB)对设备进行访问。

图9-2 配置IPv6 DNS客户端组网图

配置思路

IPv6 DNS客户端的配置思路如下:

  1. 在SwitchA和SwitchB上配置各接口的IPv6地址,并配置静态路由,实现各设备之间的路由可达。

  2. 在SwitchA上配置IPv6静态域名解析表项,实现以域名方式与SwitchB进行通信的功能。

  3. 在SwitchA上配置IPv6动态域名解析功能,实现SwitchA以动态DNS查询方式与IPv6 DNS服务器进行通信的功能。

操作步骤

  1. 配置SwitchA和SwitchB上各接口的IPv6地址和静态路由

    # 配置SwitchA上接口所属的VLAN。

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] vlan 101
    [*SwitchA-vlan101] quit
    [*SwitchA] interface 10ge 1/0/1
    [*SwitchA-10GE1/0/1] port link-type trunk
    [*SwitchA-10GE1/0/1] port trunk allow-pass vlan 101
    [*SwitchA-10GE1/0/1] quit
    [*SwitchA] commit

    # 配置SwitchA上VLANIF接口的IPv6地址。

    [~SwitchA] interface vlanif 101
    [*SwitchA-Vlanif101] ipv6 enable
    [*SwitchA-Vlanif101] ipv6 address fc00:1::1/64
    [*SwitchA-Vlanif101] quit
    [*SwitchA] commit

    # 配置SwitchA到两个服务器的静态路由。

    [~SwitchA] ipv6 route-static fc00:2:: 64 fc00:1::2
    [*SwitchA] ipv6 route-static fc00:3:: 64 fc00:1::2
    [*SwitchA] commit

    # 配置SwitchB上接口所属的VLAN。

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchB
    [*HUAWEI] commit
    [~SwitchB] vlan batch 101 102 103
    [*SwitchB] interface 10ge 1/0/1
    [*SwitchB-10GE1/0/1] port link-type trunk
    [*SwitchB-10GE1/0/1] port trunk allow-pass vlan 101
    [*SwitchB-10GE1/0/1] quit
    [*SwitchB] interface 10ge 1/0/2
    [*SwitchB-10GE1/0/2] port link-type trunk
    [*SwitchB-10GE1/0/2] port trunk allow-pass vlan 102
    [*SwitchB-10GE1/0/2] quit
    [*SwitchB] interface 10ge 1/0/3
    [*SwitchB-10GE1/0/3] port link-type trunk
    [*SwitchB-10GE1/0/3] port trunk allow-pass vlan 103
    [*SwitchB-10GE1/0/3] quit
    [*SwitchB] commit

    # 配置SwitchB上VLANIF接口的IPv6地址。

    [~SwitchB] interface vlanif 101
    [*SwitchB-Vlanif101] ipv6 enable
    [*SwitchB-Vlanif101] ipv6 address fc00:1::2/64
    [*SwitchB-Vlanif101] quit
    [*SwitchB] interface vlanif 102
    [*SwitchB-Vlanif102] ipv6 enable
    [*SwitchB-Vlanif102] ipv6 address fc00:2::2/64
    [*SwitchB-Vlanif102] quit
    [*SwitchB] interface vlanif 103
    [*SwitchB-Vlanif103] ipv6 enable
    [*SwitchB-Vlanif103] ipv6 address fc00:3::2/64
    [*SwitchB-Vlanif103] quit
    [*SwitchB] commit
    说明:

    要实现IPv6动态域名解析功能,还需要保证两个服务器到SwitchA的路由可达。

  2. 在SwitchA上配置IPv6静态域名解析表项

    [~SwitchA] ipv6 host SwitchB fc00:1::2
    [*SwitchA] commit

  3. 在SwitchA上配置IPv6动态域名解析功能

    [~SwitchA] dns resolve
    [*SwitchA] dns server ipv6 fc00:3::1
    [*SwitchA] commit

  4. 验证配置结果

    # 在设备SwitchA上执行ping ipv6 huawei.com命令,可以ping通,且对应的目的地址为fc00:2::1。

    [~SwitchA] ping ipv6 huawei.com
      PING huawei.com (FC00:2::1): 56  data bytes, press CTRL_C to break
        Reply from FC00:2::1 
        bytes=56 Sequence=1 hop limit=64 time=8 ms
        Reply from FC00:2::1 
        bytes=56 Sequence=2 hop limit=64 time=1 ms
        Reply from FC00:2::1 
        bytes=56 Sequence=3 hop limit=64 time=1 ms
        Reply from FC00:2::1 
        bytes=56 Sequence=4 hop limit=64 time=1 ms
        Reply from FC00:2::1 
        bytes=56 Sequence=5 hop limit=64 time=1 ms
                
      ---FC00:2::1 ping statistics---
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
        round-trip min/avg/max=1/2/8 ms

    # 在SwitchA用display ipv6 host命令可以查看到IPv6静态域名解析表中主机名和IPv6地址的对应关系。

    [~SwitchA] display ipv6 host
    Host Name            Age        Flags  Address                                                                                      
    ------------------------------------------------                                                                                    
    SwitchB                0        static FC00:1::2 

    # 在SwitchA用display dns ipv6 dynamic-host命令可以查看到动态缓存区中的动态IPv6 DNS表项信息。

    [~SwitchA] display dns ipv6 dynamic-host
    No   Domain Name           Ipv6address                              TTL          Alias 
    1    huawei.com            FC00:2::1                                  6   

配置文件

  • SwitchA的配置文件

    #
    sysname SwitchA
    #
    ipv6 host SwitchB FC00:1::2
    #
    dns resolve
    dns server ipv6 FC00:3::1
    #
    vlan batch 101
    #
    interface Vlanif101
     ipv6 enable
     ipv6 address FC00:1::1/64
    #                                                                               
    interface 10GE1/0/1                                                             
     port link-type trunk                                                           
     port trunk allow-pass vlan 101                                                 
    #                                                                               
    ipv6 route-static FC00:2:: 64 FC00:1::2                                             
    ipv6 route-static FC00:3:: 64 FC00:1::2  
    #
    return
    
  • SwitchB的配置文件

    #
    sysname SwitchB
    #
    vlan batch 101 to 103
    #
    interface Vlanif101
     ipv6 enable
     ipv6 address FC00:1::2/64
    #                                                                               
    interface Vlanif102
     ipv6 enable
     ipv6 address FC00:2::2/64
    #                                                                               
    interface Vlanif103
     ipv6 enable
     ipv6 address FC00:3::2/64
    #                                                                               
    interface 10GE1/0/1                                                             
     port link-type trunk                                                           
     port trunk allow-pass vlan 101                                                 
    #                                                                               
    interface 10GE1/0/2                                                             
     port link-type trunk                                                           
     port trunk allow-pass vlan 102                                                 
    #                                                                               
    interface 10GE1/0/3                                                             
     port link-type trunk                                                           
     port trunk allow-pass vlan 103                                                 
    #                                                                               
    return
    
翻译
下载文档
更新时间:2019-04-19

文档编号:EDOC1100039516

浏览量:7862

下载量:205

平均得分:
本文档适用于这些产品
相关版本
相关文档
Share
上一页 下一页