所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

CloudEngine 12800, 12800E V200R005C00 配置指南-IP业务

本文档介绍了IP业务的配置,具体包括IPv4基础配置、ARP配置、DHCP配置、DNS配置、UDP Helper配置、IP性能配置、IPv6基础配置、DHCPv6配置、IPv6 DNS配置和IPv6过渡技术配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置UDP Helper示例

配置UDP Helper示例

组网需求

图5-2所示,Switch的接口10GE1/0/2和一局域网相连并加入VLAN20,VLANIF20的IP地址为10.110.1.1/16。NetBIOS-NS和Switch的接口10GE1/0/1相连,NetBIOS-NS的IP地址为10.1.1.1/16,10GE1/0/1加入VLAN10。VLANIF10的IP地址为10.1.1.2/16。现要求局域网用户之间直接使用主机名进行互访。

图5-2 配置UDP Helper组网图

配置思路

  1. 因为局域网主机之间要使用主机名进行互访,所以需要将对方的主机名解析成IP地址。但是,NetBIOS-NS和该局域网不在同一广播域,局域网内主机发送的UDP类型的NetBIOS-NS Register广播报文无法送达NetBIOS-NS。这就需要使能Switch的UDP Helper功能,将主机发送的目的端口为137(NetBIOS-NS服务端口)的UDP广播报文单播转发给NetBIOS-NS,完成对主机名的解析。
  2. 使能了UDP Helper功能后,需要在VLANIF20上指定目的服务器为NetBIOS-NS,即指定Switch中继转发的目的IP地址为NetBIOS-NS的IP地址。
说明:

因为Switch在使能UDP Helper功能后,默认支持将目的UDP端口号为137的广播报文进行中继转发,所以此处不需要配置中继转发的UDP端口号。

操作步骤

  1. 配置Switch接口10GE1/0/2加入VLAN20并配置VLANIF20的IP地址。

    <HUAWEI> system-view
    [~HUAWEI] sysname Switch
    [*HUAWEI] commit
    [~Switch] vlan batch 20
    [*Switch] interface 10ge 1/0/2
    [*Switch-10GE1/0/2] port default vlan 20
    [*Switch-10GE1/0/2] quit
    [*Switch] interface vlanif 20
    [*Switch-Vlanif20] ip address 10.110.1.1 16
    [*Switch-Vlanif20] quit
    [*Switch] commit
    

  2. 配置Switch接口10GE1/0/1加入VLAN10。配置VLANIF10的IP地址。

    [~Switch] vlan batch 10
    [*Switch] interface 10ge 1/0/1
    [*Switch-10GE1/0/1] port default vlan 10
    [*Switch-10GE1/0/1] quit
    [*Switch] interface vlanif 10
    [*Switch-Vlanif10] ip address 10.1.1.2 16
    [*Switch-Vlanif10] quit
    [*Switch] commit
    

  3. 使能UDP Helper功能。

    [~Switch] ip udp-helper enable
    [*Switch] commit

  4. Switch接口VLANIF20上配置中继转发的目的服务器。

    [~Switch] interface vlanif 20
    [*Switch-Vlanif20] ip udp-helper server 10.1.1.1
    [*Switch-Vlanif20] quit
    [*Switch] commit
    

  5. 验证配置结果。

    在完成UDP Helper配置以后,当局域网主机通过NetBIOS-NS的解析使用主机名访问时,UDP Helper会统计中继转发的报文信息。

    [~Switch] display ip udp-helper server
    Vlan Interface          Server IP        Packet Received  Packet Dropped
    ------------------------------------------------------------------------
    Vlanif20                10.1.1.1                     201               0

配置文件

Switch的配置文件

#
sysname Switch
#
vlan batch 10 20
#
ip udp-helper enable
#
interface Vlanif10
 ip address 10.1.1.2 255.255.0.0
#  
interface Vlanif20
 ip address 10.110.1.1 255.255.0.0      
 ip udp-helper server 10.1.1.1 
#
interface 10GE1/0/1
 port default vlan 10
#
interface 10GE1/0/2
 port default vlan 20
#
return
翻译
下载文档
更新时间:2019-04-19

文档编号:EDOC1100039516

浏览量:8212

下载量:206

平均得分:
本文档适用于这些产品
相关版本
相关文档
Share
上一页 下一页