所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

CloudEngine 12800, 12800E V200R005C00 配置指南-IP业务

本文档介绍了IP业务的配置,具体包括IPv4基础配置、ARP配置、DHCP配置、DNS配置、UDP Helper配置、IP性能配置、IPv6基础配置、DHCPv6配置、IPv6 DNS配置和IPv6过渡技术配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置VXLAN集中式网关作为DHCPv6 Relay示例

配置VXLAN集中式网关作为DHCPv6 Relay示例

以跨VPN集中式VXLAN网关的典型应用场景为例,描述如何配置VXLAN集中式网关作为DHCPv6 Relay。

组网需求

图8-26所示,某企业在数据中心中分别拥有VM1、VM2,VM1属于VLAN 10,VM2属于VLAN 20,VM1和VM2均属于VPN1,DHCPv6 Server属于公网。现需要通过在VXLAN三层网关上部署DHCPv6 Relay实现VM1和VM2向DHCPv6 Server申请IPv6地址。

图8-26 配置VXLAN集中式网关作为DHCPv6 Relay组网图

配置思路

采用如下思路配置DHCPv6 Relay支持VXLAN:
  1. 配置VXLAN隧道。
    1. 在Device1、Device2和Device3上配置路由协议,保证网络三层互通。

    2. 在Device1和Device3上配置业务接入点实现区分业务流量。

    3. 在Device1、Device2和Device3上使能EVPN作VXLAN控制平面功能。

    4. 在Device1、Device2和Device3上配置BGP EVPN对等体关系。

    5. 在Device1、Device2和Device3上配置EVPN实例。

    6. 在Device1、Device2和Device3上配置头端复制功能。

    7. 在Device2上配置L3VPN实例。

    8. 在Device2上配置VXLAN三层网关。

  2. 配置DHCPv6 Relay。
    1. 在Device2的VBDIF10上使能DHCPv6中继功能。
    2. 在Device2的VBDIF10上指定DHCPv6服务器地址。
    3. 在Device2的VBDIF10上插入vss-control选项以及指定中继报文的源IP地址。
  3. 配置DHCPv6 Server。

数据准备

为完成此配置示例,需准备如下的数据:

  • 网络中设备互连的接口IP地址。
  • VM1所属的VLAN ID是VLAN 10,VM2所属的VLAN ID是VLAN 20。
  • 广播域BD ID是BD 10。
  • VXLAN网络标识VNI ID是VNI 5010。
  • EVPN实例的RD值为11:1、21:1和31:2,RT值为1:1。
  • L3VPN实例的RD值是10:1,RT值是3:3。

配置注意事项

对于CE12800,除了操作步骤中的配置之外,可以根据需要额外执行如下命令:
  • 在系统视图下执行assign forward nvo3 service extend enable命令,使能NVO3业务扩展功能。

    说明:

    设备默认情况下,NVO3的业务扩展功能未使能。此时在设备上部署NVO3业务后,若再叠加其他需要使用ACL的业务(如MQC、简化ACL、流量监管、BD流量统计、DHCP等),会较大概率出现叠加失败的情况。在部署NVO3业务的设备上,使能此命令后,在EC/ED/EF/EG(除CE-L48GT-EC、CE-L48GS-EC外)单板上,能减少这种业务叠加失败的问题。

  • 在系统视图下执行assign forward nvo3 f-linecard compatibility enable命令,用来防止在单板处于非增强模式时VXLAN流量不通。

    说明:

    在单板的互通模式为非增强模式时,如果VXLAN流量跨板转发,有可能出现VXLAN流量不通的问题。所以当单板的互通模式为非增强模式时必须配置assign forward nvo3 f-linecard compatibility enable命令才能正常使用VXLAN功能。

配置VXLAN举例的相关约束已经在操作步骤中加以说明。如果还想了解更多约束,请参见VXLAN配置注意事项。

操作步骤

  1. 配置路由协议

    分别配置Device1、Device2和Device3各接口IP地址。配置OSPF时,注意需要发布32位Loopback接口地址。

    # 配置Device1
    <HUAWEI> system-view
    [~HUAWEI] sysname Device1
    [*HUAWEI] commit
    [~Device1] interface loopback 1
    [*Device1-LoopBack1] ip address 2.2.2.2 32
    [*Device1-LoopBack1] quit
    [*Device1] interface 10ge 1/0/1
    [*Device1-10GE1/0/1] undo portswitch
    [*Device1-10GE1/0/1] ip address 192.168.1.1 24
    [*Device1-10GE1/0/1] quit
    [*Device1] ospf
    [*Device1-ospf-1] area 0
    [*Device1-ospf-1-area-0.0.0.0] network 2.2.2.2 0.0.0.0
    [*Device1-ospf-1-area-0.0.0.0] network 192.168.1.0 0.0.0.255
    [*Device1-ospf-1-area-0.0.0.0] quit
    [*Device1-ospf-1] quit
    [*Device1] commit

    Device2、Device3的配置与Device1配置类似,这里不再赘述。具体配置过程略,请参考配置文件

    OSPF成功配置后,Device之间可通过OSPF协议发现对方的Loopback接口的IP地址,并能互相ping通。

  2. 配置VXLAN隧道模式并使能VXLAN的ACL扩展功能(仅CE12800需要配置此步骤)

    # 配置Device1。Device2、Device3配置与Device1类似,这里不再赘述。

    [~Device1] ip tunnel mode vxlan
    [*Device1] assign forward nvo3 acl extend enable
    [*Device1] commit
    
    说明:

    配置VXLAN隧道模式、使能VXLAN的ACL扩展功能后,需要保存配置并重启设备才能生效,您可以选择立即重启或完成所有配置后再重启。

  3. 分别在Device1、Device3上配置业务接入点

    # 配置Device1
    [~Device1] bridge-domain 10
    [*Device1-bd10] quit
    [*Device1] interface 10GE1/0/2.1 mode l2
    [*Device1-10GE1/0/2.1] encapsulation dot1q vid 10
    [*Device1-10GE1/0/2.1] bridge-domain 10
    [*Device1-10GE1/0/2.1] quit
    [*Device1] commit

    Device3的配置与Device1配置类似,这里不再赘述。具体配置过程略,请参考配置文件

  4. 分别在Device1、Device2、Device3上使能EVPN作VXLAN控制平面功能

    # 配置Device1
    [~Device1] evpn-overlay enable
    [*Device1] commit

    Device2、Device3的配置与Device1配置类似,这里不再赘述。具体配置过程略,请参考配置文件

  5. 配置BGP EVPN对等体关系

    # 配置Device1

    [~Device1] bgp 100
    [*Device1-bgp] peer 3.3.3.3 as-number 100
    [*Device1-bgp] peer 3.3.3.3 connect-interface LoopBack1
    [*Device1-bgp] peer 4.4.4.4 as-number 100
    [*Device1-bgp] peer 4.4.4.4 connect-interface LoopBack1
    [*Device1-bgp] l2vpn-family evpn
    [*Device1-bgp-af-evpn] peer 3.3.3.3 enable
    Warning: This operation will reset the peer session. Continue? [Y/N]: y
    [*Device1-bgp-af-evpn] peer 4.4.4.4 enable
    Warning: This operation will reset the peer session. Continue? [Y/N]: y
    [*Device1-bgp-af-evpn] quit
    [*Device1-bgp] quit
    [*Device1] commit

    Device2、Device3的配置与Device1配置类似,这里不再赘述。具体配置过程略,请参考配置文件

  6. 分别在Device1、Device2和Device3上配置EVPN实例

    # 配置Device1
    [~Device1] bridge-domain 10
    [~Device1-bd10] vxlan vni 5010
    [*Device1-bd10] evpn
    [*Device1-bd10-evpn] route-distinguisher 11:1
    [*Device1-bd10-evpn] vpn-target 1:1
    [*Device1-bd10-evpn] quit
    [*Device1-bd10] quit
    [*Device1] commit

    Device2和Device3的配置与Device1配置类似,这里不再赘述。具体配置过程略,请参考配置文件

  7. 配置头端复制功能

    # 配置Device1
    [~Device1] interface nve 1
    [*Device1-Nve1] source 2.2.2.2
    [*Device1-Nve1] vni 5010 head-end peer-list protocol bgp
    [*Device1-Nve1] quit
    [*Device1] commit

    Device2和Device3的配置与Device1配置类似,这里不再赘述。具体配置过程略,请参考配置文件

  8. 在Device2上配置L3VPN实例

    [~Device2] ip vpn-instance vpn1
    [*Device2-vpn-instance-vpn1] ipv6-family
    [*Device2-vpn-instance-vpn1-af-ipv6] route-distinguisher 10:1
    [*Device2-vpn-instance-vpn1-af-ipv6] vpn-target 3:3
    [*Device2-vpn-instance-vpn1-af-ipv6] commit
    [~Device2-vpn-instance-vpn1-af-ipv6] quit
    [~Device2-vpn-instance-vpn1] quit

  9. 在Device2上配置VXLAN三层网关

    [~Device2] interface vbdif 10
    [*Device2-Vbdif10] ip binding vpn-instance vpn1
    [*Device2-Vbdif10] ipv6 enable
    [*Device2-Vbdif10] ipv6 address fc00:1::1 96
    [*Device2-Vbdif10] quit
    [*Device2] commit

  10. 检查配置结果

    上述配置成功后,执行display vxlan tunnel命令可查看到VXLAN隧道的信息;在Device1、Device2、Device3上执行display vxlan vni命令可查看到VNI的状态是Up。以Device2显示为例。

    [~Device2] display vxlan tunnel
    Number of vxlan tunnel : 2
    Tunnel ID   Source                Destination           State  Type     Uptime
    -----------------------------------------------------------------------------------
    4026531843  3.3.3.3               2.2.2.2               up     dynamic  0035h21m
    4026531844  3.3.3.3               4.4.4.4               up     dynamic  0035h22m
    [~Device2] display vxlan vni
    Number of vxlan vni : 1
    VNI            BD-ID            State
    ---------------------------------------
    5010           10               up

  11. 在Device2上配置DHCPv6 Relay。

    [~Device2] dhcpv6 enable
    [*Device2] interface Vbdif10
    [*Device2-Vbdif10] dhcpv6 relay destination fc00:2::2 public-net
    [*Device2-Vbdif10] dhcpv6 vss-control insert enable
    [*Device2-Vbdif10] dhcpv6 relay source-ip-address fc00:2::1
    [*Device2-Vbdif10] commit

  12. 配置DHCPv6服务器。

    具体配置过程略。DHCPv6服务器需要满足以下条件:
    • 在DHCPv6服务器上配置地址池,以便服务器端分配正确的IPv6地址给客户端。

    • 建议配置地址池租期,提高IPv6地址的使用效率。

  13. 验证配置结果

    在Device2上执行display dhcpv6 relay statistics命令,如果能够看到DHCPv6报文统计信息,则说明配置成功。

    [~Device2] display dhcpv6 relay statistics
      -------------------------------------------------------------------
      Bad packets received                                :   0
      DHCPv6 packets received from clients                :   41357
             DHCPv6 SOLICIT packets received              :   41357
             DHCPv6 REQUEST packets received              :   0
             DHCPv6 CONFIRM packets received              :   0
             DHCPv6 RENEW packets received                :   0
             DHCPv6 REBIND packets received               :   0
             DHCPv6 DECLINE packets received              :   0
             DHCPv6 RELEASE packets received              :   0
             DHCPv6 INFORMATION-REQUEST packets received  :   0
    
      DHCPv6 packets received from relay agents or servers:   6
             DHCPv6 RELAY-FORWARD packets received        :   6
             DHCPv6 RELAY-REPLY packets received          :   0
    
      DHCPv6 packets sent to clients                      :   0
             DHCPv6 ADVERTISE packets sent                :   0
             DHCPv6 REPLY packets sent                    :   0
             DHCPv6 RECONFIGURE packets sent              :   0
    
      DHCPv6 packets sent to relay agents or servers      :   41333
             DHCPv6 RELAY-FORWARD packets sent            :   41333
             DHCPv6 RELAY-REPLY packets sent              :   0
    
      DHCPv6 packets dropped                              :   33
             Table full                                   :   0
             General error                                :   33
             IPSec authentication failed                  :   0
    
      -------------------------------------------------------------------

配置文件

  • Device1的配置文件

    #
    sysname Device1
    #
    assign forward nvo3 acl extend enable   //仅CE12800需要配置此步骤
    #
    evpn-overlay enable
    #
    bridge-domain 10
     vxlan vni 5010
     evpn
      route-distinguisher 11:1
      vpn-target 1:1 export-extcommunity
      vpn-target 1:1 import-extcommunity
    #
    interface 10GE1/0/1
     undo portswitch
     ip address 192.168.1.1 255.255.255.0
    #
    interface 10GE1/0/2.1 mode l2
     encapsulation dot1q vid 10
     bridge-domain 10
    #
    interface LoopBack1
     ip address 2.2.2.2 255.255.255.255
    #
    interface Nve1
     source 2.2.2.2
     vni 5010 head-end peer-list protocol bgp
    #
    bgp 100
     peer 3.3.3.3 as-number 100
     peer 3.3.3.3 connect-interface LoopBack1
     peer 4.4.4.4 as-number 100
     peer 4.4.4.4 connect-interface LoopBack1
     #
     ipv4-family unicast
      peer 3.3.3.3 enable
      peer 4.4.4.4 enable
     #
     l2vpn-family evpn
      policy vpn-target
      peer 3.3.3.3 enable
      peer 4.4.4.4 enable
    #
    ospf 1
     area 0.0.0.0
      network 2.2.2.2 0.0.0.0
      network 192.168.1.0 0.0.0.255
    #
    return
  • Device2的配置文件

    #
    sysname Device2
    #
    assign forward nvo3 acl extend enable   //仅CE12800需要配置此步骤
    #
    dhcpv6 enable
    #
    evpn-overlay enable
    #
    ip vpn-instance vpn1
     ipv6-family
      route-distinguisher 10:1
      vpn-target 3:3 export-extcommunity
      vpn-target 3:3 import-extcommunity
    #
    bridge-domain 10
     vxlan vni 5010
     evpn
      route-distinguisher 21:1
      vpn-target 1:1 export-extcommunity
      vpn-target 1:1 import-extcommunity
    #
    interface Vbdif10
     ip binding vpn-instance vpn1
     ipv6 enable
     ipv6 address FC00:1::1/96
     dhcpv6 vss-control insert enable
     dhcpv6 relay destination FC00:2::2 public-net
     dhcpv6 relay source-ip-address FC00:2::1
    #
    interface 10GE1/0/1
     undo portswitch
     ip address 192.168.1.2 255.255.255.0
    #
    interface 10GE1/0/2
     undo portswitch
     ip address 192.168.2.1 255.255.255.0
    #
    interface 10GE1/0/3
     undo portswitch
     ipv6 enable
     ipv6 address FC00:2::1 96
    #
    interface LoopBack1
     ip address 3.3.3.3 255.255.255.255
    #
    interface Nve1
     source 3.3.3.3
     vni 5010 head-end peer-list protocol bgp
    #
    bgp 100
     peer 2.2.2.2 as-number 100
     peer 2.2.2.2 connect-interface LoopBack1
     peer 4.4.4.4 as-number 100
     peer 4.4.4.4 connect-interface LoopBack1
     #
      ipv4-family unicast
      peer 2.2.2.2 enable
      peer 4.4.4.4 enable
     #
     l2vpn-family evpn
      policy vpn-target
      peer 2.2.2.2 enable
      peer 4.4.4.4 enable
    #
    ospf 1
     area 0.0.0.0
      network 3.3.3.3 0.0.0.0
      network 192.168.1.0 0.0.0.255
      network 192.168.2.0 0.0.0.255
    #
    return
  • Device3的配置文件

    #
    sysname Device3
    #
    assign forward nvo3 acl extend enable   //仅CE12800需要配置此步骤
    #
    evpn-overlay enable
    #
    bridge-domain 10
     vxlan vni 5010
     evpn
      route-distinguisher 31:2
      vpn-target 1:1 export-extcommunity
      vpn-target 1:1 import-extcommunity
    #
    interface 10GE1/0/1
     undo portswitch
     ip address 192.168.2.2 255.255.255.0
    #
    interface 10GE1/0/2.1 mode l2
     encapsulation dot1q vid 20
     bridge-domain 10
    #
    interface LoopBack1
     ip address 4.4.4.4 255.255.255.255
    #
    interface Nve1
     source 4.4.4.4
     vni 5010 head-end peer-list protocol bgp
    #
    bgp 100
     peer 2.2.2.2 as-number 100
     peer 2.2.2.2 connect-interface LoopBack1
     peer 3.3.3.3 as-number 100
     peer 3.3.3.3 connect-interface LoopBack1
     #
     ipv4-family unicast
      peer 2.2.2.2 enable
      peer 3.3.3.3 enable
     #
     l2vpn-family evpn
      policy vpn-target
      peer 2.2.2.2 enable
      peer 3.3.3.3 enable
    #
    ospf 1
     area 0.0.0.0
      network 4.4.4.4 0.0.0.0
      network 192.168.2.0 0.0.0.255
    #
    return
翻译
下载文档
更新时间:2019-04-19

文档编号:EDOC1100039516

浏览量:8059

下载量:205

平均得分:
本文档适用于这些产品
相关版本
相关文档
Share
上一页 下一页