所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

CloudEngine 12800, 12800E V200R005C00 配置指南-IP业务

本文档介绍了IP业务的配置,具体包括IPv4基础配置、ARP配置、DHCP配置、DNS配置、UDP Helper配置、IP性能配置、IPv6基础配置、DHCPv6配置、IPv6 DNS配置和IPv6过渡技术配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置IPv6 over IPv4 GRE隧道示例

配置IPv6 over IPv4 GRE隧道示例

组网需求

图10-8所示,企业在A地和B地分别设有数据中心,并且数据中心A和数据中心B均部署为IPv6网络。数据中心A中服务器Server_1的网关为Switch_1。数据中心B中服务器Server_2的网关为Switch_2。数据中心A和数据中心B之间的网络为IPv4网络,并且IPv4网络内Router_1和Router_2之间路由可达。

用户希望在数据中心A和数据中心B之间建立一条稳定的通信链路,使数据中心A内的服务器Server_1和数据中心B内的服务器Server_2之间能够实现互通,并且尽可能保证数据中心之间数据传输的可靠性。

图10-8 配置IPv6 over IPv4 GRE隧道组网图

配置思路

配置IPv6 over IPv4 GRE隧道的思路如下:

  1. 配置Switch_1、Switch_2各接口的IP地址,使Switch_1可以和IPv4网络、数据中心A的IPv6网络互通,使Switch_2可以和IPv4网络、数据中心B的IPv6网络互通。

  2. 配置OSPF路由,使Switch_1与Switch_2之间IPv4路由可达。

  3. 配置Tunnel接口,使Swtich_1和Switch_2之间建立IPv6 over IPv4 GRE隧道;并且配置Keepalive检测功能,保证数据中心之间数据传输的可靠性。

  4. 配置Tunnel路由,通过OSPFv3路由实现,使Server_1和Server_2之间可以通过IPv6 over IPv4 GRE隧道实现互通。

操作步骤

  1. 配置各物理接口的IP地址

    # 配置Switch_1。

    <HUAWEI> system-view
    [~HUAWEI] sysname Switch_1
    [*HUAWEI] commit
    [~Switch_1] vlan batch 100 300
    [*Switch_1] interface 10ge 1/0/1
    [*Switch_1-10GE1/0/1] port link-type trunk
    [*Switch_1-10GE1/0/1] port trunk allow-pass vlan 100
    [*Switch_1-10GE1/0/1] quit
    [*Switch_1] interface 10ge 1/0/2
    [*Switch_1-10GE1/0/2] port default vlan 300
    [*Switch_1-10GE1/0/2] quit
    [*Switch_1] interface vlanif 100
    [*Switch_1-Vlanif100] ip address 192.168.50.2 24
    [*Switch_1-Vlanif100] quit
    [*Switch_1] interface vlanif 300
    [*Switch_1-Vlanif300] ipv6 enable
    [*Switch_1-Vlanif300] ipv6 address fc00:1::1 64
    [*Switch_1-Vlanif300] quit
    [*Switch_1] commit
    

    # 配置Switch_2。

    <HUAWEI> system-view
    [~HUAWEI] sysname Switch_2
    [*HUAWEI] commit
    [~Switch_2] vlan batch 200 300
    [*Switch_2] interface 10ge 1/0/1
    [*Switch_2-10GE1/0/1] port link-type trunk
    [*Switch_2-10GE1/0/1] port trunk allow-pass vlan 200
    [*Switch_2-10GE1/0/1] quit
    [*Switch_2] interface 10ge 1/0/2
    [*Switch_2-10GE1/0/2] port default vlan 300
    [*Switch_2-10GE1/0/2] quit
    [*Switch_2] interface vlanif 200
    [*Switch_2-Vlanif200] ip address 192.168.51.2 24
    [*Switch_2-Vlanif200] quit
    [*Switch_2] interface vlanif 300
    [*Switch_2-Vlanif300] ipv6 enable
    [*Switch_2-Vlanif300] ipv6 address fc00:2::1 64
    [*Switch_2-Vlanif300] quit
    [*Switch_2] commit
    

  2. 配置OSPF路由,使Switch_1与Switch_2之间IPv4路由可达

    # 配置Switch_1。

    [~Switch_1] ospf 1
    [*Switch_1-ospf-1] area 0
    [*Switch_1-ospf-1-area-0.0.0.0] network 192.168.50.0 0.0.0.255
    [*Switch_1-ospf-1-area-0.0.0.0] quit
    [*Switch_1-ospf-1] quit
    [*Switch_1] commit
    

    # 配置Switch_2。

    [~Switch_2] ospf 1
    [*Switch_2-ospf-1] area 0
    [*Switch_2-ospf-1-area-0.0.0.0] network 192.168.51.0 0.0.0.255
    [*Switch_2-ospf-1-area-0.0.0.0] quit
    [*Switch_2-ospf-1] quit
    [*Switch_2] commit
    

  3. 配置隧道模式

    # 配置Switch_1。

    [~Switch_1] ip tunnel mode gre
    [*Switch_1] commit

    # 配置Switch_2。

    [~Switch_2] ip tunnel mode gre
    [*Switch_2] commit
    说明:

    此命令功能需要保存配置并重启设备才能生效,您可以选择立即重启或完成所有配置后再重启。

  4. 配置Tunnel接口

    # 配置Switch_1。

    [~Switch_1] interface tunnel 1
    [*Switch_1-Tunnel1] tunnel-protocol gre
    [*Switch_1-Tunnel1] source 192.168.50.2
    [*Switch_1-Tunnel1] destination 192.168.51.2
    [*Switch_1-Tunnel1] ipv6 enable
    [*Switch_1-Tunnel1] ipv6 address fc00:3::1 64
    [*Switch_1-Tunnel1] keepalive
    [*Switch_1-Tunnel1] quit
    [*Switch_1] commit
    

    # 配置Switch_2。

    [~Switch_2] interface tunnel 1
    [*Switch_2-Tunnel1] tunnel-protocol gre
    [*Switch_2-Tunnel1] source 192.168.51.2
    [*Switch_2-Tunnel1] destination 192.168.50.2
    [*Switch_2-Tunnel1] ipv6 enable
    [*Switch_2-Tunnel1] ipv6 address fc00:3::2 64
    [*Switch_2-Tunnel1] keepalive
    [*Switch_2-Tunnel1] quit
    [*Switch_2] commit
    

  5. 配置Tunnel的路由

    # 配置Switch_1。

    [~Switch_1] ospfv3 2
    [*Switch_1-ospfv3-2] router-id 1.1.1.1
    [*Switch_1-ospfv3-2] quit
    [*Switch_1] interface vlanif 300
    [*Switch_1-Vlanif300] ospfv3 2 area 0
    [*Switch_1-Vlanif300] quit
    [*Switch_1] interface tunnel 1
    [*Switch_1-Tunnel1] ospfv3 2 area 0
    [*Switch_1-Tunnel1] quit
    [*Switch_1] commit
    [~Switch_1] quit
    

    # 配置Switch_2。

    [~Switch_2] ospfv3 2
    [*Switch_2-ospfv3-2] router-id 2.2.2.2
    [*Switch_2-ospfv3-2] quit
    [*Switch_2] interface vlanif 300
    [*Switch_2-Vlanif300] ospfv3 2 area 0
    [*Switch_2-Vlanif300] quit
    [*Switch_2] interface tunnel 1
    [*Switch_2-Tunnel1] ospfv3 2 area 0
    [*Switch_2-Tunnel1] quit
    [*Switch_2] commit
    [~Switch_2] quit
    

  6. 检查配置结果

    # 在Switch_1上能够Ping通Switch_2的IPv4地址192.168.51.2。

    <Switch_1> ping 192.168.51.2
      PING 192.168.51.2: 56  data bytes, press CTRL_C to break
        Reply from 192.168.51.2: bytes=56 Sequence=1 ttl=253 time=1 ms
        Reply from 192.168.51.2: bytes=56 Sequence=2 ttl=253 time=1 ms
        Reply from 192.168.51.2: bytes=56 Sequence=3 ttl=253 time=1 ms
        Reply from 192.168.51.2: bytes=56 Sequence=4 ttl=253 time=1 ms
        Reply from 192.168.51.2: bytes=56 Sequence=5 ttl=253 time=1 ms
    
      --- 192.168.51.2 ping statistics ---
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
        round-trip min/avg/max = 1/1/1 ms

    # 在Switch_1上能够Ping通Switch_2上Tunnel1接口的IPv6地址fc00:3::2。

    <Switch_1> ping ipv6 fc00:3::2
      PING FC00:3::2 : 56  data bytes, press CTRL_C to break
        Reply from FC00:3::2
        bytes=56 Sequence=1 hop limit=63  time = 28 ms
        Reply from FC00:3::2
        bytes=56 Sequence=2 hop limit=63  time = 27 ms
        Reply from FC00:3::2
        bytes=56 Sequence=3 hop limit=63  time = 26 ms
        Reply from FC00:3::2
        bytes=56 Sequence=4 hop limit=63  time = 27 ms
        Reply from FC00:3::2
        bytes=56 Sequence=5 hop limit=63  time = 26 ms
      --- FC00:3::2 ping statistics ---
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
        round-trip min/avg/max = 26/26/28 ms

    # Server_1和Server_2可以互相Ping通。

配置文件

  • Switch_1的配置文件

    #
    sysname Switch_1
    #
    vlan batch 100 300
    #
    ip tunnel mode gre
    #
    ospfv3 2
     router-id 1.1.1.1
     area 0.0.0.0
    #
    interface Vlanif100
     ip address 192.168.50.2 255.255.255.0
    #
    interface Vlanif300
     ipv6 enable
     ipv6 address FC00:1::1/64
     ospfv3 2 area 0.0.0.0
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface 10GE1/0/2
     port default vlan 300
    #
    interface Tunnel1
     ipv6 enable
     ipv6 address FC00:3::1/64
     tunnel-protocol gre
     keepalive 
     source 192.168.50.2
     destination 192.168.51.2
     ospfv3 2 area 0.0.0.0
    #
    ospf 1
     area 0.0.0.0
      network 192.168.50.0 0.0.0.255
    #
    return
  • Switch_2的配置文件

    #
    sysname Switch_2
    #
    vlan batch 200 300
    #
    ip tunnel mode gre
    #
    ospfv3 2
     router-id 2.2.2.2
     area 0.0.0.0
    #
    interface Vlanif200
     ip address 192.168.51.2 255.255.255.0
    #
    interface Vlanif300
     ipv6 enable
     ipv6 address FC00:2::1/64
     ospfv3 2 area 0.0.0.0
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 200
    #
    interface 10GE1/0/2
     port default vlan 300
    #
    interface Tunnel1
     ipv6 enable
     ipv6 address FC00:3::2/64
     tunnel-protocol gre
     keepalive 
     source 192.168.51.2
     destination 192.168.50.2
     ospfv3 2 area 0.0.0.0
    #
    ospf 1
     area 0.0.0.0
      network 192.168.51.0 0.0.0.255
    #
    return
翻译
下载文档
更新时间:2019-04-19

文档编号:EDOC1100039516

浏览量:7918

下载量:205

平均得分:
本文档适用于这些产品
相关版本
相关文档
Share
上一页 下一页