所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

CloudEngine 8800, 7800, 6800, 5800 V200R005C00 配置指南-以太网交换

本文档针对设备的以太网业务,主要包括以太网交换概述、MAC配置、以太网链路聚合配置、M-LAG(跨设备链路聚合)配置、VLAN配置、QinQ配置、VLAN mapping配置、GVRP配置、STP/RSTP配置、MSTP配置、VBST配置、ERPS(G.8032)配置、Loopback Detection配置和二层协议透明传输配置。

评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置基于MQC实现VLAN Mapping示例

配置基于MQC实现VLAN Mapping示例

组网需求

图7-9所示,某数据中心网络中,服务器存储的信息包括视频和数据,用户分为金牌用户和银牌用户,金牌用户和银牌用户所属的VLAN分别为VLAN200和VLAN300,并且通过企业骨干网访问服务器,企业骨干网分配给金牌用户的VLAN为VLAN2,分配给银牌用户的VLAN为VLAN3,Switch2和Switch3是企业骨干网边缘设备。由于视频服务器和数据服务器规划的VLAN和企业骨干网规划的VLAN不同,为了保证金牌用户能访问视频服务器,银牌用户能访问数据服务器,可以通过在Switch2和Switch3上配置基于MQC实现VLAN Mapping的功能来实现上述需求。

图7-9 配置基于MQC实现VLAN Mapping组网图

配置思路

采用如下的思路配置基于MQC实现VLAN Mapping:

  1. 在Switch2和Switch3上创建VLAN2和VLAN3。

  2. 在Switch2和Switch3上配置流分类、流行为和流策略。

  3. 在Switch2和Switch3上配置接口类型并加入VLAN。

  4. 在Switch2和Switch3的接口上应用MQC来实现VLAN Mapping功能。

操作步骤

  1. 创建VLAN

    # 在Switch1上创建VLAN200、VLAN300,并将连接服务器的接口分别加入VLAN。

    <HUAWEI> system-view
    [~HUAWEI] sysname Switch1
    [*HUAWEI] commit
    [~Switch1] vlan batch 200 300
    [*Switch1] interface 10ge 1/0/2
    [*Switch1-10GE1/0/2] port default vlan 200
    [*Switch1-10GE1/0/2] quit
    [*Switch1] interface 10ge 1/0/3
    [*Switch1-10GE1/0/3] port default vlan 300
    [*Switch1-10GE1/0/3] quit
    [*Switch1] commit
    

    # 在Switch4上创建VLAN200、VLAN300,并将连接用户的接口分别加入VLAN,配置过程与Switch1相同,不再赘述。

    # 在Switch2上创建VLAN2、VLAN3,即替换后的外层VLAN。

    <HUAWEI> system-view
    [~HUAWEI] sysname Switch2
    [*HUAWEI] commit
    [~Switch2] vlan batch 2 3
    [*Switch2] commit

    # 在Switch3上创建VLAN200、VLAN300,即替换后的外层VLAN。

    <HUAWEI> system-view
    [~HUAWEI] sysname Switch3
    [*HUAWEI] commit
    [~Switch3] vlan batch 200 300
    [*Switch3] commit

  2. 在Switch2和Swicth3上配置流分类、流行为和流策略

    # 配置Switch2的流分类、流行为和流策略。

    [~Switch2] traffic classifier name1
    [*Switch2-classifier-name1] if-match vlan 200
    [*Switch2-classifier-name1] quit
    [*Switch2] traffic behavior name1
    [*Switch2-behavior-name1] vlan-mapping vlan 2
    [*Switch2-behavior-name1] quit
    [*Switch2] traffic classifier name2
    [*Switch2-classifier-name2] if-match vlan 300
    [*Switch2-classifier-name2] quit
    [*Switch2] traffic behavior name2
    [*Switch2-behavior-name2] vlan-mapping vlan 3
    [*Switch2-behavior-name2] quit
    [*Switch2] traffic policy name1
    [*Switch2-trafficpolicy-name1] classifier name1 behavior name1
    [*Switch2-trafficpolicy-name1] classifier name2 behavior name2
    [*Switch2-trafficpolicy-name1] quit
    [*Switch2] commit
    

    # 配置Switch3的流分类、流行为和流策略。

    [~Switch3] traffic classifier name1
    [*Switch3-classifier-name1] if-match vlan 2
    [*Switch3-classifier-name1] quit
    [*Switch3] traffic behavior name1
    [*Switch3-behavior-name1] vlan-mapping vlan 200
    [*Switch3-behavior-name1] quit
    [*Switch3] traffic classifier name2
    [*Switch3-classifier-name2] if-match vlan 3
    [*Switch3-classifier-name2] quit
    [*Switch3] traffic behavior name2
    [*Switch3-behavior-name2] vlan-mapping vlan 300
    [*Switch3-behavior-name2] quit
    [*Switch3] traffic policy name1
    [*Switch3-trafficpolicy-name1] classifier name1 behavior name1
    [*Switch3-trafficpolicy-name1] classifier name2 behavior name2
    [*Switch3-trafficpolicy-name1] quit
    [*Switch3] commit
    

  3. 在接口上应用流策略实现VLAN Mapping功能。

    # 配置Switch2的接口10GE1/0/1。

    [~Switch2] interface 10ge 1/0/1
    [~Switch2-10GE1/0/1] port link-type trunk
    [*Switch2-10GE1/0/1] port trunk allow-pass vlan 2 3
    [*Switch2-10GE1/0/1] traffic-policy name1 inbound
    [*Switch2-10GE1/0/1] quit
    [*Switch2] commit

    # 配置Switch3的接口10GE1/0/2。

    [~Switch3] interface 10ge 1/0/2
    [~Switch3-10GE1/0/2] port link-type trunk
    [*Switch3-10GE1/0/2] port trunk allow-pass vlan 200 300
    [*Switch3-10GE1/0/2] traffic-policy name1 inbound
    [*Switch3-10GE1/0/2] quit
    [*Switch3] commit

  4. 配置其它接口

    # 在Switch1上配置接口10GE1/0/1加入VLAN200、VLAN300。Switch4上接口10GE1/0/1的配置与Switch1类似,不再赘述。

    [~Switch1] interface 10ge 1/0/1
    [~Switch1-10GE1/0/1] port link-type trunk
    [*Switch1-10GE1/0/1] port trunk allow-pass vlan 200 300
    [*Switch1-10GE1/0/1] quit
    [*Switch1] commit

    # 在Switch2上配置接口10GE1/0/2加入VLAN2、VLAN3。在Switch4上配置接口10GE1/0/1加入VLAN200、VLAN300,配置与Switch1类似,不再赘述。

    [~Switch2] interface 10ge 1/0/2
    [~Switch2-10GE1/0/2] port link-type trunk
    [*Switch2-10GE1/0/2] port trunk allow-pass vlan 2 3
    [*Switch2-10GE1/0/2] quit
    [*Switch2] commit

  5. 验证配置结果

    上述配置完成后,金牌用户能访问视频服务器,银牌用户能访问数据服务器。

配置文件

  • Switch1的配置文件

    #
    sysname Switch1
    #
    vlan batch 200 300
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 200 300
    #
    interface 10GE1/0/2
     port default vlan 200
    #
    interface 10GE1/0/3
     port default vlan 300
    #
    return
  • Switch2的配置文件

    #
    sysname Switch2
    #
    vlan batch 2 to 3
    #
    traffic classifier name1 type or
     if-match vlan 200
    #
    traffic classifier name2 type or
     if-match vlan 300
    #
    traffic behavior name1
     vlan-mapping vlan 2
    #
    traffic behavior name2
     vlan-mapping vlan 3
    #
    traffic policy name1
     classifier name1 behavior name1 precedence 5
     classifier name2 behavior name2 precedence 10
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 2 to 3
     traffic-policy name1 inbound
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 2 to 3
    #
    return
  • Switch3的配置文件

    #
    sysname Switch3
    #
    vlan batch 200 300
    #
    traffic classifier name1 type or
     if-match vlan 2
    #
    traffic classifier name2 type or
     if-match vlan 3
    #
    traffic behavior name1
     vlan-mapping vlan 200
    #
    traffic behavior name2
     vlan-mapping vlan 300
    #
    traffic policy name1
     classifier name1 behavior name1 precedence 5
     classifier name2 behavior name2 precedence 10
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 200 300
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 200 300
     traffic-policy name1 inbound
    #
    return
  • Switch4的配置文件

    #
    sysname Switch4
    #
     vlan batch 200 300
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 200 300
    #
    interface 10GE1/0/2
     port default vlan 200
    #
    interface 10GE1/0/3
     port default vlan 300
    #
    return
翻译
下载文档
更新时间:2019-04-19

文档编号:EDOC1100039617

浏览量:32366

下载量:261

平均得分:
本文档适用于这些产品

相关版本

相关文档

Share
上一页 下一页