所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

CloudEngine 8800, 7800, 6800, 5800 V200R005C00 配置指南-以太网交换

本文档针对设备的以太网业务,主要包括以太网交换概述、MAC配置、以太网链路聚合配置、M-LAG(跨设备链路聚合)配置、VLAN配置、QinQ配置、VLAN mapping配置、GVRP配置、STP/RSTP配置、MSTP配置、VBST配置、ERPS(G.8032)配置、Loopback Detection配置和二层协议透明传输配置。

评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置基于MQC的灵活QinQ示例

配置基于MQC的灵活QinQ示例

组网需求

图6-9所示,某数据中心网络中,服务器存储的信息包括视频和数据,数据服务器的MAC地址为0003-0003-0003,视频服务器的MAC地址为0004-0004-0004。某学校拥有教师办公业务和多媒体业务,并且通过企业骨干网访问服务器,企业骨干网分配给教师办公业务的VLAN为VLAN2,分配给多媒体用户的VLAN为VLAN3,SwitchB和SwitchC是企业骨干网边缘设备。

现需要实现:

  • 视频服务器和数据服务器独立划分VLAN,两者互不影响。

  • 流量在企业骨干网中透明传输,教师办公业务只能访问数据服务器,多媒体业务只能访问视频服务器,并且可以实现区分不同业务的目的。

可以通过配置基于MQC的灵活QinQ来实现上述需求。

图6-9 配置基于MQC的灵活QinQ组网图

配置思路

采用如下的思路配置基于MQC的灵活QinQ:

  1. 在SwitchB上创建相关VLAN,实现不同业务添加不同的外层VLAN Tag。

  2. 在SwitchB上配置流分类、流行为和流策略。

  3. 在SwitchB的接口上应用流策略来实现灵活QinQ功能。

操作步骤

  1. 创建VLAN

    # 在SwitchA上创建VLAN200、VLAN300,并将连接服务器的接口分别加入VLAN。SwitchD的配置与SwitchA类似,不再赘述。

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] vlan batch 200 300
    [*SwitchA] interface 10ge 1/0/2
    [*SwitchA-10GE1/0/2] port default vlan 200
    [*SwitchA-10GE1/0/2] quit
    [*SwitchA] interface 10ge 1/0/3
    [*SwitchA-10GE1/0/3] port default vlan 300
    [*SwitchA-10GE1/0/3] quit
    [*SwitchA] commit
    

    # 在SwitchB上创建VLAN2、VLAN3,即添加后的外层VLAN。

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchB
    [*HUAWEI] commit
    [~SwitchB] vlan batch 2 3
    [*SwitchB] commit

    # 在SwitchC上创建VLAN2、VLAN3,即允许通过的VLAN。

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchC
    [*HUAWEI] commit
    [~SwitchC] vlan batch 2 3
    [*SwitchC] commit

  2. 在SwitchB上配置流分类、流行为和流策略

    [~SwitchB] traffic classifier name1
    [*SwitchB-classifier-name1] if-match source-mac 0003-0003-0003
    [*SwitchB-classifier-name1] quit
    [*SwitchB] traffic behavior name1
    [*SwitchB-behavior-name1] vlan-stacking vlan 2
    [*SwitchB-behavior-name1] quit
    [*SwitchB] traffic classifier name2
    [*SwitchB-classifier-name2] if-match source-mac 0004-0004-0004
    [*SwitchB-classifier-name2] quit
    [*SwitchB] traffic behavior name2
    [*SwitchB-behavior-name2] vlan-stacking vlan 3
    [*SwitchB-behavior-name2] quit
    [*SwitchB] traffic policy name1
    [*SwitchB-trafficpolicy-name1] classifier name1 behavior name1
    [*SwitchB-trafficpolicy-name1] classifier name2 behavior name2
    [*SwitchB-trafficpolicy-name1] quit
    [*SwitchB] commit
    

  3. 在接口上应用流策略实现灵活QinQ功能

    # 配置SwitchB的接口10GE1/0/1。

    [~SwitchB] interface 10ge 1/0/1
    [~SwitchB-10GE1/0/1] port link-type trunk
    [*SwitchB-10GE1/0/1] port trunk allow-pass vlan 2 3
    [*SwitchB-10GE1/0/1] traffic-policy name1 inbound
    [*SwitchB-10GE1/0/1] quit
    [*SwitchB] commit

    # 配置SwitchC的接口10GE1/0/1。

    [~SwitchC] interface 10ge 1/0/1
    [~SwitchC-10GE1/0/1] port link-type hybrid
    [*SwitchC-10GE1/0/1] port hybrid untagged vlan 2 3
    [*SwitchC-10GE1/0/1] quit
    [*SwitchC] commit

  4. 配置其它接口

    # 在SwitchA上配置接口10GE1/0/1加入VLAN200、VLAN300。SwitchD的配置与SwitchA类似,不再赘述。

    [~SwitchA] interface 10ge 1/0/1
    [~SwitchA-10GE1/0/1] port link-type trunk
    [*SwitchA-10GE1/0/1] port trunk allow-pass vlan 200 300
    [*SwitchA-10GE1/0/1] quit
    [*SwitchA] commit

    # 在SwitchB上配置接口10GE1/0/2加入VLAN2、VLAN3。

    [~SwitchB] interface 10ge 1/0/2
    [~SwitchB-10GE1/0/2] port link-type trunk
    [*SwitchB-10GE1/0/2] port trunk allow-pass vlan 2 3
    [*SwitchB-10GE1/0/2] quit
    [*SwitchB] commit

    # 在SwitchC上配置接口10GE1/0/2加入VLAN2、VLAN3。

    [~SwitchC] interface 10ge 1/0/2
    [~SwitchC-10GE1/0/2] port link-type hybrid
    [*SwitchC-10GE1/0/2] port hybrid untagged vlan 2 3
    [*SwitchC-10GE1/0/2] quit
    [*SwitchC] commit

  5. 验证配置结果

    • 从数据服务器ping教师办公PC,可以ping通则表示教师办公业务可以访问数据服务器。

    • 从视频服务器ping多媒体教室PC,可以ping通则表示多媒体业务可以访问视频服务器。

    以数据服务器ping教师办公PC为例:将数据服务器和教师办公PC配置在同一个网段,比如配置数据服务器的IP地址为172.16.0.1/16,配置教师办公PC的IP地址为172.16.0.7/16。终端以Window XP操作系统为例说明。

    C:\Documents and Settings\Administrator> ping 172.16.0.7
    Pinging 172.16.0.7 with 32 bytes of data:
    Reply from 172.16.0.7: bytes=32 time<1ms TTL=128
    Reply from 172.16.0.7: bytes=32 time<1ms TTL=128
    Reply from 172.16.0.7: bytes=32 time<1ms TTL=128
    Reply from 172.16.0.7: bytes=32 time<1ms TTL=128
    
    Ping statistics for 172.16.0.7:
        Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
    Approximate round trip times in milli-seconds:
        Minimum = 0ms, Maximum = 0ms, Average = 0ms

配置文件

  • SwitchA的配置文件

    #
    sysname SwitchA
    #
    vlan batch 200 300
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 200 300
    #
    interface 10GE1/0/2
     port default vlan 200
    #
    interface 10GE1/0/3
     port default vlan 300
    #
    return
  • SwitchB的配置文件

    #
    sysname SwitchB
    #
    vlan batch 2 to 3
    #
    traffic classifier name1 type or
     if-match source-mac 0003-0003-0003 ffff-ffff-ffff
    #
    traffic classifier name2 type or
     if-match source-mac 0004-0004-0004 ffff-ffff-ffff
    #
    traffic behavior name1
     vlan-stacking vlan 2
    #
    traffic behavior name2
     vlan-stacking vlan 3
    #
    traffic policy name1
     classifier name1 behavior name1 precedence 5
     classifier name2 behavior name2 precedence 10
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 2 to 3
     traffic-policy name1 inbound
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 2 to 3
    #
    return
  • SwitchC的配置文件

    #
    sysname SwitchC
    #
    vlan batch 2 to 3
    #
    interface 10GE1/0/1
     port link-type hybrid
     port hybrid untagged vlan 2 to 3
    #
    interface 10GE1/0/2
     port link-type hybrid
     port hybrid untagged vlan 2 to 3
    #
    return
  • SwitchD的配置文件

    #
    sysname SwitchD
    #
    vlan batch 200 300
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 200 300
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 200
    #
    interface 10GE1/0/3
     port link-type trunk
     port trunk allow-pass vlan 300
    #
    return
翻译
下载文档
更新时间:2019-04-19

文档编号:EDOC1100039617

浏览量:32242

下载量:261

平均得分:
本文档适用于这些产品

相关版本

相关文档

Share
上一页 下一页