所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

CloudEngine 8800, 7800, 6800, 5800 V200R005C00 配置指南-以太网交换

本文档针对设备的以太网业务,主要包括以太网交换概述、MAC配置、以太网链路聚合配置、M-LAG(跨设备链路聚合)配置、VLAN配置、QinQ配置、VLAN mapping配置、GVRP配置、STP/RSTP配置、MSTP配置、VBST配置、ERPS(G.8032)配置、Loopback Detection配置和二层协议透明传输配置。

评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置基于VLAN的VLAN Mapping示例(2 to 2)

配置基于VLAN的VLAN Mapping示例(2 to 2)

组网需求

图7-8所示,某数据中心的两个分支布局在不同的地理位置,分支1和分支2位于相同的网段。为了可以规划自己的私网VLAN ID,采用了QinQ方式传输,即Switch2发往ISP网络的报文带有两层Tag。但是由于这两层VLAN ID与ISP网络提供的VLAN Tag不一致,分支报文无法通过ISP网络,从而导致分支无法正常通信,现需要实现分支1和分支2互通。

图7-8 配置VLAN Mapping示例(2 to 2)组网图

配置思路

采用如下的思路配置2 to 2的VLAN Mapping:

  1. 将连接分支1的Swith1的下行接口划分到VLAN10,将连接分支2的Swith6的下行接口划分到VLAN30。

  2. 在Switch2和Switch5上配置QinQ,使发往ISP网络的报文带有两层Tag。

  3. 在ISP网络的边缘设备Switch3、Switch4上部署2 to 2的VLAN Mapping功能,将报文的内、外层VLAN ID映射为ISP允许通过的VLAN ID,实现分支的业务互通。

操作步骤

  1. 将Switch1、Switch6的下行口划分到指定VLAN,上行口允许VLAN通过

    # 配置Switch1。

    <HUAWEI> system-view
    [~HUAWEI] sysname Switch1
    [*HUAWEI] commit
    [~Switch1] vlan 10
    [*Switch1-vlan10] quit
    [*Switch1] interface 10ge 1/0/1
    [*Switch1-10GE1/0/1] port default vlan 10
    [*Switch1-10GE1/0/1] quit
    [*Switch1] interface 10ge 1/0/2
    [*Switch1-10GE1/0/2] port link-type trunk
    [*Switch1-10GE1/0/2] port trunk allow-pass vlan 10
    [*Switch1-10GE1/0/2] quit
    [*Switch1] commit

    # 配置Switch6。

    <HUAWEI> system-view
    [~HUAWEI] sysname Switch6
    [*HUAWEI] commit
    [~Switch6] vlan 30
    [*Switch6-vlan30] quit
    [*Switch6] interface 10ge 1/0/1
    [*Switch6-10GE1/0/1] port default vlan 30
    [*Switch6-10GE1/0/1] quit
    [*Switch6] interface 10ge 1/0/2
    [*Switch6-10GE1/0/2] port link-type trunk
    [*Switch6-10GE1/0/2] port trunk allow-pass vlan 30
    [*Switch6-10GE1/0/2] quit
    [*Switch6] commit

  2. 在Switch2和Switch5上配置QinQ,使发往ISP网络的报文带有两层Tag

    # 在Switch2上配置接口10GE1/0/1的类型为QinQ,10GE1/0/1的外层Tag为VLAN20。

    <HUAWEI> system-view
    [~HUAWEI] sysname Switch2
    [*HUAWEI] commit
    [~Switch2] vlan 20
    [*Switch2-vlan20] quit
    [*Switch2] interface 10ge 1/0/1
    [*Switch2-10GE1/0/1] port link-type dot1q-tunnel
    [*Switch2-10GE1/0/1] port default vlan 20
    [*Switch2-10GE1/0/1] quit
    [*Switch2] interface 10ge 1/0/2
    [*Switch2-10GE1/0/2] port link-type trunk
    [*Switch2-10GE1/0/2] port trunk allow-pass vlan 20
    [*Switch2-10GE1/0/2] quit
    [*Switch2] commit
    

    # 在Switch5上配置接口10GE1/0/1的类型为QinQ,10GE1/0/1的外层Tag为VLAN40。

    <HUAWEI> system-view
    [~HUAWEI] sysname Switch5
    [*HUAWEI] commit
    [~Switch5] vlan 40
    [*Switch5-vlan40] quit
    [*Switch5] interface 10ge 1/0/1
    [*Switch5-10GE1/0/1] port link-type dot1q-tunnel
    [*Switch5-10GE1/0/1] port default vlan 40
    [*Switch5-10GE1/0/1] quit
    [*Switch5] interface 10ge 1/0/2
    [*Switch5-10GE1/0/2] port link-type trunk
    [*Switch5-10GE1/0/2] port trunk allow-pass vlan 40
    [*Switch5-10GE1/0/2] quit
    [*Switch5] commit
    

  3. 在Switch3和Switch4上配置VLAN Mapping

    # 配置Switch3。

    <HUAWEI> system-view
    [~HUAWEI] sysname Switch3
    [*HUAWEI] commit
    [~Switch3] vlan batch 50
    [*Switch3] interface 10ge 1/0/1
    [*Switch3-10GE1/0/1] port link-type trunk
    [*Switch3-10GE1/0/1] port trunk allow-pass vlan 50
    [*Switch3-10GE1/0/1] port vlan-mapping vlan 20 inner-vlan 10 map-vlan 50 map-inner-vlan 60
    [*Switch3-10GE1/0/1] quit
    [*Switch3] interface 10ge 1/0/2
    [*Switch3-10GE1/0/2] port link-type trunk
    [*Switch3-10GE1/0/2] port trunk allow-pass vlan 50
    [*Switch3-10GE1/0/2] quit
    [*Switch3] commit
    

    # 配置Switch4。

    <HUAWEI> system-view
    [~HUAWEI] sysname Switch4
    [*HUAWEI] commit
    [~Switch4] vlan batch 50
    [*Switch4] interface 10ge 1/0/1
    [*Switch4-10GE1/0/1] port link-type trunk
    [*Switch4-10GE1/0/1] port trunk allow-pass vlan 50
    [*Switch4-10GE1/0/1] port vlan-mapping vlan 40 inner-vlan 30 map-vlan 50 map-inner-vlan 60
    [*Switch4-10GE1/0/1] quit
    [*Switch4] interface 10ge 1/0/2
    [*Switch4-10GE1/0/2] port link-type trunk
    [*Switch4-10GE1/0/2] port trunk allow-pass vlan 50
    [*Switch4-10GE1/0/2] quit
    [*Switch4] commit
    

  4. 验证配置结果

    将分支1的Server1和分支2的Server2配置在同一个网段,比如配置分支1的Server1的IP地址为172.16.0.5/16,配置分支2的Server2的IP地址为172.16.0.6/16,分支1和分支2可以互通。以分支1的Server1 ping分支2的Server2的显示为例。
    <Server1> ping 172.16.0.6
    Pinging 172.16.0.6 with 32 bytes of data:
    Reply from 172.16.0.6: bytes=32 time<1ms TTL=128
    Reply from 172.16.0.6: bytes=32 time<1ms TTL=128
    Reply from 172.16.0.6: bytes=32 time<1ms TTL=128
    Reply from 172.16.0.6: bytes=32 time<1ms TTL=128
    
    Ping statistics for 172.16.0.6:
        Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
    Approximate round trip times in milli-seconds:
        Minimum = 0ms, Maximum = 0ms, Average = 0ms

配置文件

  • Switch1的配置文件

    #
    sysname Switch1
    #
    vlan batch 10
    #
    interface 10GE1/0/1
     port default vlan 10
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    return
  • Switch2的配置文件

    #
    sysname Switch2
    #
    vlan batch 20
    #
    interface 10GE1/0/1
     port link-type dot1q-tunnel
     port default vlan 20
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    return
  • Switch3的配置文件

    #
    sysname Switch3
    #
    vlan batch 50
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 50
     port vlan-mapping vlan 20 inner-vlan 10 map-vlan 50 map-inner-vlan 60
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 50
    #
    return
  • Switch4的配置文件

    #
    sysname Switch4
    #
    vlan batch 50
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 50
     port vlan-mapping vlan 40 inner-vlan 30 map-vlan 50 map-inner-vlan 60
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 50
    #
    return
  • Switch5的配置文件

    #
    sysname Switch5
    #
    vlan batch 40
    #
    interface 10GE1/0/1
     port link-type dot1q-tunnel
     port default vlan 40
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 40
    #
    return
  • Switch6的配置文件

    #
    sysname Switch6
    #
    vlan batch 30
    #
    interface 10GE1/0/1
     port default vlan 30
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    return
翻译
下载文档
更新时间:2019-04-19

文档编号:EDOC1100039617

浏览量:32451

下载量:261

平均得分:
本文档适用于这些产品

相关版本

相关文档

Share
上一页 下一页