所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

CloudEngine 8800, 7800, 6800, 5800 V200R005C00 配置指南-以太网交换

本文档针对设备的以太网业务,主要包括以太网交换概述、MAC配置、以太网链路聚合配置、M-LAG(跨设备链路聚合)配置、VLAN配置、QinQ配置、VLAN mapping配置、GVRP配置、STP/RSTP配置、MSTP配置、VBST配置、ERPS(G.8032)配置、Loopback Detection配置和二层协议透明传输配置。

评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置基于VLAN的VLAN Mapping示例(2 to 1)

配置基于VLAN的VLAN Mapping示例(2 to 1)

组网需求

图7-7所示,某数据中心网络中,老分支拥有办公业务服务器和生产业务服务器,所属的VLAN分别为VLAN2和VLAN3,服务器通过接入层交换机、汇聚层交换机接入核心层网络。网络管理者规划了新的分支,办公业务服务器和生产业务服务器所属的VLAN分别为VLAN2和VLAN3,并且新分支和老分支的相同业务位于相同的网段,为了实现相同业务服务器可以互访,不同业务服务器之间相互隔离以及节约VLAN资源,可以在汇聚层交换机上部署QinQ功能,同时为了不改变核心层交换机VLAN的部署,在核心层交换机上部署VLAN Mapping来实现上述功能。

图7-7 配置VLAN Mapping示例(2 to 1)组网图

配置思路

采用如下的思路配置2 to 1的VLAN Mapping:

  1. 将连接服务器的接入层交换机Switch1和Swicth2的接口分别划分到指定VLAN中。

  2. 在汇聚层交换机Switch3和Switch4上部署QinQ功能,以节省VLAN资源。

  3. 在核心层交换机Swicth5上部署2 to 1的VLAN Mapping功能,实现新老分支相同业务可以互通、不同业务相互隔离。

操作步骤

  1. 将Switch1、Switch2的下行口划分到指定VLAN,上行口允许VLAN通过

    # 配置Switch1。

    <HUAWEI> system-view
    [~HUAWEI] sysname Switch1
    [*HUAWEI] commit
    [~Switch1] vlan batch 2 3
    [*Switch1] interface 10ge 1/0/1
    [*Switch1-10GE1/0/1] port default vlan 2
    [*Switch1-10GE1/0/1] quit
    [*Switch1] interface 10ge 1/0/2
    [*Switch1-10GE1/0/2] port default vlan 3
    [*Switch1-10GE1/0/2] quit
    [*Switch1] interface 10ge 1/0/3
    [*Switch1-10GE1/0/3] port link-type trunk
    [*Switch1-10GE1/0/3] port trunk allow-pass vlan 2 3
    [*Switch1-10GE1/0/3] quit
    [*Switch1] commit

    # 配置Switch2。

    <HUAWEI> system-view
    [~HUAWEI] sysname Switch2
    [*HUAWEI] commit
    [~Switch2] vlan batch 2 3
    [*Switch2] interface 10ge 1/0/1
    [*Switch2-10GE1/0/1] port default vlan 2
    [*Switch2-10GE1/0/1] quit
    [*Switch2] interface 10ge 1/0/2
    [*Switch2-10GE1/0/2] port default vlan 3
    [*Switch2-10GE1/0/2] quit
    [*Switch2] interface 10ge 1/0/3
    [*Switch2-10GE1/0/3] port link-type trunk
    [*Switch2-10GE1/0/3] port trunk allow-pass vlan 2 3
    [*Switch2-10GE1/0/3] quit
    [*Switch2] commit

  2. 在Switch3、Swicth4上部署QinQ功能

    # 在Switch3上配置接口10GE1/0/1的类型为QinQ,10GE1/0/1的外层Tag为VLAN201。

    <HUAWEI> system-view
    [~HUAWEI] sysname Switch3
    [*HUAWEI] commit
    [~Switch3] vlan batch 201
    [*Switch3] interface 10ge 1/0/1
    [*Switch3-10GE1/0/1] port link-type dot1q-tunnel
    [*Switch3-10GE1/0/1] port default vlan 201
    [*Switch3-10GE1/0/1] quit
    [*Switch3] interface 10ge 1/0/2
    [*Switch3-10GE1/0/2] port link-type trunk
    [*Switch3-10GE1/0/2] port trunk allow-pass vlan 201
    [*Switch3-10GE1/0/2] quit
    [*Switch3] commit
    

    # 在Switch4上配置接口10GE1/0/1的类型为QinQ,10GE1/0/1的外层Tag为VLAN201。

    <HUAWEI> system-view
    [~HUAWEI] sysname Switch4
    [*HUAWEI] commit
    [~Switch4] vlan batch 201
    [*Switch4] interface 10ge 1/0/1
    [*Switch4-10GE1/0/1] port link-type dot1q-tunnel
    [*Switch4-10GE1/0/1] port default vlan 201
    [*Switch4-10GE1/0/1] quit
    [*Switch4] interface 10ge 1/0/2
    [*Switch4-10GE1/0/2] port link-type trunk
    [*Switch4-10GE1/0/2] port trunk allow-pass vlan 201
    [*Switch4-10GE1/0/2] quit
    [*Switch4] commit
    

  3. 在Switch5上配置VLAN Mapping

    <HUAWEI> system-view
    [~HUAWEI] sysname Switch5
    [*HUAWEI] commit
    [~Switch5] vlan batch 501 502
    [*Switch5] interface 10ge 1/0/1
    [*Switch5-10GE1/0/1] port link-type trunk
    [*Switch5-10GE1/0/1] port trunk allow-pass vlan 501 502
    [*Switch5-10GE1/0/1] port vlan-mapping vlan 201 inner-vlan 2 map-vlan 501
    [*Switch5-10GE1/0/1] port vlan-mapping vlan 201 inner-vlan 3 map-vlan 502
    [*Switch5-10GE1/0/1] quit
    [*Switch5] interface 10ge 1/0/2
    [*Switch5-10GE1/0/2] port link-type trunk
    [*Switch5-10GE1/0/2] port trunk allow-pass vlan 501 502
    [*Switch5-10GE1/0/2] port vlan-mapping vlan 201 inner-vlan 2 map-vlan 501
    [*Switch5-10GE1/0/2] port vlan-mapping vlan 201 inner-vlan 3 map-vlan 502
    [*Switch5-10GE1/0/2] quit
    [*Switch5] interface 10ge 1/0/3
    [*Switch5-10GE1/0/3] port link-type trunk
    [*Switch5-10GE1/0/3] port trunk allow-pass vlan 501 502
    [*Switch5-10GE1/0/3] quit
    [*Switch5] commit
    

  4. 验证配置结果

    • 将新分支办公业务服务器Server1和老分支办公业务服务器Server2配置在同一个网段,比如配置新分支办公业务服务器Server1的IP地址为172.16.0.1/24,配置老分支办公业务服务器Server2的IP地址为172.16.0.2/24。
    • 将新分支生产业务服务器Server3和老分支生产业务服务器Server4配置在同一个网段,比如配置新分支生产业务服务器Server3的IP地址为172.16.1.1/24,配置老分支生产业务服务器Server4的IP地址为172.16.1.2/24。

    新分支和老分支之间相同业务服务器可以互访,不同业务服务器之间相互隔离。

    以新分支办公业务服务器Server1 ping老分支办公业务服务器为例。
    <Server1> ping 172.16.0.2
    Pinging 172.16.0.2 with 32 bytes of data:
    Reply from 172.16.0.2: bytes=32 time<1ms TTL=128
    Reply from 172.16.0.2: bytes=32 time<1ms TTL=128
    Reply from 172.16.0.2: bytes=32 time<1ms TTL=128
    Reply from 172.16.0.2: bytes=32 time<1ms TTL=128
    
    Ping statistics for 172.16.0.2:
        Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
    Approximate round trip times in milli-seconds:
        Minimum = 0ms, Maximum = 0ms, Average = 0ms
    以新分支办公业务服务器Server1 ping老分支生产业务服务器Server4为例。
    <Server1> ping 172.16.1.2
    Pinging 172.16.1.2 with 32 bytes of data:
    Request timed out.
    Request timed out.
    Request timed out.
    Request timed out.
    
    Ping statistics for 172.16.1.2:
        Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),

配置文件

  • Switch1的配置文件

    #
    sysname Switch1
    #
    vlan batch 2 to 3
    #
    interface 10GE1/0/1
     port default vlan 2
    #
    interface 10GE1/0/2
     port default vlan 3
    #
    interface 10GE1/0/3
     port link-type trunk
     port trunk allow-pass vlan 2 to 3
    #
    return
  • Switch2的配置文件

    #
    sysname Switch2
    #
    vlan batch 2 to 3
    #
    interface 10GE1/0/1
     port default vlan 2
    #
    interface 10GE1/0/2
     port default vlan 3
    #
    interface 10GE1/0/3
     port link-type trunk
     port trunk allow-pass vlan 2 to 3
    #
    return
  • Switch3的配置文件

    #
    sysname Switch3
    #
    vlan batch 201
    #
    interface 10GE1/0/1
     port link-type dot1q-tunnel
     port default vlan 201
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 201
    #
    return
  • Switch4的配置文件

    #
    sysname Switch4
    #
    vlan batch 201
    #
    interface 10GE1/0/1
     port link-type dot1q-tunnel
     port default vlan 201
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 201
    #
    return
  • Switch5的配置文件

    #
    sysname Switch5
    #
    vlan batch 501 to 502
    #
    interface 10GE1/0/1
     port link-type trunk 
     port trunk allow-pass vlan 501 to 502
     port vlan-mapping vlan 201 inner-vlan 2 map-vlan 501
     port vlan-mapping vlan 201 inner-vlan 3 map-vlan 502
    #
    interface 10GE1/0/2
     port link-type trunk 
     port trunk allow-pass vlan 501 to 502
     port vlan-mapping vlan 201 inner-vlan 2 map-vlan 501
     port vlan-mapping vlan 201 inner-vlan 3 map-vlan 502
    #
    interface 10GE1/0/3
     port link-type trunk 
     port trunk allow-pass vlan 501 to 502
    #
    return
翻译
下载文档
更新时间:2019-04-19

文档编号:EDOC1100039617

浏览量:31395

下载量:261

平均得分:
本文档适用于这些产品

相关版本

相关文档

Share
上一页 下一页