Combined API故障
现象描述
组合API、镜像转换合并部署在CPT-SRV01和CPT-SRV02节点上。组合API服务不可用时则可能是组合API服务所在虚拟机出现故障或组合API服务进程异常。组合API、虚拟私有云、任务中心、计量话单、API网关和云配置服务共同使用一套GaussdbHA作为后端数据库,该GaussdbHA部署在PUB-DB01和PUB-DB02节点上。数据库服务不可用时则可能是数据库所在虚拟机出现故障或数据库服务进程异常。
可能原因
- 服务所在虚拟机文件系统被破坏。
- 组合API进程异常。
处理步骤
- 判断组合API服务所在的虚拟机CPT-SRV01或CPT-SRV02是否正常登录?
- 请参考云服务管理面故障诊断修复虚拟机。
- 请联系技术支持工程师协助解决,重装组合API服务,任务结束。
- 使用“PuTTY”工具,登录组合API业务节点CPT-SRV01或CPT-SRV02。
- 登录地址:节点管理IP地址
- 帐号:apicom
- 默认密码:Huawei12#$
- 执行以下命令,防止“PuTTY”超时退出。
TMOUT=0
- 执行以下命令,查看tomcat进程是否存在。
ps -ef | grep tomcat
- 执行以下命令,停止tomcat进程。
kill -9 $pid
- 执行以下命令,重新启动进程。
sh /opt/apicom/tomcat/bin/startup.sh
- 重启后是否恢复?
- 是,任务结束。
- 否,请联系技术支持工程师协助解决。
- 如果涉及多个虚拟机故障,请依次参考步骤 1~步骤 9处理。