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FusionCloud 6.3.1 故障处理 06

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常用故障

常用故障

处理日常故障

日常维护中,出现数据库复制状态异常、文件权限异常、第三方上报告警失败、登录失败等业务故障时,管理员可以在系统维护的维护工具箱,选择“故障处理”工具,根据故障名称搜索故障案例,处理故障。

前提条件
  • 管理员具有系统维护管理权限。
  • 已登录ManageOne运维面。
操作步骤
  1. 在主菜单中选择系统管理 > 平台配置 > 系统维护
  2. 在左侧导航树中选择“维护工具箱”
  3. 进入“常用工具”页面,单击“故障处理”
  4. 在右侧搜索框可以根据故障“案例名称”搜索具体的故障案例。
  5. 在故障案例列表中,选择搜索到的故障案例,单击“操作”列中对应的“执行”
  6. 如果该故障案例需要配置基本参数,进入参数列表页面,根据界面提示配置基本参数。

    不同的故障案例参数不同,下图中只是一种举例。单击“立即执行”

  7. 提示执行该案例产生的影响,确认是否继续执行该案例,单击“确定”,处理故障。

    执行过程中,页面下方会显示当前故障案例执行过程的日志信息。等待执行完成,提示如下信息时,说明执行成功。

    说明:

    不同的故障案例,产生的影响会不同,提示信息会有差异。

  8. 单击“是”,下载执行结果包。

    保存至本地,可查看执行结果包。结果包中包含收集的日志文件、配置文件等信息。

  9. 如果需要删除该故障案例,单击“操作”列中对应的“删除”。
  10. 如果需要查看该故障案例执行的详细信息以及历史记录,单击“操作”列中对应的“查看详情”

    说明:

    每个案例最多保存100条历史记录,超期历史任务将被自动删除。

    • 详细信息包含案例名称、描述以及操作影响。
    • 历史执行记录包含执行开始时间、执行结束时间、执行状态等。
      • 单击“下载结果包”,可下载故障案例执行的结果包。
      • 单击“查看日志详情”,可查看故障案例执行的日志详情。

后续操作

当管理员有新增的故障案例时,可以联系技术支持制作故障案例文件和签名文件,按照如下方法导入案例至系统中。

  1. 在主菜单中选择系统管理 > 平台配置 > 系统维护
  2. 在左侧导航树中选择“维护工具箱”
  3. 进入“常用工具”页面,单击“故障处理”
  4. 在故障处理页面,单击“导入案例”
  5. 分别单击“浏览”,选择要上传的故障案例文件和签名文件,单击“确定”
  6. 在故障案例列表,查看新导入的案例。

当管理员无法登录ManageOne运维面时,可执行以下操作处理故障。

  1. 登录MOMaintenanceService部署节点。

    1. 使用PuTTY,以sopuser帐户登录MOMaintenanceService部署节点。

      默认帐户:sopuser,默认密码:D4I$awOD7k

    2. 执行如下命令,切换至ossadm帐户。

      su - ossadm

      默认密码:ZJE%JLq5qx

  2. 执行如下命令,切换目录。

    cd /opt/oss/Product/apps/MOMaintenanceService/bin/

  3. 输入如下命令,执行故障案例脚本。

    sh shootCase.sh

    显示所有案例信息,第一列为案例ID,第二列为案例名称。案例信息如下:

    Case List:
    ----------------------------------------------------------+----------------------------------------------
    Case Id                                                     |  Case Name
    ----------------------------------------------------------+----------------------------------------------
    MO_OC_Login_Failed                                          | 运维侧登录失败检查
    ----------------------------------------------------------+----------------------------------------------
    ManageOne_SC_Detect                                         | 【运营侧】登录失败检查
    ----------------------------------------------------------+----------------------------------------------
    manageOne_third_party_user_check                           |  三方系统接入用户校验
    ----------------------------------------------------------+----------------------------------------------
    manageOne_troubleshoot_db                                  |  数据库备实例复制状态异常 
    ----------------------------------------------------------+----------------------------------------------
    manageone_scan_file_auth                                   |  服务文件权限检查
    ----------------------------------------------------------+----------------------------------------------

  4. 选择要执行的案例,输入对应案例ID并按“Enter”

    例如:要执行“三方系统接入用户校验”这个案例,需要输入manageOne_third_party_user_check
    Please enter the case ID: manageOne_third_party_user_check
    • 如果案例有参数,显示相关参数。
    • 如果案例无参数,案例直接执行。

  5. 输入案例参数。

    以执行“三方系统接入用户校验”这个案例为例,需要输入参数信息如下。

    Please enter a value for parameter userName:123
    Please enter a value for parameter ThirdPartyPasswd:

    输入对应参数值并按“Enter”,案例开始执行。

    start to execute case:
    [INFO]获取agent信息失败。
    The operation log for the case is saved in the /var/log/oss/manager/MOICAgent/operator_case.log
    说明:

    “The operation log for the case is saved in the /var/log/oss/manager/MOICAgent/operator_case.log”说明案例执行的操作日志存放目录在“/var/log/oss/manager/MOICAgent/operator_case.log”。

登录ManageOne时界面提示无法访问

现象描述

登录ManageOne时无法访问页面。

可能原因

ManageOne业务服务在运行时所需要的工作目录丢失导致后台服务启动失败。

处理步骤
  1. 使用PuTTY,以sopuser用户登录regionAlias-ManageOne-Deploy01节点。

    默认密码:D4I$awOD7k。

  2. 执行以下命令,切换到ossadm用户。

    su - ossadm

    ossadm用户的默认密码“ZJE%JLq5qx”。

  3. 执行如下命令,恢复服务所需的工作目录。

    . /opt/oss/manager/bin/engr_profile.sh

    cd /opt/oss/manager/agent/rtsp/mccommon/tools/shscript

    sh ossrunpy.sh TroubleRecoveryMgmt recreateDirectories

    回显“End to create tmp dir for Services.”时表示任务执行完毕,查看回显中有无“failed”项。

    • 如果没有,表示执行成功。
    • 如果有,请联系技术支持工程师协助解决。

  4. 执行如下命令,启动服务。

    ipmc_adm -cmd startbus

    ipmc_adm -cmd startapp

    执行完成后查看回显中有无“failed”项。

    • 如果没有,表示执行成功。
    • 如果有,请联系技术支持工程师协助解决。

  5. 重复执行步骤步骤 1~步骤 4,依次登录ManageOne剩余的其他节点,完成故障恢复操作。
  6. 重新登录ManageOne界面,检查是否登录成功。

    • 是,表示执行成功。
    • 否,请联系技术支持工程师协助解决。

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更新时间:2019-08-19

文档编号:EDOC1100043088

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