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FusionCloud 6.3.1 故障处理 06

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服务节点故障

服务节点故障

数据库安全服务界面显示空白

现象描述

通过ManageOne运营面,访问数据库安全服务界面显示空白。

可能的原因

SCC-Console的Tomcat进程异常。

处理步骤
  1. 使用PuTTY,以“SCC-Service01”字段对应的IP地址登录SCC-Service-FusionGuard01管理虚拟机。

    默认帐号:sccadmin,默认密码:Scloud12#$

  2. 执行以下命令,并按提示输入root帐户的密码Cloud12#$,切换到root帐户。

    sudo su - root

  3. 执行以下命令,防止系统超时退出。

    TMOUT=0

  4. 执行以下命令,检查Tomcat服务是否正在运行。

    ps -ef | grep tomcat | grep -v grep

    • 是,请联系技术支持工程师协助解决。
    • 否,执行步骤 5

  5. 执行以下命令,重新启动Tomcat进程。

    systemctl start systemd-tomcat

  6. 使用浏览器,以VDC管理员或VDC业务员帐号登录ManageOne运营面。

    登录地址:https://控制台主页的访问地址。例如,https://console.type.com。

  7. 在导航栏左上角下拉框选择地域和Project。
  8. 查看DBSS服务是否可正常访问。

    • 是,任务结束。
    • 否,请联系技术支持工程师协助解决。

数据库安全服务界面提示“后台服务维护中,请稍后再试”

现象描述

通过ManageOne运营面,访问数据库安全服务界面提示“后台服务维护中,请稍后再试”。

可能的原因
  • SCC-LB的Nginx进程异常。
  • SCC-Service的Tomcat进程异常。
处理步骤
  1. 登录SCC-LB节点,查看Nginx进程是否异常。

    1. 使用PuTTY,以“SCC-LB01”字段对应的IP地址登录SCC-LB-FusionGuard01管理虚拟机。

      默认帐号:sccadmin,默认密码:Scloud12#$

    2. 执行以下命令,并按提示输入root帐户的密码Cloud12#$,切换到root帐户。

      sudo su - root

    3. 执行以下命令,防止系统超时退出。

      TMOUT=0

    4. 执行以下命令,检查Nginx服务是否正在运行。

      ps -ef | grep nginx | grep -v grep

    5. 执行以下命令,重新启动Nginx服务。

      service nginxd start

    6. 使用浏览器,以VDC管理员或VDC业务员帐号登录ManageOne运营面。

      登录地址:https://控制台主页的访问地址。例如,https://console.type.com。

    7. 在导航栏左上角下拉框选择地域和Project。
    8. 查看DBSS服务是否可正常访问。
      • 是,任务结束。
      • 否,执行步骤 2

  2. 登录SCC-Service节点,查看Tomcat进程是否异常。

    1. 使用PuTTY,以“SCC-Service01”字段对应的IP地址登录SCC-Service-FusionGuard01管理虚拟机。

      默认帐号:sccadmin,默认密码:Scloud12#$

    2. 执行以下命令,并按提示输入root帐户的密码Cloud12#$,切换到root帐户。

      sudo su - root

    3. 执行以下命令,防止系统超时退出。

      TMOUT=0

    4. 执行以下命令,检查Tomcat服务是否正在运行。

      ps -ef | grep tomcat | grep -v grep

      • 是,执行2.e
      • 否,执行以下命令,重新启动Tomcat服务,重新执行2.d,如果仍有问题请联系技术支持工程师协助解决。

        systemctl start systemd-tomcat

    5. 执行以下命令,查看DBSS服务的配置是否正常。

      vim /opt/tomcat/conf/server.xml

      • 是,执行2.f
      • 否,配置DBSS服务,并执行以下命令重启Tomcat服务,重新执行2.e,如果仍有问题请联系技术支持工程师协助解决。
        systemctl restart systemd-tomcat
        说明:

        DBSS服务的Tomcat配置:

        <Context path="/dbss" docBase="/opt/onframework/scc/scc_services_dbss/" reloadable="false"/>

    6. 执行以下命令,检查DBSS服务所部署的目录是否存在。

      cd /opt/onframework/scc/scc_services_dbss

    7. 执行以下命令,检查是否有文件存在权限异常。

      ll -R /opt/onframework/scc/scc_services_dbss/ | grep -v "tomcat cloudgrp"

      • 是,存在文件权限异常,依次执行以下命令,重启Tomcat服务,重新执行2.g,如果仍有问题请联系技术支持工程师协助解决。
        • chown tomcat:cloudgrp -R /opt/onframework/scc/scc_services_dbss/
        • systemctl restart systemd-tomcat
      • 否,文件权限正常,执行2.h
    8. 执行以下命令,检查DBSS服务是否正常运行。

      tailf /var/log/scc/dbss/dbss-service.log

      • 是,执行2.i
      • 否,执行以下命令重启Tomcat服务,重新执行2.h,如果仍有问题请联系技术支持工程师协助解决。

        systemctl restart systemd-tomcat

    9. 使用浏览器,以VDC管理员或VDC业务员帐号登录ManageOne运营面。

      登录地址:https://控制台主页的访问地址。例如,https://console.type.com。

    10. 在导航栏左上角下拉框选择地域和Project。
    11. 查看DBSS服务是否可正常访问。
      • 是,任务结束。
      • 否,请联系技术支持工程师协助解决。

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更新时间:2019-08-19

文档编号:EDOC1100043088

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