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FusionCloud 6.3.1 故障处理 06

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服务节点故障

服务节点故障

程序运行认证服务界面显示空白

现象描述

登录ManageOne运营面,访问程序运行认证服务的Console界面显示空白。

可能原因

SCC-Console节点的Tomcat异常。

处理步骤
  1. 使用PuTTY,以“SCC-Console01”字段对应的IP地址登录FusionGuard-Console-FusionGuard01管理虚拟机。

    默认帐号:sccadmin,默认密码:Scloud12#$

  2. 执行以下命令,并按提示输入root帐户的密码Cloud12#$,切换到root帐户。

    sudo su - root

  3. 执行以下命令,防止系统超时退出。

    TMOUT=0

  4. 执行以下命令,查看Tomcat运行状态。

    ps -ef | grep tomcat

    Tomcat运行正常时,结果显示如图18-1所示。

    图18-1 Tomcat正常运行状态

  5. 重复执行步骤 4,查看Tomcat进程是否有变化。

    • 如果Tomcat进程已停止,则执行以下命令,重启Tomcat进程和sysmonitor服务,执行步骤 6
      • systemctl start systemd-tomcat
      • systemctl restart sysmonitor
    • 如果Tomcat进程不停被重启,则执行以下命令,查看Tomcat日志并联系技术支持工程师协助解决。

      tail -300f /opt/tomcat/logs/catalina.out

  6. 使用浏览器,以VDC管理员或VDC业务员帐号登录ManageOne运营面。

    登录地址:https://控制台主页的访问地址。例如,https://console.type.com。

  7. 在导航栏左上角下拉框选择地域和Project。
  8. 查看ARS服务是否可正常访问。

    • 是,任务结束。
    • 否,请联系技术支持工程师协助解决。

程序运行认证服务界面提示“后台服务维护中,请稍后再试”

现象描述

登录ManageOne运营面,访问程序运行认证服务的Console界面提示“后台服务维护中,请稍后再试”。

可能原因
  • SCC-LB节点的Nginx异常停止。
  • SCC-Service节点的Tomcat异常停止。
  • SCC-DB节点GaussDB进程异常。
处理步骤
  1. 登录SCC-LB节点,查看Nginx进程是否异常。

    1. 使用PuTTY,以“SCC-LB01”字段对应的IP地址登录SCC-LB-FusionGuard01管理虚拟机。

      默认帐号:sccadmin,默认密码:Scloud12#$

    2. 执行以下命令,并按提示输入root帐户的密码Cloud12#$,切换到root帐户。

      sudo su - root

    3. 执行以下命令,防止系统超时退出。

      TMOUT=0

    4. 执行以下命令,查看Nginx运行状态是否正常。

      ps -ef | grep nginx

      正常结果显示如下所示。

    1. 执行以下命令,重启Nginx。

      service nginxd start

    2. 使用浏览器,以VDC管理员或VDC业务员帐号登录ManageOne运营面。

      登录地址:https://控制台主页的访问地址。例如,https://console.type.com。

    3. 在导航栏左上角下拉框选择地域和Project。
    4. 查看ARS服务是否可正常访问。
      • 是,任务结束。
      • 否,执行步骤 2

  2. 登录SCC-Service节点,查看Tomcat进程是否异常。

    1. 使用PuTTY,以“SCC-Service01”字段对应的IP地址登录SCC-Service-FusionGuard01管理虚拟机。

      默认帐号:sccadmin,默认密码:Scloud12#$

    2. 执行以下命令,并按提示输入root帐户的密码Cloud12#$,切换到root帐户。

      sudo su - root

    3. 执行以下命令,防止系统超时退出。

      TMOUT=0

    4. 执行以下命令,查看Tomcat运行状态。

      ps -ef | grep tomcat

      正常结果显示如下所示。

    5. 执行以下命令,重启Tomcat进程。
      • systemctl start systemd-tomcat
      • systemctl restart sysmonitor
    6. 使用浏览器,以VDC管理员或VDC业务员帐号登录ManageOne运营面。

      登录地址:https://控制台主页的访问地址。例如,https://console.type.com。

    7. 在导航栏左上角下拉框选择地域和Project。
    8. 查看ARS服务是否可正常访问。
      • 是,任务结束。
      • 否,执行步骤 3

  3. 登录SCC-DB节点,查看GaussDB进程是否异常。

    1. 使用PuTTY,以“SCC-Service01”字段对应的IP地址登录SCC-Service-FusionGuard01管理虚拟机。

      默认帐号:sccadmin,默认密码:Scloud12#$

    2. 执行以下命令,并按提示输入root帐户的密码Cloud12#$,切换到root帐户。

      sudo su - root

    3. 执行以下命令,切换到dbadmin用户。

      su dbadmin

    4. 执行以下命令,防止系统超时退出。

      TMOUT=0

    5. 执行以下命令,查看Gaussdb运行状态是否正常。

      ps -ef | grep gaussdb

      • 是,执行3.f
      • 否,请联系技术支持工程师协助解决。

      Gaussdb运行正常时,结果显示如下所示。

    6. 在主节点执行以下命令,重启Gaussdb。

      gs_ctl restart -M primary

    7. 在备节点执行以下命令,重启Gaussdb。

      gs_ctl restart -M standby

    8. 使用浏览器,以VDC管理员或VDC业务员帐号登录ManageOne运营面。

      登录地址:https://控制台主页的访问地址。例如,https://console.type.com。

    9. 在导航栏左上角下拉框选择地域和Project。
    10. 查看ARS服务是否可正常访问。
      • 是,任务结束。
      • 否,请联系技术支持工程师协助解决。

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更新时间:2019-08-19

文档编号:EDOC1100043088

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