所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

FusionCloud 6.3.1 故障处理 06

评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
HAProxy故障处理

HAProxy故障处理

现象描述

通过ManageOne运维面上报的告警发现HAProxy管理节点异常,需恢复。

可能原因

  • 虚拟机故障。
  • keepalived进程异常。
  • haproxy进程异常。

定位思路

管理节点故障的处理流程如图24-3所示。

图24-3 管理节点故障处理流程

处理步骤

  1. 根据ManageOne运维面告警邮件中的“IP地址”确定发生异常的节点IP地址。
  2. 查看该异常节点是否可以通过PuTTY正常登录。

    默认帐号:ulb,默认密码:cnp200@HW。
    • 是,执行步骤3
    • 否,说明虚拟机故障,请联系技术支持工程师协助解决。

  3. 执行以下命令,并按提示输入“root”帐户的密码“Cloud12#$”,切换到root用户。

    sudo su - root

  4. 执行命令cd /etc/init.d进入进程所在目录。
  5. 执行以下命令,检查keepalived进程是否正常工作。

    service keepalived status

    说明:

    回显中包含running表明进程运行正常,不包含running表明进程运行异常。

  6. 执行以下命令,重启keepalived进程。

    service keepalived restart

  7. 执行以下命令,检查keepalived进程是否正常工作。

    service keepalived status

    • 是,执行步骤8
    • 否,请联系技术支持工程师协助解决。

  8. 执行以下命令,检查haproxy进程是否正常工作。

    service haproxy status

    • 是,请联系技术支持工程师协助解决。
    • 否,执行步骤9

  9. 执行以下命令,重启haproxy进程。

    service haproxy restart

  10. 执行以下命令,检查haproxy进程是否正常工作。

    service haproxy status

    • 是,任务结束。
    • 否,请联系技术支持工程师协助解决。

翻译
下载文档
更新时间:2019-08-19

文档编号:EDOC1100043088

浏览量:22390

下载量:453

平均得分:
本文档适用于这些产品

相关版本

相关文档

Share
上一页 下一页