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FusionCloud 6.3.1 故障处理 06

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调度集群服务(AS-Schedule)故障

调度集群服务(AS-Schedule)故障

现象描述

调度集群服务(AS-Schedule)发生故障,无法完成定时及周期性任务处理。

可能原因

  • 服务所在虚拟机文件系统被破坏。
  • 服务进程异常。

定位思路

该故障应急处理定位思路如图11-2所示。

图11-2 定位思路

处理步骤

  1. 判断AS-Schedule所在的虚拟机是否正常登录。

  2. 请参考云服务管理面故障诊断修复虚拟机。
  3. 请联系技术支持工程师协助解决。重装AS-Schedule,任务结束。
  4. 使用“PuTTY”,登录AS-SCHEDULE-SCHEDULE01或AS-SCHEDULE-SCHEDULE02。

    默认帐号:admin,默认密码:IaaS@OS-CLOUD9!

  5. 执行以下命令,防止“PuTTY”超时退出。

    TMOUT=0

  6. 执行以下命令,查看进程是否存在。

    ps -ef|grep autoscaling-schedule

  7. 执行以下命令,停止进程。

    sh /opt/autoscaling/autoscaling-schedule/bin/schedule.sh stop

  8. 执行以下命令,重启进程。

    sh /opt/autoscaling/autoscaling-schedule/bin/schedule.sh restart

  9. AS-Schedule服务是否恢复?

    • 是,任务结束。
    • 否,请联系技术支持工程师协助解决。

  10. 如果涉及多个虚拟机故障,请依次参考步骤 1~步骤 9处理。
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更新时间:2019-08-19

文档编号:EDOC1100043088

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