如何处理由于证书不存在或已过期,导致eSight无法启动的问题
现象描述
如下图所示,用户在登录eSight控制台的时候提示证书不存在或已过期。
可能原因
eSight安装目录下证书相关文件不存在,或者是证书过期,导致出现此问题。
- 如果用户使用自己的证书,证书不存在时,则重新导入证书即可解决此问题。导入证书的具体操作参见《eSight 维护指南》中的“安全维护 > 安全证书”章节。
- 如果用户使用自签名证书,证书不存在或过期时,则重新生成自签名证书后即可解决此问题。重新生成自签名的具体操作参见如下“处理步骤”。
处理步骤
- Windows
- 双击桌面上的“eSight控制台”快捷图标,或选择“开始 > 所有程序 > eSight > eSight控制台”。
弹出“eSight控制台”对话框。
- 选择“工具 > 证书工具”。
弹出“证书工具”对话框。
- 选中“生成自签名证书”,单击“下一步”。
- 推荐使用默认设置,单击“应用”。
如果选中了“自动启动网管”,eSight会在证书生成后自动启动。
- 单击“完成”。
- 双击桌面上的“eSight控制台”快捷图标,或选择“开始 > 所有程序 > eSight > eSight控制台”。
- Linux
- 对于高可用性系统,只需在主机执行如下操作即可;
- 如果您在启动过程中遇到“ eSight environment fails to be checked.”的错误信息,内容包含“The certificate file is about to expire in 90 days or has already expired.”,则需要执行第2步;
- 如果您的部署场景是OMMHA双机,启动过程中没有收到报错信息,仅在执行 status.sh 查询双机状态时看到“certificate verify failed”的错误信息,则仅需要执行第3步,生成OMMHA双机证书即可,无需执行第2步。
- 以ossuser用户登录操作系统。
- 生成自签名证书。
- 使用界面工具配置,仅适用于SUSE Linux操作系统。
- 运行配置文件,进入证书工具。
cd 安装目录/mttools/tools ./catool.sh
- 选中“生成自签名证书”,单击“下一步”。
- 推荐使用默认设置,单击“应用”。
- 单击“完成”。
- 运行配置文件,进入证书工具。
- 使用命令生成自签名证书,适用于EulerOS和SUSE Linux操作系统。
es_cli -cmd catool -type self
es_cli -cmd catool -type self命令在eSight V300R010C00SPC500及之后的版本中可以使用。
- 使用界面工具配置,仅适用于SUSE Linux操作系统。
- 重新生成OMMHA双机证书
如果部署场景是OMMHA双机(存在 /opt/ommha/ha目录),执行如下命令,切换至root用户。
su - root
Password: root用户密码
执行如下操作重新生成OMMHA双机证书:
cd /opt/ommha/config
sh create_ommha_cert.sh