所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

NE20E-S2 V800R010C10SPC500 配置指南 - IP业务 01

本文档是NE20E-S2 V800R010C10SPC500 配置指南 - IP业务
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置路由式ARP代理示例

配置路由式ARP代理示例

本举例介绍路由式ARP代理的配置过程。

组网需求

处于同一网段的两个用户,被不同的物理路由器隔离成两个不同的物理网络,现需要这两个不同物理网络中处于同一网段的用户能互通。

图2-7所示,两台路由器通过串行线路相连。两台用户计算机Host A和Host B没有配置默认网关,需要在路由器上配置路由式ARP代理,使分处在两个局域网的用户主机能互通。

图2-7 配置路由式ARP代理组网图

设备名称

接口

IP地址

DeviceA

GE0/1/0

172.16.1.1/24

GE0/2/0

172.17.3.1/24

DeviceB

GE0/1/0

172.16.2.1/24

GE0/2/0

172.17.3.2/24

注意事项

配置思路

采用如下的思路配置路由式ARP代理:

  1. 路由器连接用户主机侧的接口上需要配置IP地址,以实现用户侧链路连通。

  2. 路由器连接用户主机侧的接口上配置路由式ARP代理功能,使得主机发送一个ARP请求(请求目的主机的MAC地址),使能ARP代理功能的路由器收到这样的请求后,会使用自己的MAC地址作为该ARP请求的回应,以此进行数据转发。

  3. 在两台路由器之间需要配置默认路由,使得两个路由器之间能够有路由可达,数据报文能够正常传输。

数据准备

为完成此配置举例,需要准备如下数据:

  • 路由器用户主机侧接口的IP地址,Device A的接口IP地址为172.16.1.1/24,Device B的接口IP地址为172.16.2.1/24。

  • 路由器上的默认路由。

  • 用户主机的IP地址,Host A的IP地址为172.16.1.2/16,Host B的接口IP地址为172.16.2.2/16。

操作步骤

  1. 配置路由器DeviceA

    # 配置接口GE0/1/0的IP地址。

    <HUAWEI> system-view
    [~HUAWEI] sysname Device A
    [*HUAWEI] commit
    [~Device A] interface gigabitethernet 0/1/0
    [~Device A-GigabitEthernet0/1/0] ip address 172.16.1.1 255.255.255.0

    # 使能路由式ARP代理功能。

    [*Device A-GigabitEthernet0/1/0] arp-proxy enable
    [*Device A-GigabitEthernet0/1/0] undo shutdown
    [*Device A-GigabitEthernet0/1/0] quit

    # 配置静态路由。

    [*Device A] ip route-static 0.0.0.0 0 gigabitethernet 0/2/0 172.17.3.2

    # 配置接口GE0/2/0的IP地址。

    [*Device A] interface gigabitethernet 0/2/0
    [*Device A-GigabitEthernet0/2/0] ip address 172.17.3.1 255.255.255.0
    [*Device A-GigabitEthernet0/2/0] undo shutdown
    [*Device A-GigabitEthernet0/2/0] quit
    [*Device A] commit

  2. 配置路由器DeviceB

    # 配置接口GE0/1/0的IP地址。

    <HUAWEI> system-view
    [~HUAWEI] sysname DeviceB
    [*HUAWEI] commit
    [~Device B] interface gigabitethernet 0/1/0
    [~Device B-GigabitEthernet0/1/0] ip address 172.16.2.1 255.255.255.0

    # 使能路由式ARP代理功能。

    [*Device B-GigabitEthernet0/1/0] arp-proxy enable
    [*Device B-GigabitEthernet0/1/0] undo shutdown
    [*Device B-GigabitEthernet0/1/0] quit

    # 配置静态路由。

    [*Device B] ip route-static 0.0.0.0 0 gigabitethernet 0/2/0 172.17.3.1

    # 配置接口GE0/2/0的IP地址。

    [*Device B] interface gigabitethernet 0/2/0
    [*Device B-GigabitEthernet0/2/0] ip address 172.17.3.2 255.255.255.0
    [*Device B-GigabitEthernet0/2/0] undo shutdown
    [*Device B-GigabitEthernet0/2/0] quit
    [*Device B] commit

  3. 配置主机

    # 配置主机Host A的IP地址为172.16.1.2/16。

    # 配置主机Host B的IP地址为172.16.2.2/16。

  4. 验证配置结果

    # 主机Host A上ping主机Host B,可以通。

    # 查看Host A的ARP表,可以看到Host B所对应的MAC地址是Device A的接口GE0/1/0的MAC地址。

    C:\Documents and Settings\Administrator>arp -a
    Interface: 172.16.1.2 --- 0x2
      Internet Address      Physical Address      Type
      172.16.2.2            00e0-fc39-80aa        dynamic

配置文件

  • Device A的配置文件

    #
    sysname Device A
    #
    ip route-static 0.0.0.0 0.0.0.0 GigabitEthernet0/2/0 172.17.3.2
    #
     interface GigabitEthernet0/1/0
     undo shutdown
     ip address 172.16.1.1 255.255.255.0
     arp-proxy enable
    #
     interface GigabitEthernet0/2/0
     undo shutdown
     ip address 172.17.3.1 255.255.255.0
    #
    return
  • Device B的配置文件

    #
    sysname Device B
    #
    ip route-static 0.0.0.0 0.0.0.0 GigabitEthernet0/2/0 172.17.3.1
    #
     interface GigabitEthernet0/1/0
     undo shutdown
     ip address 172.16.2.1 255.255.255.0
     arp-proxy enable
    #
     interface GigabitEthernet0/2/0
     undo shutdown
     ip address 172.17.3.2 255.255.255.0
    #
    return
翻译
下载文档
更新时间:2018-12-29

文档编号:EDOC1100057893

浏览量:1665

下载量:11

平均得分:
本文档适用于这些产品
相关版本
相关文档
Share
上一页 下一页