所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

NE20E-S2 V800R010C10SPC500 配置指南 - IP业务 01

本文档是NE20E-S2 V800R010C10SPC500 配置指南 - IP业务
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置ARP与接口状态联动示例

配置ARP与接口状态联动示例

本举例介绍ARP与接口状态联动的配置过程。

组网需求

图2-11所示,DeviceA与DeviceB通过交换机相连。如果DeviceA与交换机相连的链路工作正常,DeviceB与交换机之间的链路出现故障。当DeviceA的interface1接口的物理状态与协议状态均为Up时,DeviceA感知不到DeviceB与交换机之间的链路故障,会继续通过交换机向DeviceB发送报文,但是被交换机丢弃。此时在DeviceA上使能ARP与接口状态联动功能,探测对端DeviceB的interface1接口状态。使DeviceA根据交换机与DeviceB的链路状态,迅速对interface1接口的协议状态作出调整。

图2-11 配置ARP与接口状态联动组网图
说明:

本示例中interface1代表GigabitEthernet0/1/1



配置思路

ARP与接口状态联动的配置思路如下:

  1. 配置接口的IP地址。

  2. 使能ARP与接口状态联动功能。

数据准备

为完成此配置举例,需要准备如下数据:

  • 接口的IP地址。

  • 接口发送ARP探测报文的目的IP地址。

操作步骤

  1. 配置接口的IP地址

    # 配置DeviceA。

    <HUAWEI> system-view
    [~HUAWEI] sysname DeviceA
    [*HUAWEI] commit
    [~DeviceA] interface gigabitethernet 0/1/1
    [~DeviceA-GigabitEthernet0/1/1] ip address 10.1.1.1 255.255.255.0
    [*DeviceA-GigabitEthernet0/1/1] undo shutdown
    [*DeviceA-GigabitEthernet0/1/1] commit
    [~DeviceA-GigabitEthernet0/1/1] quit

    # 配置DeviceB。

    <HUAWEI> system-view
    [~HUAWEI] sysname DeviceB
    [*HUAWEI] commit
    [~DeviceB] interface gigabitethernet 0/1/1
    [~DeviceB-GigabitEthernet0/1/1] ip address 10.1.1.2 255.255.255.0
    [*DeviceB-GigabitEthernet0/1/1] undo shutdown
    [*DeviceB-GigabitEthernet0/1/1] commit
    [~DeviceB-GigabitEthernet0/1/1] quit

    # 在DeviceA上执行Ping命令,确认到DeviceB的GigabitEthernet0/1/1接口是可达的。

    [~DeviceA] ping 10.1.1.2
      PING 10.1.1.2: 56  data bytes, press CTRL_C to break
        Reply from 10.1.1.2: bytes=56 Sequence=1 ttl=255 time=62 ms
        Reply from 10.1.1.2: bytes=56 Sequence=2 ttl=255 time=1 ms
        Reply from 10.1.1.2: bytes=56 Sequence=3 ttl=255 time=1 ms
        Reply from 10.1.1.2: bytes=56 Sequence=4 ttl=255 time=2 ms
        Reply from 10.1.1.2: bytes=56 Sequence=5 ttl=255 time=2 ms
    
      --- 10.1.1.2 ping statistics ---
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
        round-trip min/avg/max = 1/13/62 ms

    # 在DeviceA和DeviceB上分别执行display interface命令查看GigabitEthernet0/1/1接口状态,可以确认接口的物理状态和协议状态均为Up。

    [~DeviceA] display interface gigabitethernet 0/1/1
    GigabitEthernet0/1/1 current state : UP (ifindex: 9)
    Line protocol current state : UP 
    Last line protocol up time : 2018-01-24 11:03:06
    Link quality grade : GOOD
    Description: 
    Route Port,The Maximum Transmit Unit is 1500 
    Internet Address is 10.1.1.1/24
    IP Sending Frames' Format is PKTFMT_ETHNT_2, Hardware address is 3892-6c21-0302
    Loopback:none, LAN full-duplex mode, Pause Flowcontrol: Receive Enable and Send Enable
    Last physical up time   : 2018-01-24 09:00:21
    Last physical down time : 2018-01-24 08:58:14
    Current system time: 2018-01-24 11:22:58
    Statistics last cleared:never
        Last 300 seconds input rate: 0 bits/sec, 0 packets/sec
        Last 300 seconds output rate: 0 bits/sec, 0 packets/sec
        Input peak rate 0 bits/sec, Record time: -
        Output peak rate 0 bits/sec, Record time: -
        Input: 0 bytes, 1254 packets
        Output: 0 bytes, 1261 packets
        Input: 
          Unicast: 10 packets, Multicast: 46 packets
          Broadcast: 1198 packets, JumboOctets: 0 packets
          CRC: 0 packets, Symbol: 0 packets
          Overrun: 0 packets, InRangeLength: 0 packets
          LongPacket: 0 packets, Jabber: 0 packets, Alignment: 0 packets
          Fragment: 0 packets, Undersized Frame: 0 packets
          RxPause: 0 packets
        Output:
          Unicast: 11 packets, Multicast: 46 packets
          Broadcast: 1204 packets, JumboOctets: 0 packets
          Lost: 0 packets, Overflow: 0 packets, Underrun: 0 packets
          System: 0 packets, Overruns: 0 packets
          TxPause: 0 packets
        Last 300 seconds input utility rate:  0.00%
        Last 300 seconds output utility rate: 0.00%
    [~DeviceB] display interface gigabitethernet 0/1/1
    GigabitEthernet0/1/1 current state : UP (ifindex: 9)
    Line protocol current state : UP 
    Last line protocol up time : 2018-01-24 11:03:28
    Link quality grade : GOOD
    Description: 
    Route Port,The Maximum Transmit Unit is 1500 
    Internet Address is 10.1.1.2/24
    IP Sending Frames' Format is PKTFMT_ETHNT_2, Hardware address is 3892-6c41-0302
    Loopback:none, LAN full-duplex mode, Pause Flowcontrol: Receive Enable and Send Enable
    Last physical up time   : 2018-01-24 09:00:22
    Last physical down time : 2018-01-24 09:00:21
    Current system time: 2018-01-24 11:23:25
    Statistics last cleared:never
        Last 300 seconds input rate: 0 bits/sec, 0 packets/sec
        Last 300 seconds output rate: 0 bits/sec, 0 packets/sec
        Input peak rate 0 bits/sec, Record time: -
        Output peak rate 0 bits/sec, Record time: -
        Input: 0 bytes, 1262 packets
        Output: 0 bytes, 1255 packets
        Input: 
          Unicast: 11 packets, Multicast: 47 packets
          Broadcast: 1204 packets, JumboOctets: 0 packets
          CRC: 0 packets, Symbol: 0 packets
          Overrun: 0 packets, InRangeLength: 0 packets
          LongPacket: 0 packets, Jabber: 0 packets, Alignment: 0 packets
          Fragment: 0 packets, Undersized Frame: 0 packets
          RxPause: 0 packets
        Output:
          Unicast: 10 packets, Multicast: 47 packets
          Broadcast: 1198 packets, JumboOctets: 0 packets
          Lost: 0 packets, Overflow: 0 packets, Underrun: 0 packets
          System: 0 packets, Overruns: 0 packets
          TxPause: 0 packets
        Last 300 seconds input utility rate:  0.00%
        Last 300 seconds output utility rate: 0.00%

  2. 模拟接口故障

    # 在DeviceB的GigabitEthernet0/1/1接口执行shutdown命令。

    [~DeviceB] interface gigabitethernet 0/1/1
    [~DeviceB-GigabitEthernet0/1/1] shutdown
    [*DeviceB-GigabitEthernet0/1/1] commit
    [~DeviceB-GigabitEthernet0/1/1] quit

    # 在DeviceA上执行display interface命令查看GigabitEthernet0/1/1接口状态,可以确认接口的物理状态和协议状态均为Up。

    [~DeviceA] display interface gigabitethernet 0/1/1
    GigabitEthernet0/1/1 current state : UP (ifindex: 9)
    Line protocol current state : UP 
    Last line protocol up time : 2018-01-24 11:03:06
    Link quality grade : GOOD
    Description: 
    Route Port,The Maximum Transmit Unit is 1500 
    Internet Address is 10.1.1.1/24
    IP Sending Frames' Format is PKTFMT_ETHNT_2, Hardware address is 3892-6c21-0302
    Loopback:none, LAN full-duplex mode, Pause Flowcontrol: Receive Enable and Send Enable
    Last physical up time   : 2018-01-24 09:00:21
    Last physical down time : 2018-01-24 08:58:14
    Current system time: 2018-01-24 11:25:18
    Statistics last cleared:never
        Last 300 seconds input rate: 0 bits/sec, 0 packets/sec
        Last 300 seconds output rate: 0 bits/sec, 0 packets/sec
        Input peak rate 0 bits/sec, Record time: -
        Output peak rate 0 bits/sec, Record time: -
        Input: 0 bytes, 1254 packets
        Output: 0 bytes, 1261 packets
        Input: 
          Unicast: 10 packets, Multicast: 46 packets
          Broadcast: 1198 packets, JumboOctets: 0 packets
          CRC: 0 packets, Symbol: 0 packets
          Overrun: 0 packets, InRangeLength: 0 packets
          LongPacket: 0 packets, Jabber: 0 packets, Alignment: 0 packets
          Fragment: 0 packets, Undersized Frame: 0 packets
          RxPause: 0 packets
        Output:
          Unicast: 11 packets, Multicast: 46 packets
          Broadcast: 1204 packets, JumboOctets: 0 packets
          Lost: 0 packets, Overflow: 0 packets, Underrun: 0 packets
          System: 0 packets, Overruns: 0 packets
          TxPause: 0 packets
        Last 300 seconds input utility rate:  0.00%
        Last 300 seconds output utility rate: 0.00%

    # 在DeviceA上执行Ping命令,确认到DeviceB的GigabitEthernet0/1/1接口不可达。

    [~DeviceA] ping 10.1.1.2
      PING 10.1.1.2: 56  data bytes, press CTRL_C to break
        Request time out
        Request time out
        Request time out
        Request time out
        Request time out
    
      --- 10.1.1.2 ping statistics ---
        5 packet(s) transmitted
        0 packet(s) received
        100.00% packet loss

  3. 在DeviceA上使能ARP与接口状态联动功能

    # 使能DeviceA的接口发送ARP探测报文。

    [~DeviceA] interface gigabitethernet 0/1/1
    [~DeviceA-GigabitEthernet0/1/1] arp status-detect 10.1.1.2
    [*DeviceA-GigabitEthernet0/1/1] commit
    [~DeviceA-GigabitEthernet0/1/1] quit

  4. 检查配置结果

    # 等待探测时间后,DeviceA的GigabitEthernet0/1/1接口状态为Up,协议状态变为Down。

    [~DeviceA] display interface gigabitethernet 0/1/1
    GigabitEthernet0/1/1 current state : UP (ifindex: 9)
    Line protocol current state : DOWN 
    Link quality grade : GOOD
    Description: 
    Route Port,The Maximum Transmit Unit is 1500 
    Internet Address is 10.1.1.1/24
    IP Sending Frames' Format is PKTFMT_ETHNT_2, Hardware address is 3892-6c21-0302
    Loopback:none, LAN full-duplex mode, Pause Flowcontrol: Receive Enable and Send Enable
    Last physical up time   : 2018-01-24 12:03:24
    Last physical down time : 2018-01-24 11:40:45
    Current system time: 2018-01-24 12:06:25
    Statistics last cleared:never
        Last 300 seconds input rate: 0 bits/sec, 0 packets/sec
        Last 300 seconds output rate: 0 bits/sec, 0 packets/sec
        Input peak rate 0 bits/sec, Record time: -
        Output peak rate 0 bits/sec, Record time: -
        Input: 0 bytes, 1354 packets
        Output: 0 bytes, 1370 packets
        Input: 
          Unicast: 64 packets, Multicast: 91 packets
          Broadcast: 1199 packets, JumboOctets: 0 packets
          CRC: 0 packets, Symbol: 0 packets
          Overrun: 0 packets, InRangeLength: 0 packets
          LongPacket: 0 packets, Jabber: 0 packets, Alignment: 0 packets
          Fragment: 0 packets, Undersized Frame: 0 packets
          RxPause: 0 packets
        Output:
          Unicast: 12 packets, Multicast: 90 packets
          Broadcast: 1268 packets, JumboOctets: 0 packets
          Lost: 0 packets, Overflow: 0 packets, Underrun: 0 packets
          System: 0 packets, Overruns: 0 packets
          TxPause: 0 packets
        Last 300 seconds input utility rate:  0.00%
        Last 300 seconds output utility rate: 0.00%

配置文件

  • DeviceA的配置文件

    #
    sysname DeviceA
    #
    interface GigabitEthernet0/1/1
     undo shutdown  
     ip address 10.1.1.1 255.255.255.0
     arp status-detect 10.1.1.2
    #
    return
  • DeviceB的配置文件

    #
    sysname DeviceB
    #
    interface GigabitEthernet0/1/1
     undo shutdown  
     ip address 10.1.1.2 255.255.255.0
    #
    return
翻译
下载文档
更新时间:2018-12-29

文档编号:EDOC1100057893

浏览量:1490

下载量:11

平均得分:
本文档适用于这些产品
相关版本
相关文档
Share
上一页 下一页