所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

NE20E-S2 V800R010C10SPC500 配置指南 - IP业务 01

本文档是NE20E-S2 V800R010C10SPC500 配置指南 - IP业务
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置本地ARP代理示例

配置本地ARP代理示例

从典型的应用场景描述了在EVC场景下如何通过配置ARP本地代理功能实现同一个BD内相互隔离的两个成员口之间相互通信。

组网需求

在EVC模型中,BD是一个广播域,BD的成员口收到报文后会在广播域内广播。为了减少广播,网络管理员通常会在没有互通需求的成员口上配置水平分割功能,使得BD内的指定用户之间相互隔离,无法二层互通。

图2-10所示,网络管理者已经规划HostA和HostB之间不能互相通信,因此在PE上配置了BD内的水平分割功能。但是随着用户业务的不断扩展,HostA和HostB之间会不断有互通的需求,此时网络管理者可以在VBDIF接口上使能本地ARP代理功能,实现HostA和HostB间的相互通信。

图2-10 配置本地ARP代理组网图
说明:

本例中interface1,interface2分别代表GE0/1/1,GE0/1/2


注意事项

使能本地ARP代理功能之后,BD内的所有用户之间将能够互相通信。如果网络规划仅希望对BD内的部分用户开放互通功能,建议用户对需要开放互通的成员口执行undo split-horizon enable命令,取消水平分割功能。

配置思路

采用如下的思路配置本地ARP代理功能:

  1. 分别在CE上配置二层转发功能。

    1. 在CE上创建VLAN,将CE的下行口加入VLAN,确定业务所属的VLAN。
    2. 在CE的上行口上配置二层转发功能,使得CE发往PE的报文带有一层VLAN Tag。
  2. 在PE上搭建EVC模型:
    1. 配置广播域BD,用来转发业务。
    2. 创建二层子接口,并加入BD,同时在下行口配置流封装,以实现业务接入点接入业务。
    3. 配置BD内的水平分割功能,使HostA和HostB之间不能二层互通。
  3. 在PE上配置本地ARP代理功能:
    1. 创建VBDIF接口,并配置VBDIF接口的IP地址。
    2. 使能本地ARP代理功能,实现HostA和HostB之间互通。

数据准备

为完成此配置例,需准备如下的数据:
  • 用户所属的VLAN ID。
  • CE设备连接用户的接口编号、CE与PE之间连接的接口编号。
  • 广播域BD ID、流封装类型和流动作。
  • VBDIF接口编号和IP地址。

操作步骤

  1. 在CE上配置二层转发功能

    # 配置CE1。

    <HUAWEI> system-view
    [~HUAWEI] sysname CE1
    [*HUAWEI] commit
    [~CE1] vlan 10
    [*CE1-vlan10] quit
    [*CE1] interface gigabitethernet 0/1/1
    [*CE1-GigabitEthernet0/1/1] undo shutdown
    [*CE1-GigabitEthernet0/1/1] portswitch
    [*CE1-GigabitEthernet0/1/1] port link-type access
    [*CE1-GigabitEthernet0/1/1] port default vlan 10
    [*CE1-GigabitEthernet0/1/1] quit
    [*CE1] interface gigabitethernet 0/1/2
    [*CE1-GigabitEthernet0/1/2] undo shutdown
    [*CE1-GigabitEthernet0/1/2] portswitch
    [*CE1-GigabitEthernet0/1/2] port link-type trunk
    [*CE1-GigabitEthernet0/1/2] port trunk allow-pass vlan 10
    [*CE1-GigabitEthernet0/1/2] commit
    [~CE1-GigabitEthernet0/1/2] quit

    # 配置CE2。

    <HUAWEI> system-view
    [~HUAWEI] sysname CE2
    [*HUAWEI] commit
    [~CE2] vlan 10
    [*CE2-vlan10] quit
    [*CE2] interface gigabitethernet 0/1/1
    [*CE2-GigabitEthernet0/1/1] undo shutdown
    [*CE2-GigabitEthernet0/1/1] portswitch
    [*CE2-GigabitEthernet0/1/1] port link-type access
    [*CE2-GigabitEthernet0/1/1] port default vlan 10
    [*CE2-GigabitEthernet0/1/1] quit
    [*CE2] interface gigabitethernet 0/1/2
    [*CE2-GigabitEthernet0/1/2] undo shutdown
    [*CE2-GigabitEthernet0/1/2] portswitch
    [*CE2-GigabitEthernet0/1/2] port link-type trunk
    [*CE2-GigabitEthernet0/1/2] port trunk allow-pass vlan 10
    [*CE2-GigabitEthernet0/1/2] commit
    [~CE2-GigabitEthernet0/1/2] quit

  2. 在PE上搭建EVC模型

    # 创建BD。

    <HUAWEI> system-view
    [~HUAWEI] sysname PE
    [*HUAWEI] commit
    [~PE] bridge-domain 10
    [*PE-bd10] quit

    # 创建二层子接口并加入BD,同时在下行口配置流封装。

    [*PE] interface gigabitethernet 0/1/1
    [*PE-GigabitEthernet0/1/1] undo shutdown
    [*PE-GigabitEthernet0/1/1] quit
    [*PE] interface gigabitethernet 0/1/1.1 mode l2
    [*PE-GigabitEthernet0/1/1.1] encapsulation dot1q vid 10
    [*PE-GigabitEthernet0/1/1.1] rewrite pop single
    [*PE-GigabitEthernet0/1/1.1] bridge-domain 10
    [*PE-GigabitEthernet0/1/1.1] commit
    [~PE-GigabitEthernet0/1/1] quit
    [~PE] interface gigabitethernet 0/1/2
    [~PE-GigabitEthernet0/1/2] undo shutdown
    [*PE-GigabitEthernet0/1/2] quit
    [*PE] interface gigabitethernet 0/1/2.1 mode l2
    [*PE-GigabitEthernet0/1/2.1] encapsulation dot1q vid 10
    [*PE-GigabitEthernet0/1/2.1] rewrite pop single
    [*PE-GigabitEthernet0/1/2.1] bridge-domain 10
    [*PE-GigabitEthernet0/1/2.1] commit
    [~PE-GigabitEthernet0/1/2] quit
    # 在HostA上pingHostB的IP地址,可以正常ping通。
    c:\>ping 10.110.10.2
    
    Pinging 10.110.10.2 with 32 bytes of data:
    Reply from 10.110.10.2: bytes=32 time<1ms TTL=128
    Reply from 10.110.10.2: bytes=32 time<1ms TTL=128
    Reply from 10.110.10.2: bytes=32 time<1ms TTL=128
    Reply from 10.110.10.2: bytes=32 time<1ms TTL=128
    
    Ping statistics for 10.110.10.2:
        Packets: Sent = 4, Received = 4, Lost = 0 <0% loss>,
    Approximate round trip times in mill-seconds:
        Minimum = 0ms, Maximum = 0ms, Average = 0ms

    # 配置BD内的水平分割功能。

    [~PE] bridge-domain 10
    [*PE-bd-10] split-horizon enable
    [*PE-bd-10] quit
    [*PE] commit
    # 在HostA上pingHostB的IP地址,无法ping通。
    c:\>ping 10.110.10.2
    
    Pinging 10.110.10.2 with 32 bytes of data:
    Request timed out.
    Request timed out.
    Request timed out.
    Request timed out.
    
    Ping statistics for 10.110.10.2:
        Pacets: Sent = 4, Received = 0, Lost = 4 <100% loss>,

  3. 在PE上配置本地ARP代理功能

    # 创建VBDIF接口,配置VBDIF接口的IP地址。

    [~PE] interface vbdif 10
    [*PE-Vbdif10] ip address 10.110.10.3 255.255.255.0

    # 使能本地ARP代理功能。

    [*PE-Vbdif10] arp-proxy local enable
    [*PE-Vbdif10] commit

  4. 验证配置结果

    上述配置完成后,在HostA上pingHostB的IP地址,可以正常ping通。
    c:\>ping 10.110.10.2
    
    Pinging 10.110.10.2 with 32 bytes of data:
    Reply from 10.110.10.2: bytes=32 time<1ms TTL=128
    Reply from 10.110.10.2: bytes=32 time<1ms TTL=128
    Reply from 10.110.10.2: bytes=32 time<1ms TTL=128
    Reply from 10.110.10.2: bytes=32 time<1ms TTL=128
    
    Ping statistics for 10.110.10.2:
        Packets: Sent = 4, Received = 4, Lost = 0 <0% loss>,
    Approximate round trip times in mill-seconds:
        Minimum = 0ms, Maximum = 0ms, Average = 0ms

    执行命令display bridge-domain命令,可以查看到二层子接口加入的BD、BD的状态等信息。

    [~PE] display bridge-domain
    The total number of bridge-domains is : 1
    --------------------------------------------------------------------------------
    MAC_LRN: MAC learning;         STAT: Statistics;         SPLIT: Split-horizon;
    BC: Broadcast;                 MC: Unknown multicast;    UC: Unknown unicast;
    *down: Administratively down;  FWD: Forward;             DSD: Discard;
    --------------------------------------------------------------------------------
    
    BDID  State MAC-LRN STAT    BC  MC  UC  SPLIT   Description
    --------------------------------------------------------------------------------
    10    up    enable  disable FWD FWD FWD enable

配置文件

  • PE的配置文件

    #
    sysname PE
    #
    vlan batch 10
    #
    bridge-domain 10
     split-horizon enable
    #
    interface Vbdif10
     undoshutdown
     ip address 10.110.10.3 255.255.255.0
     arp-proxy local enable
    #
    interface GigabitEthernet0/1/1
     undo shutdown
    #
    interface GigabitEthernet0/1/1.1 mode l2
     encapsulation dot1q vid 10
     rewrite pop single
     bridge-domain 10
    #
    interface GigabitEthernet0/1/2
     undo shutdown
    #
    interface GigabitEthernet0/1/2.1 mode l2
     encapsulation dot1q vid 10
     rewrite pop single
     bridge-domain 10
    #
    return
  • CE1的配置文件

    #
    sysname CE1
    #
    vlan batch 10
    #
    interface GigabitEthernet0/1/1
     portswitch
     undo shutdown
     port link-type access
     port default vlan 10
    #
    interface GigabitEthernet0/1/2
     portswitch
     undo shutdown
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    return
  • CE2的配置文件

    #
    sysname CE1
    #
    vlan batch 10
    #
    interface GigabitEthernet0/1/1
     portswitch
     undo shutdown
     port link-type access
     port default vlan 10
    #
    interface GigabitEthernet0/1/2
     portswitch
     undo shutdown
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    return
翻译
下载文档
更新时间:2018-12-29

文档编号:EDOC1100057893

浏览量:1587

下载量:11

平均得分:
本文档适用于这些产品
相关版本
相关文档
Share
上一页 下一页