所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

NE20E-S2 V800R010C10SPC500 配置指南 - IP业务 01

本文档是NE20E-S2 V800R010C10SPC500 配置指南 - IP业务
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置VLAN内ARP代理示例

配置VLAN内ARP代理示例

本示例组网的特点是需要互通的设备处于相同的VLAN,但是设备间配置了端口隔离,通过配置VLAN内的ARP代理功能,实现设备间的互通。

组网需求

图2-8所示,设备CE连接到PE的子接口Eth-Trunk1.1上,子接口Eth-Trunk1.1配置为关联VLAN10。

Host A和Host B是CE下的两个用户,连接Host A和Host B的两个端口在CE上属于同一个VLAN,且在CE上配置了VLAN内不同端口间彼此隔离。

在PE的Eth-Trunk1.1上使能VLAN内的ARP代理,实现Host A和Host B的互通。

图2-8 配置VLAN内ARP代理组网图
说明:

本例中interface1,interface2分别代表GE0/1/1,GE0/1/2



配置思路

VLAN内ARP代理的配置思路如下:

  1. 在CE上创建VLAN,确定用户所属的VLAN,使得需要互通的用户处于相同的VLAN。

  2. 配置PE上创建接口Eth-Trunk1.1,并配置IP地址,作为网关地址。

  3. 配置接口Eth-Trunk1.1关联VLAN 10。

  4. 配置Eth-Trunk1.1在VLAN 10内启动ARP代理,使得隔离的用户间可以互通。

数据准备

为完成此配置举例,需要准备如下数据:

  • 用户主机所属的VLAN为VLAN 10.

  • Eth-Trunk1.1接口的IP地址为10.10.10.1/24。

  • Eth-Trunk1.1接口关联的VLAN为VLAN 10。

  • 用户主机的IP地址,Host A的IP地址为10.10.10.2/24,HostB的接口IP地址为10.10.10.3/24。

操作步骤

  1. 在CE上创建VLAN,确定用户所属的VLAN

    <HUAWEI> system-view
    [~HUAWEI] sysname CE
    [*HUAWEI] commit
    [~CE] vlan 10
    [*CE-vlan 10] commit
    [~CE-vlan 10] quit
    [~CE] interface gigabitethernet 0/1/1
    [~CE-GigabitEthernet0/1/1] portswitch
    [*CE-GigabitEthernet0/1/1] undo shutdown
    [*CE-GigabitEthernet0/1/1] port default vlan 10
    [*CE-GigabitEthernet0/1/1] commit
    [~CE-GigabitEthernet0/1/1] quit
    [~CE] interface gigabitethernet 0/1/2
    [~CE-0/1/2] portswitch
    [*CE-0/1/2] undo shutdown
    [*CE-0/1/2] port default vlan 10
    [*CE-0/1/2] commit
    [~CE-0/1/2] quit

  2. 配置PE上创建接口Eth-Trunk1.1,并配置IP地址

    <HUAWEI> system-view
    [~HUAWEI] sysname PE
    [*HUAWEI] commit
    [~PE] interface eth-trunk 1.1
    [*PE-Eth-Trunk1.1] ip address 10.10.10.1 255.255.255.0
    [*PE-Eth-Trunk1.1] commit

  3. 配置Host A和Host B的IP地址

    # 分别为Host A和Host B配置IP地址,并使它们和Eth-Trunk1.1的地址处于同一网段。

    配置成功后,Host A和Host B分别与PE可以相互Ping通,但Host A和Host B之间不能相互Ping通。

  4. 配置接口Eth-Trunk1.1关联VLAN 10

    [~PE-Eth-Trunk1.1] vlan-type dot1q 10
    [*PE-Eth-Trunk1.1] commit

  5. 配置Eth-Trunk1.1在VLAN 10内启动ARP代理

    [~PE-Eth-Trunk1.1] arp-proxy inner-sub-vlan-proxy enable
    [*PE-Eth-Trunk1.1] commit

  6. 验证配置结果

    Host A和Host B可以相互Ping通。

配置文件

  • PE的配置文件

    #
    sysname PE
    #
    interface Eth-Trunk1
     undo shutdown
    #
    interface Eth-Trunk1.1
     undo shutdown
     vlan-type dot1q 10
     ip address 10.10.10.1 255.255.255.0
     arp-proxy inner-sub-vlan-proxy enable
    #
    return
  • CE的配置文件

    #
    sysname CE
    #
    interface GigabitEthernet0/1/1
     portswitch
     undo shutdown
     port default vlan 10
    #
    interface GigabitEthernet0/1/2
     portswitch
     undo shutdown
     port default vlan 10
    #
    return
翻译
下载文档
更新时间:2018-12-29

文档编号:EDOC1100057893

浏览量:1436

下载量:11

平均得分:
本文档适用于这些产品
相关版本
相关文档
Share
上一页 下一页