所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

NE20E-S2 V800R010C10SPC500 配置指南 - IP业务 01

本文档是NE20E-S2 V800R010C10SPC500 配置指南 - IP业务
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置IP报文转发的接口非等价负载分担示例

配置IP报文转发的接口非等价负载分担示例

本举例介绍IP报文转发的接口非等价负载分担的配置过程。

组网需求

图10-2所示,DeviceA和DeviceE之间通过三条链路连接,这三条链路分别经过DeviceB、DeviceC和DeviceD。现在要在DeviceA到DeviceE的这三条链路上实现非等价负载分担。该举例中的非等价负载分担特指接口非等价负载分担。

图10-2 配置非等价负载分担示例
说明:

本例的配置在DeviceA、DeviceB、DeviceC、DeviceD、DeviceE设备上进行,HUAWEI NE20E-S2可以做为DeviceA、DeviceB、DeviceC、DeviceD、DeviceE设备。



设备名称 接口名称 IP地址
DeviceA GE0/1/8 10.30.1.1/24
GE0/3/0 10.40.1.1/24
GE0/2/0 10.50.1.1/24
DeviceB GE0/1/0 10.30.1.2/24
GE0/2/0 10.60.1.2/24
DeviceC GE0/1/0 10.40.1.2/24
GE0/2/0 10.70.1.2/24
DeviceD GE0/1/0 10.50.1.2/24
GE0/2/0 10.80.1.2/24
DeviceE GE0/1/8 10.60.1.1/24
GE0/3/0 10.70.1.1/24
GE0/2/0 10.80.1.1/24

配置思路

采用如下的思路配置非等价负载分担:

  1. 在各路由器上配置IGP,本示例中以IS-IS为例。

  2. DeviceA各接口上使能非等价负载分担功能,使DeviceA和DeviceE之间的流量基于不同的链路进行非等价负载分担。

数据准备

完成此配置,需准备如下的数据:

  • 接口类型和接口编号

  • 接口的IP地址

  • 路由器的IS-IS区域号和级别

操作步骤

  1. 配置各接口的IP地址(略)
  2. 配置IS-IS的基本功能

    # 配置DeviceA。

    [~DeviceA] isis 1
    [*DeviceA-isis-1] is-level level-1
    [*DeviceA-isis-1] network-entity 10.0000.0000.0001.00
    [*DeviceA-isis-1] commit
    [~DeviceA-isis-1] quit
    [~DeviceA] interface gigabitethernet 0/1/0
    [~DeviceA-GigabitEthernet0/1/0] isis enable 1
    [*DeviceA-GigabitEthernet0/1/0] quit
    [*DeviceA] interface gigabitethernet 0/2/0
    [*DeviceA-GigabitEthernet0/2/0] isis enable 1
    [*DeviceA-GigabitEthernet0/2/0] quit
    [*DeviceA] interface gigabitethernet 0/1/8
    [*DeviceA-GigabitEthernet0/1/8] isis enable 1
    [*DeviceA-GigabitEthernet0/1/8] quit
    [*DeviceA] interface gigabitethernet 0/3/0
    [*DeviceA-GigabitEthernet0/3/0] isis enable 1
    [*DeviceA-GigabitEthernet0/3/0] quit
    [*DeviceA] commit

    # 配置DeviceB。

    [~DeviceB] isis 1
    [*DeviceB-isis-1] is-level level-1
    [*DeviceB-isis-1] network-entity 10.0000.0000.0002.00
    [*DeviceB-isis-1] commit
    [~DeviceB-isis-1] quit
    [~DeviceB] interface gigabitethernet 0/1/0
    [~DeviceB-GigabitEthernet0/1/0] isis enable 1
    [*DeviceB-GigabitEthernet0/1/0] quit
    [*DeviceB] interface gigabitethernet 0/2/0
    [*DeviceB-GigabitEthernet0/2/0] isis enable 1
    [*DeviceB-GigabitEthernet0/2/0] quit
    [*DeviceB] commit

    # 配置DeviceC。

    [~DeviceC] isis 1
    [*DeviceC-isis-1] is-level level-1
    [*DeviceC-isis-1] network-entity 10.0000.0000.0003.00
    [*DeviceC-isis-1] commit
    [~DeviceC-isis-1] quit
    [~DeviceC] interface gigabitethernet 0/1/0
    [~DeviceC-GigabitEthernet0/1/0] isis enable 1
    [*DeviceC-GigabitEthernet0/1/0] quit
    [*DeviceC] interface gigabitethernet 0/2/0
    [*DeviceC-GigabitEthernet0/2/0] isis enable 1
    [*DeviceC-GigabitEthernet0/2/0] quit
    [*DeviceC] commit

    # 配置DeviceD。

    [~DeviceD] isis 1
    [*DeviceD-isis-1] is-level level-1
    [*DeviceD-isis-1] network-entity 10.0000.0000.0004.00
    [*DeviceD-isis-1] commit
    [~DeviceD-isis-1] quit
    [~DeviceD] interface gigabitethernet 0/1/0
    [~DeviceD-GigabitEthernet0/1/0] isis enable 1
    [*DeviceD-GigabitEthernet0/1/0] quit
    [*DeviceD] interface gigabitethernet 0/2/0
    [*DeviceD-GigabitEthernet0/2/0] isis enable 1
    [*DeviceD-GigabitEthernet0/2/0] quit
    [*DeviceD] commit

    # 配置DeviceE。

    [~DeviceE] isis 1
    [*DeviceE-isis-1] is-level level-1
    [*DeviceE-isis-1] network-entity 10.0000.0000.0005.00
    [*DeviceE-isis-1] commit
    [~DeviceE-isis-1] quit
    [~DeviceE] interface gigabitethernet 0/1/0
    [~DeviceE-GigabitEthernet0/1/0] isis enable 1
    [*DeviceE-GigabitEthernet0/1/0] quit
    [*DeviceE] interface gigabitethernet 0/2/0
    [*DeviceE-GigabitEthernet0/2/0] isis enable 1
    [*DeviceE-GigabitEthernet0/2/0] quit
    [*DeviceE] interface gigabitethernet 0/1/8
    [*DeviceE-GigabitEthernet0/1/8] isis enable 1
    [*DeviceE-GigabitEthernet0/1/8] quit
    [*DeviceE] interface gigabitethernet 0/3/0
    [*DeviceE-GigabitEthernet0/3/0] isis enable 1
    [*DeviceE-GigabitEthernet0/3/0] quit
    [*DeviceE] commit

  3. 检查IS-IS基本配置

    # 在DeviceA上查看IS-IS的路由信息。

    [~DeviceA] display isis route
                Route information for ISIS(1)
                      -----------------------------
    
                      ISIS(1) Level-1 Forwarding Table
                      --------------------------------
    
     IPV4 Destination     IntCost    ExtCost ExitInterface       NextHop         Flags
    --------------------------------------------------------------------------------
     10.1.1.0/24              10         NULL    GE0/1/0         Direct          D/-/L/-/-
     10.20.1.0/24              30         NULL    GE0/3/0         10.40.1.2        A/-/-/-/C
                                                 GE0/2/0         10.50.1.2
                                                 GE0/1/8        10.30.1.2
     10.30.1.0/24              10         NULL    GE0/1/8        Direct          D/-/L/-/-
     10.40.1.0/24              10         NULL    GE0/3/0         Direct          D/-/L/-/-
     10.50.1.0/24              10         NULL    GE0/2/0         Direct          D/-/L/-/-
     10.60.1.0/24              20         NULL    GE0/1/8        10.30.1.2        R/-/-
     10.70.1.0/24              20         NULL    GE0/3/0         10.40.1.2        A/-/-/-/-
     10.80.1.0/24              20         NULL    GE0/2/0         10.50.1.2        R/-/-
         Flags: D-Direct, A-Added to URT, L-Advertised in LSPs, S-IGP Shortcut,
                           U-Up/Down Bit Set, C-In Computing
    

    # 此时在DeviceA上可以ping通10.20.1.1,从NM Station(Network Management Station)上可以看到各个出接口上实现了等价负载分担。

    <DeviceA> ping 10.20.1.1
      PING 10.20.1.1: 56  data bytes, press CTRL_C to break
        Reply from 10.20.1.1: bytes=56 Sequence=1 ttl=254 time=16 ms
        Reply from 10.20.1.1: bytes=56 Sequence=2 ttl=254 time=1 ms
        Reply from 10.20.1.1: bytes=56 Sequence=3 ttl=254 time=1 ms
        Reply from 10.20.1.1: bytes=56 Sequence=4 ttl=254 time=1 ms
        Reply from 10.20.1.1: bytes=56 Sequence=5 ttl=254 time=64 ms
    
        --- 10.20.1.1 ping statistics ---
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
        round-trip min/avg/max = 1/16/64 ms 
    

  4. DeviceA的各个出接口上使能非等价负载分担功能

    [~DeviceA] interface gigabitethernet 0/2/0
    [~DeviceA-GigabitEthernet0/2/0] load-balance unequal-cost enable
    [*DeviceA-GigabitEthernet0/2/0] quit
    [*DeviceA] interface gigabitethernet 0/1/8
    [*DeviceA-GigabitEthernet0/1/8] load-balance unequal-cost enable
    [*DeviceA-GigabitEthernet0/1/8] quit
    [*DeviceA] interface gigabitethernet 0/3/0
    [*DeviceA-GigabitEthernet0/3/0] load-balance unequal-cost enable
    [*DeviceA-GigabitEthernet0/3/0] quit
    [*DeviceA] commit

  5. 检查配置结果

    # 此时在DeviceA上仍可以ping通10.20.1.1,从NM Station(Network Management Station)上可以看到各个出接口上实现了非等价负载分担。

    <DeviceA> ping 10.20.1.1
      PING 10.20.1.1: 56  data bytes, press CTRL_C to break
        Reply from 10.20.1.1: bytes=56 Sequence=1 ttl=254 time=16 ms
        Reply from 10.20.1.1: bytes=56 Sequence=2 ttl=254 time=1 ms
        Reply from 10.20.1.1: bytes=56 Sequence=3 ttl=254 time=1 ms
        Reply from 10.20.1.1: bytes=56 Sequence=4 ttl=254 time=1 ms
        Reply from 10.20.1.1: bytes=56 Sequence=5 ttl=254 time=64 ms
    
      --- 10.20.1.1 ping statistics ---
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
        round-trip min/avg/max = 1/16/64 ms
    

配置文件

  • DeviceA的配置文件

    #
     sysname DeviceA
    #
    isis 1
     is-level level-1
     network-entity 10.0000.0000.0001.00
    #
    interface GigabitEthernet0/1/0
     undo shutdown
     ip address 10.1.1.1 255.255.255.0
     isis enable 1
    #
    interface GigabitEthernet0/2/0
     undo shutdown
     load-balance unequal-cost enable
     ip address 10.50.1.1 255.255.255.0
     isis enable 1
    #
    interface GigabitEthernet0/3/0
     undo shutdown
     load-balance unequal-cost enable
     ip address 10.40.1.1 255.255.255.0
     isis enable 1
    #
    interface GigabitEthernet0/1/8
    undo shutdown
     load-balance unequal-cost enable
     ip address 10.30.1.1 255.255.255.0
     isis enable 1
    #
    return
    
  • DeviceB的配置文件

    #
     sysname DeviceB
    #
    isis 1
     is-level level-1
     network-entity 10.0000.0000.0002.00
    #
    interface GigabitEthernet0/1/0
     undo shutdown
     ip address 10.30.1.2 255.255.255.0
     isis enable 1
    #
    interface GigabitEthernet0/2/0
     undo shutdown
     ip address 10.60.1.2 255.255.255.0
     isis enable 1
    #
    return
    
  • DeviceC的配置文件

    #
     sysname DeviceC
    #
    isis 1
    is-level level-1
     network-entity 10.0000.0000.0003.00
    #
    interface GigabitEthernet0/1/0
     undo shutdown
     ip address 10.40.1.2 255.255.255.0
     isis enable 1
    #
    interface GigabitEthernet0/2/0
     undo shutdown
     ip address 10.70.1.2 255.255.255.0
     isis enable 1
    #
    return
    
  • DeviceD的配置文件

    #
     sysname DeviceD
    #
    isis 1
     is-level level-1
     network-entity 10.0000.0000.0004.00
    #
    interface GigabitEthernet0/1/0
     undo shutdown
     ip address 10.50.1.2 255.255.255.0
     isis enable 1
    #
    interface GigabitEthernet0/2/0
     undo shutdown
     ip address 10.80.1.2 255.255.255.0
     isis enable 1
    #
    return
    
  • DeviceE的配置文件

    #
     sysname DeviceE
    #
    isis 1
     is-level level-1
     network-entity 10.0000.0000.0005.00
    #
    interface GigabitEthernet0/1/0
     undo shutdown
     ip address 10.20.1.1 255.255.255.0
     isis enable 1
    #
    interface GigabitEthernet0/2/0
     undo shutdown
     ip address 10.80.1.1 255.255.255.0
     isis enable 1
    #
    interface GigabitEthernet0/3/0
     undo shutdown
     ip address 10.70.1.1 255.255.255.0
     isis enable 1
    #
    interface GigabitEthernet0/1/8
     undo shutdown
     ip address 10.60.1.1 255.255.255.0
     isis enable 1
    #
    return
    
翻译
下载文档
更新时间:2018-12-29

文档编号:EDOC1100057893

浏览量:1651

下载量:11

平均得分:
本文档适用于这些产品
相关版本
相关文档
Share
上一页 下一页